nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   RH9 with Geforce 2, X issue (http://www.nvnews.net/vbulletin/showthread.php?t=11575)

Beez 05-10-03 05:51 PM

RH9 with Geforce 2, X issue
 
1 Attachment(s)
Machine is Intel 815, 256 Ram, GeForce 2 64Mb, Red Hat 9

Ran the installer (NVIDIA-Linux-x86-1.0-4363.run), everything installed fine and then I made the required changes to XF86Config as specified in the Nvidia README.

Machine will not start X when the driver is set to "nvidia" it will only work when it is "nv".

Have added the Option "NvAGP" "0" with "nvidia" to see if AGP is the issue, but it does not work. So it looks like the Nvidia driver is the issue not the AGP.

I have read on another site that Intel 815 with the Nvidia GeForce 2 on Linux might be a known issue but it didn't provide further detail. Did not see anything on this site to confirm that.

I am getting an error in XFree.86.0.log dealing with Failed to add GLX extension (Nvidia XFree86 driver not found). See attached file for full message

Beez 05-10-03 06:03 PM

1 Attachment(s)
Here is the XF86Config included.

In this version the driver is "nv" which will load X regardless of what NVAGP is. X will not load when driver is "nvidia", even is nvAGP is 0.

Beez 05-11-03 08:42 AM

Exact message in XFree86.0.log is:

(EE) [GLX]: Failed to add GLX extension (NVIDIA XFree86 driver not found)

Beez 05-12-03 08:36 AM

One last shameless bump before this post and my dreams of running the nvidia drivers float away :angel:

unclegus 05-13-03 02:31 PM

Darn, I had the same problem. I remember it having something to do with X finding the nv drivers that were part of the new X11 w/ RH9.0 and it wasn't finding the NVidia drivers ...

do you have

alias char-major-195 nvidia

in your /etc/modules.conf?

unclegus 05-13-03 02:48 PM

It's coming back to me ...

In /usr/X11R6/lib/modules/drivers I have nvidia_drv.o

There also exists nv_drv.o which I believe is XFRee86 implementation of nvidia driver for X11.

I can't recall how I got nvidia_drv.o in there?

I'm still pokin' around ....

alien999999999 05-14-03 07:17 AM

nvidia is the you should use.

but your problem is most likely a result of not finding the GLX library.

try adapting /etc/ld.so.conf so that it can find the libGLX.so file.

also an 'ldconfig' as root has been known to fix the error.

Beez 05-14-03 08:07 PM

Well I finally fixed it. When I installed Red Hat 9.0 last week (yes I'm a Linux newb), it was version 2.4.20-6. Well not knowing much, I saw the blinking red exclamation points for an update. So I updated to 2.4.20-9 (since then I've learned that odd numbered ending numbers are releases that aren't very stable and more for hip developers wanting to check out the latest and greatest....correct me if this is wrong).

So to get to the issue, when I ran the nvidia run program i did it on version .6 but when I updated the XFree86.0.log I did it on .9. Then when restarting I kept bringing up .9 which was giving me errors with the 'nvidia' line in the XFree86.0.log. So today I changed the .6 XFree86.0.log to 'nvidia' and restarted in .6 and voila everything is cool. So I removed .9 from my grub and try to avoid it.

I guess I don't quite understand why it doesn't work in .9 though. I mean XFree86.0.log is the same file regardless of which version I'm in right.? So was my only mistake not running the .run prog in .9? If that's the case do I need to redo all the driver stuff everytime I update? Sorry for the newb questions, but I am loving Linux so far and this little bit of help means a lot.

Thanks to all those that replied to my thread to help out!! :D

unclegus 05-15-03 06:54 AM

Yes, I believe you have to run the nvidia update script/exe when ever you upgrade your kernel.

Two points. The nvidia updater is pretty nice now in that it will download prebuilt drivers for your kernel version if they exist, or it will try to compile the drivers for your kernel version. Of course the later requires that you have the kernel source installed! I believe for RH the kernel source is not installed for their basic installations. You either have to install everything, do a custom install and select kernel source rpm or lastly find the kernel source rpm on your distribution media and install it your self.

The second point it for RH and their updater program, I believe you can tell it not to update and kernel packages automatically. You might try this to avoid accidentally updating your kernel without realizing it.

-Brad


All times are GMT -5. The time now is 01:56 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.