nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   boot console on gf2/mx400 tv-out (http://www.nvnews.net/vbulletin/showthread.php?t=1159)

token 08-26-02 09:11 AM

boot console on gf2/mx400 tv-out
 
Hi people.

I bought a GeForce2/MX400 64MB from XFX Graphics (a Pine division).

The card is working ok, except one thing (which is the main reason why i bought it): the README.TXT on the linux drivers says it will assume console on TV if a monitor is not detected on the first port. It's not happening... :(

I'm using S-Video (but it will not work with composite too), and i'm using original svideo cable (have tried with other too).

Once the machine is up, i can use TV, it will even assume the first head is the TV when without a monitor, but only when X starts (until there, i get just a black screen).

As you can see on this site:
http://www.ocmelbourne.com/articles/hepc/
this guy has made it with a
"Video Card - Nvidia Geforce 4 MX-420", if you go to the screenshots you'll see the machine booting (EPA logo and counting memory) on TV.

Is that an exclusive feature of GeForce4, or should i return this Pine one and get another brand?

Thanks,

Thunderbird 08-26-02 10:06 AM

Direct booting from tv is only possible I thought if you use a composite connection on the card. (not using a convertor or something like that)

I think that the guys at the site you gave aren't using that way. I think they use a VGA -> TV convertor.

token 08-26-02 10:52 AM

Quote:

Originally posted by Thunderbird
Direct booting from tv is only possible I thought if you use a composite connection on the card. (not using a convertor or something like that)

I think that the guys at the site you gave aren't using that way. I think they use a VGA -> TV convertor.

Hi.

My card has both composite and svideo connectors, i've tried them independently and toguether.

The guy from the site is not using a VGA->TV, he says that on the article.

Did i misunderstood what the README.TXT on the linux drivers says? Anyone else has ever tried this, or could meke a test and report here?

I still have time to exchange for another brand if i discover it's a "this brand only" problem. Seems that NVidia does the chipset, but the maker of the card does the rest (including TV-out).

BTW mine is chrontel 7007.

Thanks,

Thunderbird 08-26-02 01:56 PM

I checked the article this time and they say this on the hardware specification page:

Video Card - Nvidia Geforce 4 MX-420
At the time that the HEPC was constructed, this was the most powerful "Low Profile" video card we could find. Since this box will also be used as a LAN box, we decided to use this card instead of the onboard video + VGA -> TV converter , as this card provides much more 3D power.

token 08-26-02 02:31 PM

Quote:

Originally posted by Thunderbird
I checked the article this time and they say this on the hardware specification page:

Video Card - Nvidia Geforce 4 MX-420
At the time that the HEPC was constructed, this was the most powerful "Low Profile" video card we could find. Since this box will also be used as a LAN box, we decided to use this card instead of the onboard video + VGA -> TV converter, as this card provides much more 3D power.

Yeah, that's right :)

Note the "instead of" part. They prefered the MX-420 alone "instead of" the onboard+vga->tv.

So, that screenshot of booting from TV is from a MX-420 TV-out card, and i thought this would apply to MX-400 also, as the README says it's for all cards (as for the drivers).

Does anybody out there have got this to work? This is the only card i have near me right now.

From the README.txt, that can be found here:
http://download.nvidia.com/XFree86_4...960/README.txt

"If a TV is the only display device connected to your video card, it will
be used as the primary display when you boot your system (ie the console
will come up on the TV just as if it were a CRT)."

I need to know if:

1) anyone has got this working, ever, on MX-400, and
2) if 1 is true, anyone knows this is a "this brand" problem (i should return it and get another brand).

Thanks,


All times are GMT -5. The time now is 09:50 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.