nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   RH9 + Geforce2 + Latest Driver = Nightmare (http://www.nvnews.net/vbulletin/showthread.php?t=11600)

jac1d 05-11-03 10:05 AM

RH9 + Geforce2 + Latest Driver = Nightmare
 
Hello All,

I have just done a fresh install of RH9 on my machine. The machine has an MSI Geforce2 MX 400 (TV out) card. I did the install and then ran the RH Network upgrade tool and upgraded the kernel to 2.4.20-9 (including kernel sources). I rebooted to load the -9 kernel, then exited X, become root and ran the latest NVidia installer. There were no error messages, it all seemed to work.

I then edited my X config, and made the changes requried as detailed in the readme (changed the driver name to nvidia, and removed a line from the modules).

When I reboot and the system attempts to start X it fatals out and complains that there is a problem with the kernel module of the NVidia driver.

I had this happen once before and thought I might have mucked up my system, thus the fresh install. At this point NOTHING else is loaded except the RH9 iso install, and the updates to the kernel.

Can anyone point me in the direction of what has gone wrong and how I can fix it?

All assistance greatly appreciated.


PS - I'm at a complete loss as to how a stock install of RH9 could get messed up this badly after the driver install - scary.

jac1d 05-11-03 02:13 PM

Further Details on RH9 and GeForce2 Problems
 
Hmm... no one has been able to help yet so I've been mucking about trying different things.

I reinstalled RH9 from scratch again. Only this time I applied NO updates. The system is literally straight from the ISO CDs.

I changed my /etc/inittab to start the machine at init 3 so that I always come in text mode so I can start X on my own.

I downloaded and installed the latest IA32 driver from the NVidia website. All seemed to work ok.

I rebooted for good measure - even though I didn't have to.

I run startx and got the same unable to load NVIDIA kernel error. I would have further collected the info from my X log except that my machine then locked up solid - right there are the command prompt. I had to reboot to get control back.

Any ideas? Can someone shed some light? Thanks.

-Jeff

jac1d 05-11-03 02:21 PM

XLog Attached
 
1 Attachment(s)
I have attached the full output of my X log to aid in diagnosis.

jac1d 05-11-03 02:35 PM

PROBLEM SOLVED
 
THIS SHOULD DEFINITELY BE IN THE readme.txt FROM NVIDIA.

I found the problem - you MUST have your motherboard BIOS set to "Plug and Play OS - NO" and "Allocate IRQ to PCT Video - YES" or the driver will cause the problems I outlined above.

Thankfully, in the syslog messages in /var/log/messages the engineers included info to this effect. Everything is now running swimmingly.

Grrr... Linux needs massively better documentation before it will ever compete with windows.

jac1d 05-11-03 02:38 PM

PCT should be PCI
 
Pardon my typo... Apparently I also need lots of documentation before I can compete with Bill. In the above message, that should read "...PCI Video..." not "...PCT Video.."

jac1d 05-11-03 02:43 PM

Upgrading Kernel
 
I have removed the driver using the handy --uninstall option and I am now upgrading to the latest kernel release from Red Hat and then I will reinstall the driver. If I don't post anything else here - all is well in my world once again... well that is until I start fighting with my MPEG capture card....

Soul-Crusher 05-11-03 08:13 PM

Careful what you say about Windows in a Linux forum, you probably don't want to get trolls like me distracted from the real issue at hand--getting your stuff working. Besides, as far as I know Microsoft is about the only entity who has tried to pass off Linux as a competitor to Windows, and that was just to weasel their way out of court. Me? I haven't the faintest clue why people keep saying that Linux is supposed to be a competitor. Sure there are users deflecting, but that doesn't mean Microsoft and Linux kernel devs are competing.

Anyway, back to your issue, it does not look like you are installing the kernel headers. The source is one thing, but you need the headers as well.

jac1d 05-11-03 09:03 PM

All Better
 
Once I changed those BIOS settings - all was fine. Thanks for your assistance.


All times are GMT -5. The time now is 06:30 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.