nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Module will not load Red Hat 9 (http://www.nvnews.net/vbulletin/showthread.php?t=11615)

Hangfire 05-11-03 08:44 PM

Module will not load Red Hat 9 RESOLVED
 
My X server fails to start, and my XFree86 log file contains the error:

"(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!"

I'm getting this problem, but the help files don't make any sense to me as far as what to do next...

- Xtasy GeForce 4 MX 420
- NVIDIA-Linux-x86-1.0-4363
- Red Hat 9
- don't know my video bios ver, /proc/driver/nvidia doesnt exist..
- AMD Athlon 1.0ghz
- Shuttle Spacewalker AK12A

I edited XF86Config to change the "nv" to "nvidia" and removed the load options as the directions said but it doesnt work...

Lord Blackdrago 05-11-03 09:27 PM

hangfire did you go to your /sbin directory as root and tried modprobe nvidia, then insmod then depmod -ae

then move over to /etc and pico, emacs, or vi the file modules.conf and add this line alias char-major-195 nvidia

i think this will help you

but i'm a newbie just like you :-)

good luck :afro2:

Hangfire 05-11-03 10:24 PM

modprobe and modinfo dont find the nvidia module, i tried insmod and it told me that the ""module kernel was compiled with gcc version and and system kernel was compiled with gcc version 3"" ??? whats up with that?

what i had tried was insmod nvidia-drv.o

Hangfire 05-11-03 11:00 PM

I possibly found my problem but dont know what it means or how to deal with it..

nvidia.o is showing up in /lib/modules/2.4.20-8/kernel/drivers/video/

but my kernel is version 2.4.20-9...........

any ideas?

:confused:

Lord Blackdrago 05-11-03 11:07 PM

yeah move over to

/lib/modules/2.4.20-8/kernel/drivers/video/

and cp nvidia.o /lib/modules/2.4.20-9.../kernel/drivers/video/

then in the /sbin type modprobe nvidia, insmod nvidia,
depmod -ae

Hangfire 05-12-03 12:12 AM

Fixed it!!

the problem was= i was using a boot disk to get to run level 3 to perform the install, the boot disk was loading Linux kernel version 2.4.20-8 and my system is -9.. when the installer executed uname -r it was getting the -8 version and installing accordingly..

Definately something to watch out for!

Make a new -current kernel - boot disk before using the boot disk method to install the new drivers!!


All times are GMT -5. The time now is 09:41 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.