nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   mdk9.1/nvidia install prob solved! (http://www.nvnews.net/vbulletin/showthread.php?t=11625)

Supernewby 05-12-03 02:40 AM

mdk9.1/nvidia install prob solved!
 
After doing what I thought was a correct install and rebooting, the screen would flash three times and boot into text mode. I went back to the "nv" driver (see last paragaph about vi) and searched this forum and the mandrakeclub forum for clues.

I found one on the mdk-club that said that booting into failsafe is not a normal text mode and that the driver won't install properly for reasons that I didn't understand (a bit over my newby head). The problem is I didn't know of any other way to get out of Xwindows. Pressing cntrl-alt-backspace took me back to a graphical looking login with no other way to log in to text mode. I finally found a way.

In grahpics mode I opened the Mandrake Control Center and clicked on Hardware>XFdrake>Options>No>Quit.
That allowed me to reboot into the real text mode, 'cd' to the correct directory and 'sh' the ...4363.run file.

Now I just had to change to the "nvidia"' driver in the XF86Config-4 file and "startx" (or did I reboot before starting x?). Then I could go back to mdkcontrol center>hardware>xfdrake>options>yes>quit then reboot and ta! da! it's working! Man, I'm feelin like a geek already!

Anyway if your using vi for the first time (like me) to edit the config file I suggest the book "A PRACTICAL QUIDE TO LINUX" by Mark G Sobell. It's got a whole chapter on vi. You need to know the read command ":r XF86Config-4", the insert command ":i", the write command ":w! XF86Config-4" and quit ":q"
Happy Hackin! :D

brewer13210 05-12-03 07:59 AM

Alas, I should keep from getting my hopes up...it didn't work for me.

Well, I should qualify that. It works as long as I don't reboot the system. If I use the NVIDIA install script, afterwards I can log in to any user, the NVIDIA splash screen appears and then KDE starts. As soon as I reboot, I'm back to where I was before...the screen flashes a couple of times and the system locks.

System: Mandrake 9.1
Mobo: ABIT KD7 - VIA KT 400 chipset
Card: GF4 440 MX

Todd

tsubasa 05-12-03 08:45 AM

hello
 
I will Test it, u think its not good to install in init 3 mode ?

It always not work on my KT333
:'(

alien999999999 05-12-03 12:42 PM

it's not good to install in runlevel 5, one must go into level 3, but not with the failsafe, for some reason Ican't remember. one can '/etc/init.d/dm stop' to kill the display manager and '/etc/init.d/dm start' to start it again. I think that would be a lot easier...

if it works but not when you reboot: try 'insmod nvidia' or add nvidia to the /etc/modules.conf file...

I think this happens when you did not exited X the right way...

one can go to text login by pressing CTRL-ALT-F1 and log in as root and kill the display manager from there...

tsubasa 05-28-03 05:57 AM

Always dont work for me

zdra 05-28-03 04:50 PM

nothing work with me... I think it's impossible to install a g3 on linux mdk9.1.:(

tsubasa 05-29-03 04:06 AM

hello
 
my Kt333 mobo and my G3ti500 are always in the mood :confused:


All times are GMT -5. The time now is 08:19 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.