nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Newest Nvidia 64bit drivers don't support 7900GTX? (http://www.nvnews.net/vbulletin/showthread.php?t=116254)

kogos 07-14-08 07:29 AM

Newest Nvidia 64bit drivers don't support 7900GTX?
 
I'm using Ubuntu Hardy 8.04 with a 7900GTX (XFX XXX edition). Unfortunately, as it seems, Nvidia won't support these cards with the latest drivers on Ubuntu... I'll explain what made me come to this conclusion:

I'm playing World of Warcraft with Ubuntu Hardy with OpenGL through wine. I am using ubuntu to play warcraft for many years now, but unfortunately problems started to occur with the latest nvidia's drivers. When i try to enable 4xMultisampling in warcraft, the mouse and the keyboard freeze completely. However, the game is not crashing since i hear the music playing and people moving. The keyboard is locked and the only way to recover is by reseting the PC. Only SysRq+Alt+B can reset the system.

I tried almost every version of wine out there, and i also tried disabling or uninstalling other hardware devices that may conflict with warcraft. I also try enabling/disabling compiz effects, i even unisntalled compiz completely. I also tried enabling Multisampling through nvidia-settings and not from within the game. In all cases the game crashes with the symptoms i'm writing above. I also tried to add "Option "UseCompositeWrapper" "True"" parameter on the xorg.conf, and tried the registry hack for fps boost. Well, i tried practically everything i could find on the internet that might solve this issue.

I'm not new to linux, so i guess that doing something wrong could be out of the question here. I also used a newly installed Ubuntu Hardy to eliminate problems with other piece of software that might be left behind. I tried EVERY driver version newer than 100.14.19. Only with 100.14.19 version, the game can be played with 4xMultisampling without freezeing. By the way, version 100.14.19 was the default version in Ubuntu 7.10.

So, my guess is that there is a major incompatibility of some kind with ALL these new nvidia drivers and the 7900GTX card. The only thing that i didn't try is installing the latest drivers in Ubuntu 7.10, but I simply can't use 7.10 anymore for other reasons i won't refer to here.

My system:
-CPU: AMD 64 3800+ (not dual core)
-Mobo: Asus A8N-SLI Premium
-VGA Card: XFX 7900GTX XXX Edition
-Ubuntu Hardy 64bit with all the latest updates

P.S.: I also posted this problem several weeks ago on ubuntuforums.org, but i can't find any solution until now:( Any help would be appreciated. I'm not saying that all 64bit linux distributions are having this problem, but with Ubuntu Hardy, all the latest Nvidia drivers have some major issues! And since Ubuntu is pretty popular, maybe it should be taking care of. Thanks in advance for your time!

Dragoran 07-14-08 11:33 AM

Re: Newest Nvidia 64bit drivers don't support 7900GTX?
 
A bug does not mean that your card is not supported.
Attach an nvidia-bug-report.log.

kogos 07-14-08 07:02 PM

Re: Newest Nvidia 64bit drivers don't support 7900GTX?
 
1 Attachment(s)
unfortunately i cannot create a nvidia-bug-report.log file while the system is locked. I tried to log on remotely, but no luck. So this is the log file with X running, but not after the problem occured. I don't think this will help you with anything, but here it goes (it's compressed cause it was a little bigger than allowed).

When problem occurs, the only thing i can do is just reset... i can't run any applications, can't even kill X or any process... no shortcut is working, except SysRq+Alt+B... By the way, i tried today on another AMD64 system i have... i used my VGA card with the Ubuntu Hardy 64 installed of course... and the same thing happened...

It's pretty sad to be honest, and i hope this issue will be addressed for future driver releases. Thanks again for your time...

kogos 09-04-08 01:43 PM

Re: Newest Nvidia 64bit drivers don't support 7900GTX?
 
so, i guess there is no solution to the problem above... that's sad


All times are GMT -5. The time now is 11:50 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.