nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   error: remap_page_range_R2baf18f2 (http://www.nvnews.net/vbulletin/showthread.php?t=11630)

bromod 05-12-03 03:58 AM

fixed error: remap_page_range_R2baf18f2
 
Help: I am trying to build the NVIDIA_nforce-1.0-0256 software.

What am I doing wrong?

I am using RedHat 9 with
kernel-source-2.4.20-8
kernel-2.4.20-8

I am getting this error:

[root@localhost nforce]# make
make -C nvnet
make[1]: Entering directory `/root/nforce/nvnet'
cc -c -Wall -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/lib/modules/2.4.20-8/build/include -DMODVERSIONS -include /lib/modules/2.4.20-8/build/include/linux/modversions.h nvnet.c
ld -r -o temp.o nvnet.o nvnetlib.o
objcopy --strip-symbol="gcc2_compiled." temp.o
cp temp.o nvnet.o
rm temp.o
make[1]: Leaving directory `/root/nforce/nvnet'
make -C nvaudio
make[1]: Entering directory `/root/nforce/nvaudio'
make nvaudio.o
make[2]: Entering directory `/root/nforce/nvaudio'
cc -D__KERNEL__ -I/lib/modules/2.4.20-8/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DMODVERSIONS -include /lib/modules/2.4.20-8/build/include/linux/modversions.h -c -o nvhw.o nvhw.c
cc -D__KERNEL__ -I/lib/modules/2.4.20-8/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DMODVERSIONS -include /lib/modules/2.4.20-8/build/include/linux/modversions.h -c -o nvrec.o nvrec.c
cc -D__KERNEL__ -I/lib/modules/2.4.20-8/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DMODVERSIONS -include /lib/modules/2.4.20-8/build/include/linux/modversions.h -c -o nvwavout.o nvwavout.c
cc -D__KERNEL__ -I/lib/modules/2.4.20-8/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DMODVERSIONS -include /lib/modules/2.4.20-8/build/include/linux/modversions.h -c -o nvspdif.o nvspdif.c
cc -D__KERNEL__ -I/lib/modules/2.4.20-8/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DMODVERSIONS -include /lib/modules/2.4.20-8/build/include/linux/modversions.h -c -o nvcrush.o nvcrush.c
nvcrush.c: In function `Nvaudio_mmapwrite':
nvcrush.c:426: warning: passing arg 1 of `remap_page_range_R2baf18f2' makes pointer from integer without a cast
nvcrush.c:426: incompatible type for argument 4 of `remap_page_range_R2baf18f2'
nvcrush.c:426: too few arguments to function `remap_page_range_R2baf18f2'
nvcrush.c: In function `Nvaudio_mmap':
nvcrush.c:465: warning: passing arg 1 of `remap_page_range_R2baf18f2' makes pointer from integer without a cast
nvcrush.c:465: incompatible type for argument 4 of `remap_page_range_R2baf18f2'
nvcrush.c:465: too few arguments to function `remap_page_range_R2baf18f2'
make[2]: *** [nvcrush.o] Error 1
make[2]: Leaving directory `/root/nforce/nvaudio'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/root/nforce/nvaudio'
make: *** [nvaudio_make] Error 2

:eek:

bromod 05-20-03 11:16 PM

I was able to build the nvnet but not the nvaudio - I went into the makefile and removed the option from the SUBDIRS

bromod 05-20-03 11:51 PM

for the nforce-1.0-0256 codebase on kernel 2.4.20-8 to get this to compile, I had to make the following change. It now builds.

Within the nvaudio/nvcrush.c file, I made the following change to both calls to the remap_page_range, lines 426 and 465.

OLD LINE:
if (remap_page_range(vma->vm_start, virt_to_phys(recdmabuf->rawbuf), size, vma->vm_page_prot))


NEW LINE:
if (remap_page_range( vma, vma->vm_start, virt_to_phys(recdmabuf->rawbuf), size, vma->vm_page_prot))

Kennedy 05-21-03 03:26 AM

Thanks Bromod

That seems to have worked fine.

Regards

Kennedy

tho 06-05-03 10:02 AM

Hi bromod,

your patch worked for me, too. (RedHat 9 with kernel-2.4.20-18.9)

I can provide RPMs with your patch for the people who do not want to build them on their own. Have a look at http://www.rcs.ei.tum.de/~hopfner/nvidia/ and I hope this Q&D hack works for other people, too.

CU,
Tom

Kennedy 06-05-03 10:14 AM

I recently upgraded the kernel to 2.4.20-18.9 and had to reinstall the nv drivers.

This caused problems because the "make clean" in the nforce directory didn't work. I assumed it didn't matter - wrong.

The "make install" crashed with unresolved dependencies.

I had to do a "make clean" in each of the subfolders nvnet and nvaudio. Which then resolved the problem.

Thought I would post it here for any other newbies suffering the same way.

Another good thing - RH seem to have addressed the IDE speed problem in the new kernel. Around 50% improvement I think.

Kennedy


All times are GMT -5. The time now is 08:53 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.