nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem configuring TV-Out (Dual Screen) (http://www.nvnews.net/vbulletin/showthread.php?t=11685)

Loki-450 05-12-03 08:44 PM

Problem configuring TV-Out (Dual Screen)
 
1 Attachment(s)
I'm trying to configure my GeForce 4 Mx 420 video card to use a dual monitor configuration (CRT & TV). I'm only able to get the CRT output to work.

I know the TV display works, if i only hook the TV up it displays the console fine.

I have been unsuccessful in getting it to work. If anyone can offer me any suggestions it would be greatly appreciated.

I've attached my XF86Config file.

Thanks,

~Loki

edit: I'm using 4349

alien999999999 05-13-03 06:04 AM

read the README file that came with nvidia. there's a whole appendix on how to make TV-Out work...

Loki-450 05-13-03 11:46 AM

I've read the readme, twice

I'm trying to figure out if there is something i'm missing, as it is not working right, wondering if others were having problems.

This is what i had about the linux, it is a great os, but you've got a bunch of **** heads running it who know no other response than RTFM. It's no wonder people use windows

Misel 05-13-03 12:28 PM

and the only thing you do is flaming back ;)

besides you could have posted your XFree config flle. Then it would be much easier to solve your problem.

Loki-450 05-13-03 02:45 PM

You are right, I shouldn't have flamed back, I was just in a very bad mood at the time, and people like him bother me.

If you don't have something useful to add to a conversation, don't say anything.

And if you look at my original post, xf86config.txt (my config file) is attached. I had to add the txt extension for it to post.

Misel 05-13-03 03:11 PM

hey, you cheated. that wasn't there when I looked first!

j/k ;) :D

well I looked at it and something's missing, I think. You want to use dual screens you have to activate TwinView:

Code:

        Option    "ConnectedMonitors"        "CRT, TV" # Monitors with s!!!
        Option    "TwinView"          "On"  # [<bool>]
        Option    "TwinViewOrientation" "RightOf"    # <str>
        Option    "MetaModes"          "1280x1024,1280x1024; 1024x768,1024x768"      # <str>

I think those lines are needed to work. I use this to get my dual monitor setup working but that shouldn't differ that much. You have to change the MetaModes to your needs though. Look for the semicolons and commata notation!

I hope I could help you.

BTW: If you do an "XFree86 -configure" X tries to guess your setup. It probably won't detect your TV but it gives you a full list of parameters for the drivers in the newly created config-file. :)

Loki-450 05-13-03 03:36 PM

That isn't exactly what i was trying to do, used to have it set up like that when I was using 31??(can't remember the version number right off).

I was trying to use the seperate screen feature that was added in the later versions (again not sure what version).

I tried following your example, but it doesn't seem to work with the newer versions of the driver.

I think there is some sort of problem with the tv-out on GeForce 4 MX with the newer drivers.

I've read in other places of people having problems using the tv-out on a geforce 4 with the newer driver versions.

I guess it's back to the old drivers.

Thanks, for trying to help

clockworks 05-13-03 09:38 PM

1 Attachment(s)
are you trying to use 2 seperate x screens? one for tv and one for crt? if thats the case, i have an XF86Config for you. my config does 3 important things:
1) puts the TV to the left of the CRT
2) screen 0.0 is the CRT, screen 0.1 is the TV
3) screen 0.1 (the TV) has the video overlay. meaning if you play back movies on that screen they won't tear. but if you playback movies on the CRT, they will tear
4) there is a bug. when you quit the x server with this config, you get a blank (or a messed up) screen where you can't see anything. input still works, and you can restart the x server just fine, but you just won't be able to see anything at the console.

hope this helps,
-- christopher

Misel 05-14-03 06:33 AM

you run your TV @ 1152x864?????

clockworks 05-14-03 01:47 PM

Quote:

Originally posted by Misel
you run your TV @ 1152x864?????
yeah...it runs fine and its easier to see stuff (when its showing a desktop). i know everyone is like "don't run it higher than 800x600", but i haven't had any problems yet...=P maybe it actually runs at 640x480 despite whats in the xf86config, dunno...

-- christopher

Loki-450 05-14-03 03:40 PM

Thanks clockworks,

That was exactly what I was trying to do (except that high of a resolution on the tv)

I was able to reproduce everything down to the messed up screen upon exiting X, except one thing - my tv screen remained blank. Although I could move my cursor off the screen like there should be another screen there.

I think there is something weird with my combination of driver, kernel, and Xfree version, i've heard of others having the same problem with very similar configurations.

What version of XFree are you using?
What kernel version are you using?

schotty 05-14-03 04:23 PM

Hey all!

I have just decided to make my tv-out work as well, and have run into some issues as well. Here is a snippet of my X log. I am running the 4349 driver and plan to upgrade tonight or so (sooner rather than later). And I do have my kernel sources available.

Any tips would be greatly appreciated. I basically took clockworks' X config and "migrated" it to mine. An attatchment can be provided if neccessary. Basically what I would prefer to do is mirror what is on my VGA to my TV. IF that is possible. I am not new to linux, but new to nVIDIA and TV out options. I am sort of confused on some of the layout settings and what is needed.

Thanks!

[code]
(WW) Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.
o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWSave from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unre
solved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWSave from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unre
solved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWRestore from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is u
nresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWRestore from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is u
nresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWUnmapMem from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol fbCloseScreen from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol fbWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o
is unresolved!
Symbol fbWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o
is unresolved!
Symbol fbCreateWindow from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol fbCreateGC from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unr
esolved!
Symbol fbGCPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o
is unresolved!
Symbol fbValidateGC from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is u
nresolved!
Symbol fbPictureInit from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is
unresolved!
Symbol fbWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o
is unresolved!

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error:
Caught signal 11. Server aborting
[/code[

and just so I get this out of the way ...
Code:

[schotty@drunkenmaster schotty]$ sudo rpm -qa | grep ernel
Password:
kernel-2.4.20-9
kernel-source-2.4.20-9
kernel-pcmcia-cs-3.1.31-13
kernel-2.4.20-6
[schotty@drunkenmaster schotty]$

Thanks!


All times are GMT -5. The time now is 05:15 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.