nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GL/CLX Parts missing (http://www.nvnews.net/vbulletin/showthread.php?t=117557)

CrossBow 08-08-08 09:26 PM

GL/CLX Parts missing
 
2 Attachment(s)
Basics:

Fedora 8

uname -a
Linux scorpy 2.6.25.11-60.fc8 #1 SMP Mon Jul 21 02:06:29 EDT 2008 i686 athlon i386 GNU/Linux

lspci -v
02:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX - nForce GPU] (rev a3) (prog-if 00 [VGA controller])

(440MX on motherboard (shared memory)

NVIDIA Driver Version: 96.43.07

I am running dualhead (TwinView). 2 x 17" lcd's at their native resolutions (1024x768). I am running at 16 bpp, because this system has never been able to run dual head at 32 bpp. due to the speed of the shared memory.

Problem:

3-D parts of many programs are simply missing.

The earth is missing in GoogleEarth (see attachment)! Extreme Tux Racer starts with just the pale blue background. By guessing key presses, I can start a game, and tux is rendered, and runs at good speed, but the scenery is missing(see attachment).

Must OpenGL xscreensaver modules run fine, but some do have parts missing, or simply result in a blank screen. CPU load is normal, and all 2D stuff seems fine. System is stable, moving windows, etc. seems to have good speed.

There is nothing helpful in Xorg.0.log, and no errors.

System was previously running a much older version of fedora, and a very old NVidia driver. I had not updated for years. In the old configuration, I was limited to 16bpp, but 3D stuff (specifically tux racer) worked fine.

The problem started when I upgraded to Fedora 8. At first, I was using the 96.43.05 driver with a patch. When 96.43.07 appeared, it built and installed fine (no patch needed), but the problem persisted.

xorg.conf is as the nvidia installer creates it, with the exception that I had to comment out the FontPath line

I have tried dropping down to 1 monitor, (TwinView off) but the problem persists.

I know one answer is to buy new hardware, and I may do that, but I would still like to know what is going wrong here.

Thanks in advance for any help you can provide.

adamk75 08-09-08 09:32 AM

Re: GL/CLX Parts missing
 
Please read this post: http://nvnews.net/vbulletin/showthread.php?t=46678

Particularly the bit about providing a bug report.

Adam

CrossBow 08-12-08 07:47 PM

Re: GL/CLX Parts missing
 
1 Attachment(s)
nvidia-bug-report.sh attached.

BTW, just upgraded kernel to 2.6.25.14-69. Same NVidia drivers (96.43.07) re-built with the nvidia installer. No problems during build, or running X, but identical problem persists.

CrossBow 08-16-08 08:47 PM

Re: GL/CLX Parts missing
 
Sorry to <bump>,

but I would really appreciate some help here.

May be just a simple path problem, or a real driver problem.

Thanks;

jamesjones 08-18-08 08:13 PM

Re: GL/CLX Parts missing
 
Thanks for the bug report. I looked into your issue and fixed it. The fixes will be in the next release from the 96.43 branch.

CrossBow 08-19-08 06:24 PM

Re: GL/CLX Parts missing
 
Thanks;

I've said it publicly here before, and on my website:

You - Guys - Rock (urock)

hwertz 09-17-08 09:05 PM

Re: GL/CLX Parts missing
 
Awesome!!! I've been hacking up 87.76 driver for like 2 years with my 4MX, due to 71.86 being quite a bit slower, and 96.xx just not working for 3D apps. I'll be thrilled if this gets fixed in 96.43.08 or whatever! :captnkill:


All times are GMT -5. The time now is 07:38 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.