nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   A7N266-VM-RH9-Success (http://www.nvnews.net/vbulletin/showthread.php?t=11763)

[)eacon]ndigo 05-13-03 11:43 PM

A7N266-VM-RH9-Success
 
I'm new to Linux (though I did run it back around '92 for a while--things have changed :)), so getting linux running on this board was a bit of a learning experience.

First I had the hang at finding modules dependencies. That was solved (thanks to hints from this forum and other places) by unplugging the mouse. I found that I could plug it back in once I got past that point in the boot process and it would work. It hung again upon rebooting, but I've since put the mouse on one of the USB ports connected to the front of my case and the machine now boots with the mouse attached. So if you have this problem try unplugging the mouse temporarily or just try different ports.

The sound worked when the machine came up, but the NIC didn't and the RPM (NVIDIA_nforce-1.0-0248.src.rpm) on the nVidia site didn't work. The kernel tar file version did work, however (thanks to scritch for that tip), but upon upgrading to the 2.4.20-9 kernel my Ethernet port was broken again.

I saw a post from meterman regarding http://www.pheran.com/nv7linux/ and a 0248 RPM so I checked there and found nvnet-1.0_0256-1.athlon.rpm which got my Ethernet going again.

At first I was concerened that I'd be stuck running Windows on this machine (for a while at least), but everthing seems to be working great now thanks mainly to this board.

Pheran 05-14-03 08:30 PM

Thanks for the plug! I just registered for this forum, so I thought I'd let you know that I just posted a new RPM that adds support for the new 2.4.20-13.9 kernel.

[)eacon]ndigo 05-14-03 09:47 PM

Just grabbed it and the new kernel build. Works great.

Thanks!

soccer4net 05-15-03 01:25 PM

I'm pretty much in the same boat as deacon was, tried installing the new Nforce driver src.rpm for rh9 with no success. I installed pheran's new nvnet.rpm, modules.conf still has eth0 pointing to nvnet driver, however I assume this is for the old non-working driver. Do I need to erase the old driver/point to a different driver name or what??

Pheran 05-15-03 09:06 PM

Your modules.conf still has to contain "alias eth0 nvnet", that won't change. Are you saying that the RPM didn't work after rebooting?

soccer4net 05-16-03 12:10 PM

That's right. Installed without any errors, verified that alias eth0 nvnet was there, and rebooted. On boot up it said something about nvnet not present or something-delaying initilization. It gives me the same message when I try to activate it manually.

Don't know if this means anything but when I tried to reinstall it, but when I use rpm -e nvnet*.rpm it says error: package not installed. And when I try to install it again: rpm -i nvnet*.rpm it says package already installed :confused:

Any ideas?

Pheran 05-16-03 05:31 PM

Hmm, what kernel are you running (uname -r). What's the output of modprobe nvnet?

The correct way to remove the package is rpm -e nvnet; the command you listed won't work (as you discovered).

mceachrw 05-22-03 12:46 PM

don't unplug the mouse!
 
i can't remember the exact bios setting, but it has something to do with leagacy usb devices. the choices are primary, secondary, and disabled. if you choose primary, you will have problems with devices plugged into the primary usb ports. if you choose secondary, you will have problems with devices plugged into secondary usb ports.

choose disabled, and all problems go away on rh9.

finding module dependencies asus a7n266-vm for search reasons!

[)eacon]ndigo 05-22-03 07:17 PM

Thanks for the tip, mceachrw.

soccer4net 05-23-03 10:41 AM

Sorry I didn't get back to you sooner. I'm running ver. 20-6(haven't upgraded since installing rh9) I tried uninstalling nvnet and reinstalling. The package places the eth0 nvnet entry in modules.conf again, but on restart it still says module doesn't seem to be present delaying init. When I do a modprobe it says can't locate module.


All times are GMT -5. The time now is 02:18 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.