nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Games not runing, believe to be driver related (http://www.nvnews.net/vbulletin/showthread.php?t=11792)

AnvilDemon 05-14-03 10:26 AM

Games not runing, believe to be driver related
 
1 Attachment(s)
Well, I am a big gamer and I have moved to Linux over the past couple of weeks. Well i ordered a bunch of games from Tuxgames and only 3 of the ones I ordered work.
The games that work are Majesty, Kohan, and Dominions.
The games that do not work are Descent3, Sin, Shogo, Terminus, Myth2, Civ:CTP.
All the games that do not work require a 3d accelerator and the games that work, do not require the 3d accelerator.
Atleast this is to my understanding anyway.

All the games that do not work with either not start or I can view the intro then it will drop me to my desktop in gnome.

I have a program called nv check and it tests to see if the driver is installed properly. You can get this program from www.linuxgaming.net , Here is the readout I get from that proggy or script.

Welcome to the NVidia Driver Installation Checker.
This shell script is meant to help you debug your installation
of the beta NVidia Linux drivers. It is not 100% foolproof.
In particular, you will definitely want to make sure you have
the correct options in your XF86Config to make X work properly.
This script cannot debug your X setup. That being said, it
should prove useful if are having problems with the drivers and
want to check the validity of your driver install.

At no time will this script EVER make changes to your system.
It is simply a diagnostic tool - fixes of any kind will have to
come from you.

Press enter to continue...

OK, the first thing we need to do is make sure your XF86Config file
is set up correctly. In order to do this, I'm first going to try
and find where this file might be...
checking /usr/X11R6/lib/X11/XF86Config...
found
checking /usr/X11R6/etc/X11/XF86Config...
not found
checking /etc/XF86Config...
not found
checking /etc/X11/XF86Config...
found
checking /etc/X11/XF86Config-4...
not found
I'm going to be doing my checking using /etc/X11/XF86Config. If this is not
actually your X config, then quit this script with Ctrl-C, remove
or rename the file, then run this script again.
Press enter to continue

I'm going to check your XF86Config file for the following things:
1) Loading the GLcore and glx modules
2) Specifying the nvidia driver instead of nv

Checking for the Load glx statement...
Load "glx"
It seems to be intact. Now lets see if you're loading the correct
video driver...
Driver "nvidia"
Everything seems fine in your X config file. This is not 100%
guaranteed to be accurate, but lets continue anyway (press enter)...

The next step involves making sure you have the proper files in
the right places, and that the kernel module loaded correctly.
Press enter to begin the test.

First lets make sure you don't have the old modules still present
by mistake...
Checking /usr/X11R6/lib/modules/extensions/libglx.a...
Checking /usr/X11R6/lib/modules/extensions/libGLcore.a...
You don't appear to have any conflicting older drivers. Now lets check
if the new driver files are in place...
Checking /usr/X11R6/lib/modules/drivers/nvidia_drv.o...
Checking /usr/X11R6/lib/modules/extensions/libglx.so...
Checking /usr/lib/libGL.so...
libGLcore.so.1 => /usr/lib/tls/libGLcore.so.1 (0x40085000)
Checking /usr/lib/libGLcore.so.1...
All the files seem to exist. Now I'm going to see if your kernel
module is loaded correctly...
the NVdriver kernel module does not seem to be loaded. The 3D
drivers will not work without it...please compile it for your
kernel, set it up to insert the module on boot, then run
this script again.
Remember if you are having trouble compiling the module,
try adding -D_LOOSE_KERNEL_NAMES to the Makefile.

I have run the module from the command line before X loads, and have tried insmod NVidia but it still gives me the same thing at the bottom of the report.

I know this was a long post but thanks for reading and any help will be greatly appreciated.

My hardware is:
2400+ T-Bred
Abit NF7-S rev 1.2
Gainward GF3 TI200 GS w/128mb
1gig Corsair XMS Pc3200LL

I am using the onboard sound and NIC
My config is attached.

AnvilDemon 05-14-03 10:27 AM

1 Attachment(s)
Here is my xfree86 log.

Oh, I am using the 4363 drivers and I installed them using the init 3 to drop out of X. The install seemed to go well, no errors to my knowledge.

shassard 05-14-03 10:34 AM

nothing looks particularly wrong with your log.

perhaps you could post your /etc/X11/XF86Config-4 file?

Also, what version of redhat are you running? I know that certain version of redhat have some broken libraries that ship by default and you might need to update your system for stuff to work properly. take a look around the board here, their are other people having problems with redhat.

AnvilDemon 05-14-03 10:39 AM

I am using RH9, kernel is 2.4.20-6

I do not have a file called XF86Config-4 file
I only have the XF86Config file and a backup.

I just read the other thread about the nforce drivers and the nvidia drivers conflicting with the nvidia.o file or something. I had to install the nforce drivers before the vid card so I could get the NIC working. Maybe that is my problem?

AnvilDemon 05-14-03 10:44 AM

oh yeah I also own UT and UT2k3 and they install but will not even load up the intro. The screen will flash for a second then back to desktop.

shassard 05-14-03 12:16 PM

send up your XF86Config file. they're the same difference :P

AnvilDemon 05-14-03 12:24 PM

1 Attachment(s)
Sorry, bout that wasn't for sure, I have only been using RH9 and Linux for about a week. Don't know to much yet.

I posted the XFconfig log in my first post though. I had to add the .log to it in order for me to attach it. Here it is again though. :)

shassard 05-14-03 12:28 PM

looks like you're running xfs.

perhaps you could also post you /etc/X11/fs/config file ..

bwkaz 05-14-03 12:32 PM

Also, saying "the games just drop back to the desktop" isn't any help at all. What's happening is that they're printing an error message, but since you didn't start them from a command prompt, you aren't seeing that error.

Open up a terminal emulator (xterm, Eterm, aterm, konsole, gnome-terminal, any of these will work, and I've surely forgotten others that will also work), and run the game from there. ut2003 will start UT2k3, for example.

Then, when the game exits, post the error message (or just the full output) here.

Which glibc version do you have? Did you update glibc at all since installing? The problem referred to earlier was a problem with the U.S. boxed set of RH -- they shipped with a buggy C library (glibc) that causes problems with GL programs. The first version that works is noted somewhere in the README, in the FAQ section.

You should be able to rpm -qa | grep glibc to find out which version(s) you have.

AnvilDemon 05-14-03 12:34 PM

1 Attachment(s)
I really appreciate you taking the time for this shassard.

Since I was new to the Linux world i wanted to see what the OS had available, so i did a complete install. This way when I figure out how to set everything up the way I wanted I could reinstall with only the stuff I know I would be using. Or I will just leave it as it is after it is setup correctly.
Here it is.

AnvilDemon 05-14-03 12:49 PM

Here is the info on the glibc.

glibc-kernheaders-2.4-8.10
glibc-profile-2.3.2-5
glibc-common-2.3.2-5
glibc-devel-2.3.2-5
glibc-utils-2.3.2-5
glibc-2.3.2-5
glibc-debug-2.3.2-5

Here is the error I get in Descent3

SIGNAL 11 caught, aborting
Recursive signal cleanup! Hard exit! AHHGGGG!


Thanks for letting me know that bwkaz.

AnvilDemon 05-14-03 01:06 PM

1 Attachment(s)
Here is what the new fs config file looks like.
Descent3 still crashes with same error after the changes.


All times are GMT -5. The time now is 11:37 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.