nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Quadro4 RH9 Xdisplay (http://www.nvnews.net/vbulletin/showthread.php?t=11794)

tauperin 05-14-03 10:34 AM

Quadro4 RH9 Xdisplay
 
1 Attachment(s)
Hi,
I am new here so please bear with me...

Configuration:
Asus A7V333-X motherboard KT333 chipset
AMD Athlon XP 2700+ Processor
1GB RAM
Quadro4 750 XGL 128MB
SyncMaster 172T flat panel
RedHat 9

I just bought that flat panel. Reading through your forum, I found out that the DVI port is not supported by driver nvidia 4363 or earlier version.
So I went for the analog port.
I installed the driver 4363 from nvidia website (installation went fine, see log) and tried to run X. It hangs.
CRT+ALT+BACKSPACE gives me the text mode back and it seems that initializing the GLX extension is the problem, since that is where it stops...
If I use the driver from RH9 (option "nv" for driver in XF86Config), the Xdisplay works fine but if I try the Nvidia driver (option "nvidia"), it fails...

Also, this monitor is supposed to have a resolution of 1280x1024 and it seems that I don't get that using the driver from RH9 because "hsync out of range"...

I am not really sure what kind of files I should provide you to help you figure it out...
I attached the nvidia-installer.log of the installation and my XF86Config... Let me know if you need anything else and I'll make sure to post it tomorrow.

Thanks
-th

PS: the funny thing is that my work computer has a flat panel T860 IBM using DVI port on a NetVista 8307-H6U IBM computer where we changed the video card to a Quadro4 750 XGL and running RH8 2.4.18-24.8.0 (using Nvidia driver 1.0-4191) AND IT WORKS FINE !!!!

Video BIOS 04.25.00.29.03:confused:

tauperin 05-14-03 10:37 AM

XF86Config(.log)
 
1 Attachment(s)
XF86Config(.log)

tauperin 05-14-03 06:14 PM

HELP!!!!!
 
I NEED HELP!!!

HELLO???!!!!

:(

DrOzz 05-14-03 06:19 PM

post your xfree86.0.log file located in /var/log folder

tauperin 05-15-03 09:22 AM

1 Attachment(s)
Hi,

I tried a few things.

1) Option "ConnectedMonitor" "DFP" freezes the computer when startx and I cannot use CRTL+ALT+BACKSPACE (see 1_XFree86.0.log). I have to reset.

2) Option "IgnoreDisplayDevices" "CRT,TV" freezes the computer when startx and I cannot use CRTL+ALT+BACKSPACE (see 2_XFree86.0.log). I have to reset.

3) If I do not put any of these above options, X starts but hangs when the screen which RH logo comes up (where it is loading all the environment). I CAN use CRTL+ALT+BACKSPACE (see 3_XFree86.0.log).

I hope these log files will help someone figure it out...
Thanks to anyone who can help me on this.
later
-th

tauperin 05-15-03 09:23 AM

2_XFree86.0.log
 
1 Attachment(s)
for Option "IgnoreDisplayDevices" "CRT,TV"

tauperin 05-15-03 09:23 AM

3_XFree86.0.log
 
1 Attachment(s)
for no options.

DrOzz 05-15-03 10:50 AM

well d00d i noticed your getting alot farther then others...and definetaly farther then me...cause the last thing i see in my log files is:

(II) NVIDIA(0): AGP 4X successfully initialized
(II) NVIDIA(0): Setting mode "1024x768"

but anyways i see a few times that it said it could get the EDID, so maybe try Option "IgnoreEDID" "1", and by what i am reading i don't think you did try the option "NvAgp", so give it a try using the value "0", and then if that dont' work try "1"...
so in your config file under the Device section you will add.....

Option "IgnoreEDID" "1"
Option "NvAgp" "0"

and the accepted vales for nvagp are 0 -3 , so if you wish you can experiment with them all....

tauperin 05-16-03 09:19 AM

fresh reinstall
 
I tried to re-install RH9 thinking that maybe it would be better...

I tried first with the DVI port and RH9 recognizes the monitor as a SyncMaster (which it is) but once it starts the display to configure, this is black, no image...

So I tried with the analog port and everything went smoothly (although it said "Unprobed Monitor")...
Then I tried to install nvidia driver 4363 but the loading of the GLX extension is the problem... I left it 15 minutes trying to load that stuff and gave up.
I went back to the "nv" driver and everything works fine although it is annoying to have a 3D video card and not being able to use it.

I did not try EDID and NvAGP options (I am a little scared about EDID since the manual says it could be harmful to the monitor!!)...

Is the SyncMaster 172T not compatible with RH9?? (although I don't see why it would not).

Next step is to try RH8 and we will see...

DrOzz 05-16-03 02:33 PM

well just to save you some disappointment and grieft i will tell you that these problems aren't really distro related....cause i have had RH8 RH9 and MDK9.1 on my box and there is no difference...same problems...so with that said, i don't think you should try different distros based on the thought that you think it will work

and if you could, could you post the log that shows the error in loading the GLX extension

tauperin 05-16-03 02:54 PM

on the other end, I am running RH8 at work with a flat screen T860 (IBM) on DVI port with nvidia driver 1.0-4191 and EVERYTHING WORKS FINE!!!

So there is still hope!!!

tauperin 05-16-03 04:02 PM

Hey DrOZZ,

For the log file containing the GLX error, it is not really an error... It just says:

(II) [GLX]: Initializing GLX extension


and hangs...


See 1_xfree86.0-1.log and 2_xfree86.0-1.log.
One of my previous messages explains what is what...

Thanks for your help.
-th


All times are GMT -5. The time now is 01:54 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.