nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Giving up on A7N8X Deluxe and Debian (http://www.nvnews.net/vbulletin/showthread.php?t=11837)

forevrnite 05-15-03 05:44 AM

Giving up on A7N8X Deluxe and Debian
 
No matter what parameters I tried during install I couldn't get it to install the 3c59 driver for the onboard 3Com NIC and also couldn't get X to start. I think that may have been due to it coming with a 2001 release of xfree86 but I have no idea how to install the latest version at this point. So I think I'm going to try RH 9 and see if that works and then try to learn some stuff before trying Debian again. Any idea if my FX5800 Ultra could be causing these problems with X?

suexec 05-15-03 01:25 PM

Are you installing from a CD? If so, most likely you are installing Debian Woody. Normally its install uses the 2.2.2x (I think it may be 20) kernel which knows nothing of the nForce2 chipset nor its 3Com NIC. Even if you use the bf2.4 kernel, I don't think the 3Com would be supported as it is 2.4.18. The nForce2 did not really get supported until 2.4.21 (various pre's added more functionality). You need a much more current kernel than what comes with the original Debian the 3Com NIC and the rest of the nForce2. I think the 3c59x driver was updated in 2.4.21-pre3 to support the PCI ID of the 3Com NIC.

You could have grabbed the nForce drivers from nVidia and got the nvnet driver working on the nVidia MAC. It is a small download which you should be able to transport to your A7N8X DX machine via floppy. Once you have network connectivity, you could download the latest 2.4.21-rc2 kernel and recompile. Then you should be set.

leibold 05-15-03 03:35 PM

If it's just the network that is holding you back, take the 3c90x driver from the ASUS CD that came with your motherboard. It will *NOT* work as is, but only requires a small one line change to enable the correct support. Let me know if you want to try this.

forevrnite 05-15-03 04:34 PM

Eh, I think I'm gonna play with RH a little and try to learn some basics first. Even if I do get the network driver working on Debian I think I still need to figure out how to install a new version of xfree86 because the version that comes with Debian is from 2001 and I don't think it's playing nice with my FX5800. No matter what settings I tried X wouldn't start. Anyway RH9 is installed so I guess I'm gonna go figure out how to install the Nvidia drivers and get hardware acceleration working on the video card. RH9 picked up both the video card and the 3Com NIC during install just fine but I guess the AGP gart stuff isn't there since I have no hardware acceleration (box is grayed out in the display config in Gnome). I also need to figure out how to install OSS drivers for my Audigy 2. I read somewhere on a Usenet board that they had drivers that worked for the Audigy 2.

Oh for Suexec, I was using the bf24 option to install the 2.4 series kernel.


All times are GMT -5. The time now is 03:16 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.