nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Kernel 2.6.26.1 and NVIDIA drivers (http://www.nvnews.net/vbulletin/showthread.php?t=118717)

amont 08-30-08 05:39 AM

Kernel 2.6.26.1 and NVIDIA drivers
 
1 Attachment(s)
Hi,

I have got a Debian SID and I have recently upgraded my kernel from 2.6.25.2 to 2.6.26.1.

I run the NVIDA Installer for my GeForce 4 and the installation process produces the attached error.



May you please help me to fix it?

Best


I have used (with the same error) both the 96.43.07 driver and the 100.14.11
A

whig 08-30-08 06:29 PM

Re: Kernel 2.6.26.1 and NVIDIA drivers
 
From the .log,
Quote:

The compiler used to compile the kernel (gcc 4.1) does not exactly match the current compiler (gcc 4.3). The Linux 2.6 kernel module loader rejects kernel modules built with a version of gcc that does not exactly match that of the compiler used to build the running kernel.
Easiest solutions,

Option 1: downgrade to gcc 4.1 to compile nvidia.ko kernel module
Option 2: recompile your current kernel with gcc 4.3

amont 08-31-08 12:26 AM

Re: Kernel 2.6.26.1 and NVIDIA drivers
 
Thank you.

I used a patch found on this forum

http://www.nvnews.net/vbulletin/showthread.php?t=110088

and it was ok with kernel 2.6.25. Unfortunately, this trick is not working with kernel 2.6.26.

Anyway, thank you.

gbil 08-31-08 03:23 AM

Re: Kernel 2.6.26.1 and NVIDIA drivers
 
Quote:

Originally Posted by amont (Post 1762240)
Thank you.

I used a patch found on this forum

http://www.nvnews.net/vbulletin/showthread.php?t=110088

and it was ok with kernel 2.6.25. Unfortunately, this trick is not working with kernel 2.6.26.

Anyway, thank you.

The compilation problem has nothing to do with the patch for the NVidia kernel module.

The error is that your 2.6.26.1 kernel was compiled using gcc 4.1 BUT the installed gcc in your system and the one that will be used to compile the NVidia kernel driver is version 4.3. This might cause incompatibilities and therefore the installer refuses to continue.

amont 08-31-08 03:26 AM

Re: Kernel 2.6.26.1 and NVIDIA drivers
 
But I had the same error with kernel 2.6.25 and using that patch the NVIDIA drivers worked very well.

May you please tell me how I can fix it?

gbil 08-31-08 06:06 AM

Re: Kernel 2.6.26.1 and NVIDIA drivers
 
Quote:

Originally Posted by amont (Post 1762302)
But I had the same error with kernel 2.6.25 and using that patch the NVIDIA drivers worked very well.

May you please tell me how I can fix it?

whig gave a solution but I would be very reluctant to downgrade the distro compiler.

What seems funny though is how debian shipped a new kernel compiled with a gcc version not shipped! Are you sure your system if fully updated or correctly updated?

amont 08-31-08 07:09 AM

Re: Kernel 2.6.26.1 and NVIDIA drivers
 
1 Attachment(s)
I have tried to set the gcc from 4.3 to 4.1, but still the installer does not work.

I have attached the new .log file

Many thanks for any help

gbil 08-31-08 07:32 AM

Re: Kernel 2.6.26.1 and NVIDIA drivers
 
Quote:

Originally Posted by amont (Post 1762348)
I have tried to set the gcc from 4.3 to 4.1, but still the installer does not work.

I have attached the new .log file

Many thanks for any help

This error probably indicates that the wrong kernel development files are installed. Since you updated to 2.6.26.1 kernel have you also updated the dev package? My guess is that only the dev package from 2.6.25 is installed.

amont 08-31-08 08:34 AM

Re: Kernel 2.6.26.1 and NVIDIA drivers
 
I updated using "smart update"

gbil 08-31-08 10:58 AM

Re: Kernel 2.6.26.1 and NVIDIA drivers
 
Quote:

Originally Posted by amont (Post 1762388)
I updated using "smart update"


Well I don't know the exacts mechanics of debian but as I told you probably the kernel dev package is not correct.

amont 09-01-08 02:00 PM

Re: Kernel 2.6.26.1 and NVIDIA drivers
 
Quote:

Originally Posted by gbil (Post 1762425)
Well I don't know the exacts mechanics of debian but as I told you probably the kernel dev package is not correct.

I have got kernel dev updated but Nvida installer does not work.

I think Nvidia 96.xx drivers does not support kernel 2.6.26...

ledoc 09-01-08 02:10 PM

Re: Kernel 2.6.26.1 and NVIDIA drivers
 
There are 96.43.07 packages compiled for 2.6.26 in the debian repositories though.


All times are GMT -5. The time now is 10:26 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.