nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   even VIM runs slowly with KDE 4.1/NVIDIA (http://www.nvnews.net/vbulletin/showthread.php?t=118888)

zetaexmachina 09-03-08 08:24 PM

even VIM runs slowly with KDE 4.1/NVIDIA
 
I never thought the day would come. VIM runs slow on my current system:

2.5ghz dual core
nvidia quadro FX 570M
2GB memory
KDE4.1.1 / Kubuntu

By slow I mainly mean slow scrolling, and not nearly as smooth as my pentium II downstairs. This is particularly noticeable when doing vsplit.

For those interested in reproducing the result, you can try running the following as non-sudo so you don't screw things up, but just to see what I mean:

1. vim /etc/X11/xorg.conf
2. type ":vsplit /etc/X11/xorg.conf"
3. use "ctrl-w-w" to hop between the split views
4. up/down arrow keys to scroll up and down to see what I mean
5. type ":q!" to quit

What's even weirder is that this only occurs during vsplit (vertical split), but not split (which defaults to horizontal split). Anyone?



zetaexmachina

RazZziel 09-04-08 04:00 AM

Re: even VIM runs slowly with KDE 4.1/NVIDIA
 
Try the temporal solutions propposed here, it works fine for me right now with latest .70 driver and no special tricks (with an uptime of only 20 minutes)

kriko 09-04-08 04:14 AM

Re: even VIM runs slowly with KDE 4.1/NVIDIA
 
@zetaexmachina: do you use Xrender for graphical effects?
For me console is slow when using Xrender, switching to openGL or disabling effects resolves this problem.
Also apply tweaks included in sticky post with newest beta drivers.

zetaexmachina 09-04-08 10:46 PM

Re: even VIM runs slowly with KDE 4.1/NVIDIA
 
How do I switch konsole to use Xrender as opposed to opengl?

ledoc 09-04-08 11:09 PM

Re: even VIM runs slowly with KDE 4.1/NVIDIA
 
In systemsettings->Desktop->Effects/Advanced->Compositing type you can switch between OpenGL and XRender.

zetaexmachina 09-05-08 07:43 AM

Re: even VIM runs slowly with KDE 4.1/NVIDIA
 
I'm not even using any desktop effects. Would turning it on actually make it faster? O_o

Bearclaw 09-05-08 07:56 AM

Re: even VIM runs slowly with KDE 4.1/NVIDIA
 
Wait... So Bigman runs slow? Not possible. Try rebooting him.

zetaexmachina 09-05-08 09:43 PM

Re: even VIM runs slowly with KDE 4.1/NVIDIA
 
What exactly is bigman?


All times are GMT -5. The time now is 04:47 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.