nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Debian + nForce Drivers (http://www.nvnews.net/vbulletin/showthread.php?t=11898)

zero_ 05-16-03 12:33 PM

Debian + nForce Drivers
 
Hey!

Debian Woody (2.4.18-bf2.4)

I've desperately tried to install the nForce drivers by making the unpacked package. But I just get plenty of errors - fx in relation to 'modversions.h'. When I try to load the installed soundmodule, it says that it has been compiled for kernel 2.4.18, but this kernel is 2.4.18-bf2.4... I've installed kernel-headers for 2.4.18-bf2.4, but I'm unable to make it work. Could someone please find me a guide or just tell me how to install these drivers correctly?

Thanks a lot :)

galaxor 05-16-03 02:22 PM

Hi,

'Debian-Instructions' don't differ much from 'generic Linux-Instructions':

* get the recent kernel sources: ftp://ftp.kernel.org/pub/linux/kerne...2.4.20.tar.bz2

* get the 2.4.21-rc2 patch: ftp://ftp.kernel.org/pub/linux/kerne...2.4.21-rc2.bz2

* get the nforce agpgart patch (see thread 'nforce2 AGPgart and linux')

* decompress the sources and apply the patches:
cd /usr/src
tar xfj linux-2.4.20.tar.bz2
cd linux
bzip2 -dc ../patch-2.4.21-rc2.bz2 | patch -p1
patch -p1 < ../nforce-agp.diff

* configure, compile and install the kernel
(I suggest not to use the debian-scripts)

* reboot

* get ATI's drivers for XFree86 4.1.x and compile the fglrx.o-Module
(don't use the patches posted in thread 'nforce2 AGPgart and linux' - they
are for the XFree86 4.3.x drivers ONLY):
+++ decompress +++
cd /lib/modules/fglrx/build_mod
sh make.sh
cd ..
sh make_install.sh
depmod -a

* load the agpgart.o-module and use modconf to insert it automatically next
time your Linux boots up

* configure your X-Server to use the ATI-driver (also called fglrx):
dpkg-reconfigure xserver-xfree86

* start your X-Server

(* if you are using a A7N8X-Deluxe get the NVidia drivers for NVidia-NIC/sound)

good luck :)

zero_ 05-17-03 01:54 AM

Isn't is possible to install these drivers wihtout upgrading the kernel? Btw, my motherboard is ASUS A7N8X Deluxe...

galaxor 05-17-03 03:35 AM

Hi,

well, it's not really impossible but probably harder than compiling a new kernel ;)

But you should consider a kernel upgrade for another reason: With the bf2.4-kernel you won't be able to use the UltraDMA-feature of your harddisks and onboard-IDE-controller.

If you like I could make my kernel (together with the ATI-Drivers) available for download.

zero_ 05-17-03 07:00 AM

Kernel
 
Well, the problem is that I receive plenty of errors by upgrading the kernel... When I've installed and chosen the new version via Lilo bootmanager I just get an error that says 'Kernel panic.. Please append correct root/boot option'? What may be wrong? I've set 'root=/dev/hda3' in the lilo.conf, but still it does not work

Thanks a lot!

EDIT: Sorry for the new thread :( Wasn't my intension!

galaxor 05-17-03 11:51 AM

Hi,

your kernel is unable to mount your root filesystem.

Add (if it is not there) the following line to your lilo.conf:

append="root=/dev/hda3 mem=nopentium"

The value in Lilo's 'root=...'-option indicates where Lilo installs its boot-sector. The append-option contains the kernel parameters (->see lilo man-pages).

zero_ 05-17-03 04:39 PM

Network
 
Well, now my I am able to boot with kernel 2.4.20, but my network is unreachable... I've compiled '8139too' with the kernel and loaded it and got this message:

--
8139too Fast Ethernet Driver 0.9.26
eth0: Realtek RTL8139 Fast Ethernet at 0x9000 IRQ 11

Installation succeeded
--

But it does not work :| No connection.. What may be wrong in this situation? It works fine on 2.4.18..

Help please!

galaxor 05-18-03 05:16 AM

Hi,

your A7N8X has two fine onboard-NICs. You probably don't need an extra realtek-NIC.

Your NVidia-NIC works with the nvnet-driver. Your 3com-NIC works without patch from kernel 2.4.21-rc2 on upwards.

use modconf to load your 8139-module on boot-time or edit /etc/modules manually.

don't forget to assign IP-adresses:

Quote:

# /etc/network/interfaces
# The loopback interface
auto lo eth0 eth1
iface lo inet loopback
iface eth0 inet static
address 192.168.10.13
netmask 255.255.255.0

iface eth1 inet static
address 192.168.10.14
netmask 255.255.255.0
# /etc/network/ifstate
lo=lo
eth0=eth0
eth1=eth1

zero_ 05-21-03 08:38 AM

Ive tried hardly, but I cannot make it work :/ But I would like to try your kernel - Can you make it available?

galaxor 05-21-03 02:33 PM

Hi,

here it is (about 2.9MB):

http://www.ldknet.org/hp/mweitzel/ke...21-rc2.tar.bz2

Don't extract it in your /-directory ... or it will probably overwrite a few config-files (I've included the modutil-, X-server and network config-files)

DeVioSiTY 05-22-03 09:16 PM

Nvnet = no compile
 
I have never been able to get the nvidia supplied drivers to actually compile so I can add it into my kernel. I'm using debian 3.0 (woody), and custom kernels. I was running 2.4.21-rc1 and never had any luck getting the nvnet drivers. I figured I would try 2.4.21-rc3 and still have no luck. It errors out with the following: cc -c -Wall -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/usr/src/linux-2.4.21/include nvnet.c
In file included from nvnet.h:20,
from nvnet.c:21:
/usr/src/linux-2.4.21/include/linux/module.h:21:34: linux/modversions.h: No such file or directory
make: *** [nvnet.o] Error 1

Of course I use Debian since Redhat is now less than worthless, and as a matter of principal I never ever have module support. I've submitted a bug to the bug list for these drivers, but that was weeks ago and I doubt they will ever allow this driver to be compile into the kernel. This is on an ASUS A7N8X Deluxe. The only features of this board I am using (or trying to use) are the NICs. I got the 3com to work with some patches, and it should work with the new kernel patch, but I just can never get anything to compile for the garbage nvnet driver supplied from nvidia. Any help will be appreciated.

galaxor 05-23-03 03:28 AM

Hi DeVioSiTY,

the libc6-dev package is automatically installed as soon as you install a C-compiler. This package also contains a directory with the Kernel's header files (/usr/include/linux) because any system/linux specific programming depends on them.

The problem is, that these header files are really outdated (afair kernel version 2.4.9) and don't fit to your custom kernel. Simply do the following:

cd /usr/src
ln -s linux-2.4.21-rc2 linux
cd /usr/include
mv linux linux.old
ln -s /usr/src/linux/include/linux .

...and your header files are up to date and the nvnet-module will compile (as long as you don't delete your /usr/src/linux ;) )


All times are GMT -5. The time now is 03:14 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.