nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   KDE4's Blur plugin problem (http://www.nvnews.net/vbulletin/showthread.php?t=119739)

sheytan 09-20-08 03:19 PM

KDE4's Blur plugin problem
 
THIS IS TO NVIDIA LINUX DRIVER DEVELOPERS:
Hi, I found today that blur plugin in kde4 causes problems with performance and makes black screen when swtiching virtual desktop or using dekstop grind plugin. When i turned it off my KDE runs much much faster with compositing effects. I'm not sure if it's Nvidia's driver problem or Kwin's, but i'm reporting about it here and on kde's bugs site.

NvFuchs 09-20-08 03:49 PM

Re: KDE4's Blur plugin problem
 
Please provide a nvidia bug report created after the problem occured, and give more detailed information on how to reproduce (versions and steps)

Fuchs

xorbe 09-20-08 04:13 PM

Re: KDE4's Blur plugin problem
 
Yeah there is something weird with blur. It also causes the entire screen to shift up 1 pixel (but not the mouse pointer of course). I don't have any non-nVidia machines so I can't compare...

sheytan 09-21-08 05:57 AM

Re: KDE4's Blur plugin problem
 
That bug is known on bugs.kde.org. I'm using the latest beta drivers. Xorg.conf configuerd using nvidia-xconfig, added some lines like this:

Code:

Section "Device"
    Identifier    "Device[0]"
    Driver        "nvidia"
    VendorName    "NVidia"
    BoardName      "GeForec 7600GS"
    Option        "RenderAccel" "true"
    Option        "AddARGBGLXVisuals" "true"
    Option        "AllowSHMPixmaps" "0"
EndSection

and:
Code:

Section "Screen"
    Identifier    "Screen[0]"
    Device        "Device[0]"
    Monitor        "Monitor[0]"
    Option "PixmapCacheSize" "20000000"
    Option "AllowSHMPixmaps" "0"
    SubSection    "Display"
        Modes      "default"
    EndSubSection
    [...]
EndSection

After xserver started i did:
Code:

nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
All efects works fine. Just blur makes a crapy lines on desktop and a black screen when switching virtual desk. Even scalling the konsole window when blur is on makes it slooooow.

NvFuchs 09-21-08 06:49 AM

Re: KDE4's Blur plugin problem
 
Quote:

Originally Posted by NvFuchs (Post 1782952)
Please provide a nvidia bug report created after the problem occured

No further comment.

sheytan 09-21-08 07:07 AM

Re: KDE4's Blur plugin problem
 
where i can fint it? What report do you mean?

NvFuchs 09-21-08 07:29 AM

Re: KDE4's Blur plugin problem
 
http://nvnews.net/vbulletin/showthread.php?t=46678

This one. As the thread title suggests, you should read this first when you have a problem.

A nvidia bug report is a plain text file created with the nvidia-bug-report.sh script, containing lots of usefull information (module versions, full Xorg configuration and log, device information, logs of nvidia related errors ...) which helps nvidia to reproduce and solve your problem.

Fuchs

sheytan 09-21-08 07:41 AM

Re: KDE4's Blur plugin problem
 
http://www.sendspace.com/file/nvsyuv here you are.

adamk75 09-21-08 10:29 AM

Re: KDE4's Blur plugin problem
 
Errr, please just attach the log file to a post here, even if you have to gzip it first. Do not send people to a site that they can't actually download your file from without first waiting in a queue, or spending money.

Adam

sheytan 09-21-08 01:39 PM

Re: KDE4's Blur plugin problem
 
1 Attachment(s)
Attachment 33237


All times are GMT -5. The time now is 03:36 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.