nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Upgraded system, Drivers now cause X to Hang (http://www.nvnews.net/vbulletin/showthread.php?t=11994)

Psychobudgie 05-17-03 07:23 PM

Upgraded system, Drivers now cause X to Hang
 
I have just upgraded my old PIII 866 on a ABit BX133 to a new shiny Athlon 2000XP on a Jetway V400DB (Via KT400 Chipset).

Graphics Card is a Creative GeForce 256 Annihalator Pro DDR 32mb running at 4x AGP (I have tried running it at 1x 2x and 4x)

The only things that have changed are the mobo, chip and memory. Everything is as it was on my old system.

So I put a fresh install of Mandrake 9.1 on, downloaded all the updates (after getting my BT Voyager USB Modem going again) and reinstalled the nvidia 4363 drivers (same ran fine on the BX). Rebooted X and well, Black Screen and CPU at 100%. Boot in to console mode and run startx it bombs out with Fatal Server Error (no screens found).

fell back to the nv driver (which works) and in the log it has : Failed to add GLX Extensions (nvidia xfree86 driver not found).

What is going on, I've tried everything I can think of and I am getting nowhere. Everything else on the system is running great. However as a spent all my money on the new mobo another graphics card is not an option.

Anyone got any suggestions?

All help appreciated

Regards,

Iain Hamilton

bwkaz 05-17-03 10:31 PM

I think you're seeing three different issues here.

First, you saw a problem where X took a high % of CPU and you just had a black screen. I'm not sure what to try with that one, other than maybe taking a look at some of the other Mandrake 9.1 threads, or the other KT400 threads (though I think that driver 4363 is supposed to fix the KT400 issues... well, as long as you're using Option "NvAGP" "1" in your Device section, that is).

The second problem I'm not sure about, since "no screens found" is not the actual error (the actual error either was printed up higher on the screen, or is recorded in the X log), but I'm pretty sure it's that you didn't have the "nvidia" kernel module loaded. Try /sbin/modprobe nvidia as root before doing startx as your normal user, and you'll probably get the same blank screen problem. If so, add alias /dev/nvidia* nvidia to /etc/modules.conf, and run /sbin/depmod -a as root, to make the module autoload when it's needed (with Mandrake, the usual cause of not getting that alias put in there by the driver is that you booted to failsafe mode when installing).

The third thing is that you were still loading nVidia's "glx" extension (libglx.so), but you weren't using nVidia's X driver. The "glx" extension needs the Driver "nvidia" line to be in use before it'll work right.

Fix the modules.conf, and revert to Driver "nvidia", and you should be back to the blank screen. Fix that, and you'll get a working driver (well.... hopefully).

Psychobudgie 05-18-03 04:34 AM

modules.conf is fine, one of the first things I tried. Thanks for the suggestion. However it still fails to load the kernal. I've officially gone nuts now. Was up until 5 this morning trying out many varied solutions however I'm right back at square 1 again. Load nvidia and grey screen CPU maxed out, load nv all is right with 2D. I feel like crying.

bwkaz 05-18-03 07:13 AM

Are you using Option "NvAGP" "1"? Note that it's case sensitive...

Current agpgart implementations don't support the KT400 well enough.


All times are GMT -5. The time now is 07:16 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.