nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   Crysis (http://www.nvnews.net/vbulletin/forumdisplay.php?f=59)
-   -   My Warhead Config (http://www.nvnews.net/vbulletin/showthread.php?t=120070)

FastRedPonyCar 09-27-08 08:10 AM

My Warhead Config
 
I tweaked the Xconfig 1.3 autoexe file with different SSAO and HDR settings along with turning off POM, turning on battle dust, some terrain ao settings, etc...

I give the Xconfig guy full credit.

Code:

;XCFG Package version 1.3
;Very High config
;Compatible with Crysis 1.2
;Created by xGj
-Do not distribute without authors permission-

### Testing vars ###


r_displayinfo=0 -- Set to 1 to show FPS count and other information
con_restricted=0

### Control stock settings ###
sys_spec_GameEffects = 3
sys_spec_ObjectDetail = 3
sys_spec_Particles = 3
sys_spec_Physics = 3
sys_spec_PostProcessing = 3
sys_spec_Quality = 3
sys_spec_Shading = 3
sys_spec_Shadows = 3
sys_spec_Sound = 3
sys_spec_Texture = 3
sys_spec_VolumetricEffects = 3
sys_spec_Water = 3

### Objects settings ###
ca_AttachmentCullingRation = 200
ca_DrawFaceAttachments = 1
ca_UseDecals = 1
e_cbuffer_resolution = 256
e_decals_allow_game_decals = 1
e_decals_life_time_scale = 2
e_decals = 1

e_dissolve = 1
e_lod_min = 0
e_lod_ratio = 5
e_obj_quality = 3
e_view_dist_ratio = 60
e_view_dist_ratio_detail = 33
es_DebrisLifetimeScale = 0.6
i_rejecteffects = 1
sys_flash_curve_tess_error = 2
e_terrain_occlusion_culling = 1
e_terrain_occlusion_culling_max_dist = 200
e_terrain_occlusion_culling_version = 0
e_terrain_lod_ratio = 0.8
e_lods = 1

 
### Post Processing settings ###

r_ColorGrading = 1
r_DepthOfField = 1
r_MotionBlur = 1
cl_hitblur = 0
cl_hitShake = 0
g_Dof_Ironsight = 1

### Shader settings ###

r_DetailDistance = 8
r_DetailNumLayers = 2
r_DetailTextures = 1
r_EnvTexUpdateInterval = 0.05
r_FillLights = 7
r_HairSortingQuality = 1
r_LightsSinglePass = 0
e_max_entity_lights = 11
e_particles_lights = 1
e_ram_maps = 1
e_sky_type = 1
e_sky_update_rate = 1
e_terrain_ao = 1
e_terrain_normal_map = 0
e_vegetation_use_terrain_color = 1
q_Renderer = 3
q_ShaderFX = 3
q_ShaderGeneral = 3
q_ShaderGlass = 3
q_ShaderHDR = 3
q_ShaderMetal = 3
q_ShaderPostProcess = 3
q_ShaderIce = 3
q_ShaderShadow = 2
q_ShaderSky = 3
q_ShaderTerrain = 3
q_ShaderVegetation = 3
sys_flash_edgeaa = 1


### Particles settings ###

e_particles_lod = 1
e_particles_max_emitter_draw_screen = 20
e_particles_quality = 3
e_particles_object_collisions = 1
r_UseSoftParticles = 1
e_particles_thread=1
e_particles_receive_shadows = 1


### Shadow settings ###

e_shadows = 1
e_shadows_cast_view_dist_ratio = 0.8
e_shadows_max_texture_size = 1024
e_shadows_from_terrain_in_all_lods = 1
e_shadows_on_alpha_blended = 1
e_gsm_cache = 1 --Change to 0 if running SLi or CrossFire
e_gsm_lods_num = 5
e_gsm_range = 3
e_gsm_range_step = 2
r_ShadowJittering = 1.5
r_ShadowBlur = 0
r_ShadowsMaskResolution = 0

### Sound settings ###

s_CacheSize = 80
s_FormatSampleRate = 48000
s_MPEGDecoders = 32
s_Obstruction = 1
s_ObstructionAccuracy = 1
s_ObstructionUpdate = 0.1
s_ReverbType = 1 -- 1 is EAX sound, set to 2 (software) if needed
s_SoundMoodsDSP = 1
s_VariationLimiter = 1

### Water settings ###

r_WaterCaustics = 1
r_WaterReflections = 1
r_WaterReflectionsQuality = 2
r_WaterRefractions = 1
r_WaterUpdateDistance = 0.2
r_WaterUpdateFactor = 0.05
r_WaterGodRays = 1
r_WaterReflectionsMinVisiblePixelsUpdate = 0.001
q_ShaderWater = 2
e_water_ocean_fft = 1
e_water_ocean_soft_particles = 1
e_water_tesselation_amount = 8
e_water_tesselation_swath_width = 10

### Vegetation settings ###

e_vegetation_static_instancing=0
e_vegetation_sprites_distance_ratio = 1
e_cull_veg_activation = 50
e_view_dist_ratio_vegetation = 50
e_proc_vegetation = 1
e_vegetation_bending = 2
e_vegetation_min_size = 0
e_vegetation_sprites_distance_custom_ratio_min = 1
e_vegetation_wind = 1
 

### Viewdistance settings ###

e_detail_materials_view_dist_xy = 4096
e_detail_materials_view_dist_z = 256
e_max_view_dst_spec_lerp = 1

### Physics ###

e_foliage_wind_activation_dist = 25
e_phys_foliage = 2
e_phys_ocean_cell = 0.5
es_MaxPhysDist = 180
es_MaxPhysDistInvisible = 25
g_breakage_particles_limit = 220
g_joint_breaking = 1
g_tree_cut_reuse_dist = 0
p_max_MC_iters = 6000
p_max_substeps_large_group = 5
p_num_bodies_large_group = 100
sys_physics_cpu = 1
es_ondemandphysics = 1
gpu_particle_physics = 1

### Lighting & Volumetric settings ###

-- Sunshafts --
r_sunshafts = 1
r_Beams = 3
r_BeamsDistFactor = 0.03
r_BeamsMaxSlices = 220
e_clouds = 1
r_CloudsUpdateAlways = 1
r_Coronas = 1
r_Flares = 1
r_CoronaFade = 0.5

### HDR + AO settings ###

r_SSAO = 1
r_SSAO_darkening = 0.6
r_ssao_quality = 2
r_ssao_radius = .1
r_ssao_amount 0.6
r_HDRRendering = 1
r_EyeAdaptionClamp = 2.5
r_HDRlevel = .6
r_hdrbrightoffset = 15
r_HDRBrightTreshold = 20
r_SSAO_blur = 1
r_SSAO_blurrines .8
r_Glow = 1
r_GlowScreenMultiplier = 0.2
r_TerrainAO = 7
r_TerrainAO_FadeDist=0.1
r_eyeadaptationbase=0.3


### Texture Settings ###

r_usepom = 0
r_DynTexMaxSize = 80
r_EnvTexResolution = 3
r_EnvCMResolution = 2
r_ImposterRatio = 1
r_TexAtlasSize = 1024
r_TexturesStreaming = 0
r_TexSkyResolution = 0
r_TexBumpResolution = 0
r_TexResolution = 0
r_TexturesFilteringQuality = 0
r_DynTexAtlasSpritesMaxSize = 24
sys_LowSpecPak = 0
r_VegetationSpritesTexRes = 128
r_DynTexAtlasCloudsMaxSize = 32


### Various tweaks ###

--- Optimization ---
r_GeomInstancing=1
e_cbuffer = 2
r_CullGeometryForLights = 1
e_recursion_occlusion_culling = 1
e_hw_occlusion_culling_objects = 1
e_hw_occlusion_culling_water = 1
e_precache_level = 1
e_particles_preload = 1
v_vehicle_quality = 4

--- Game specific ---
g_battleDust_enable = 1
g_ragdollDistance = 30
g_ragdollMinTime = 15
i_lighteffects = 1


--- Anti Aliasing ---

r_useEdgeAA = 1

--- Enable CrossFire or SLi (dual graphics cards) ---
r_MultiGPU = 2 ---Set to 1 force enable

----- xGj 2008 -----



And now of course the obligatory screen shots. I was tweaking this config throughout the entire game so they aren't ALL of this exact config but they're all close enough as the only changes I made were very minor.

Also note the FPS in various areas.

I used 1680X1050 with no AA or AF. I'm sure I could put AA to 2 or 4 with what I would hope to be a negligible increase but I haven't played around with that yet.


http://img.photobucket.com/albums/v2...1-14-10-13.jpg

http://img.photobucket.com/albums/v2...0-40-24-66.jpg

http://img.photobucket.com/albums/v2...7-27-40-42.jpg

26 fps (about as low as it will usually go) in the heavily populated ice sections.

http://img.photobucket.com/albums/v2...06-37-10-1.jpg

http://img.photobucket.com/albums/v2...7-37-28-30.jpg

http://img.photobucket.com/albums/v2...7-24-32-37.jpg

http://img.photobucket.com/albums/v2...7-24-59-10.jpg

http://img.photobucket.com/albums/v2...7-53-16-59.jpg

$n][pErMan 09-27-08 03:30 PM

Re: My Warhead Config
 
Those shots DX9 or DX10?

Dreamingawake 09-27-08 04:26 PM

Re: My Warhead Config
 
How do we use this config??

XDanger 09-27-08 05:11 PM

Re: My Warhead Config
 
copy the text in a notepad text file and rename it autoexec.cfg and put it here
X:\Program Files\Steam\steamapps\common\crysis warhead\autoexec.cfg
, save your previous .cfg if you have one by re-naming it autoexec.cfg.orig or whatever.

I like this config, It is nice,

Thankyou very mutch

Soetdjuret 09-27-08 08:30 PM

Re: My Warhead Config
 
Thanks alot red, this config is perfect for me, this allows me to use 2 or 4 times AA with my SLI setup ;)

Buio 09-28-08 12:54 AM

Re: My Warhead Config
 
I tested this config, it looks good, but for me performance went down.

Also, checking the game.log file, there is several "[Warning] Unknown command". But I also saw some random occurances of that warning, so don't know what's to be trusted.

I get for these:
Code:

[Warning] Unknown command: e_particles_max_emitter_draw_screen = 20
[Warning] Unknown command: r_WaterUpdateDistance = 0.2
[Warning] Unknown command: r_WaterUpdateFactor = 0.05
[Warning] Unknown command: r_HDRBrightTreshold = 20
[Warning] Unknown command: r_SSAO_blurrines .8


gerardfraser 09-28-08 01:34 AM

Re: My Warhead Config
 
@fastredponycar

I have seen a few CFG you put up in the fourms,and they were good.
This one however is not good,so i took it upon myself to get it fixed for you and with better FPS

Your CFG Ice Level
http://img1.hugeup.com/t/09272008/0c6473c5e.jpg

Your fixed one now
http://img1.hugeup.com/t/09272008/3a3b1a1.jpg

Fixed one with added slow motion,binded key which you can change Q for slowmotion 3 to return to normal

Code:

con_restricted=0
r_displayinfo = 0
r_width =
r_height =
bind q time_scale .3
bind 3 time_scale 1

;XCFG Package version 1.3
;Very High config
;Compatible with Crysis 1.2
;Created by xGj
-Do not distribute without authors permission-

### Testing vars ###


r_displayinfo=0 -- Set to 1 to show FPS count and other information
con_restricted=0

### Control stock settings ###
sys_spec_GameEffects = 4
sys_spec_ObjectDetail = 4
sys_spec_Particles = 4
sys_spec_Physics = 4
sys_spec_PostProcessing = 4
sys_spec_Quality = 4
sys_spec_Shading = 4
sys_spec_Shadows = 4
sys_spec_Sound = 4
sys_spec_Texture = 4
sys_spec_VolumetricEffects = 4
sys_spec_Water = 4

### Objects settings ###
ca_AttachmentCullingRation = 200
ca_DrawFaceAttachments = 1
ca_UseDecals = 1
e_cbuffer_resolution = 256
e_decals_allow_game_decals = 1
e_decals_life_time_scale = 2
e_decals = 1

e_dissolve = 1
e_lod_min = 0
e_lod_ratio = 5
e_obj_quality = 3
e_view_dist_ratio = 60
e_view_dist_ratio_detail = 33
es_DebrisLifetimeScale = 0.6
i_rejecteffects = 1
sys_flash_curve_tess_error = 2
e_terrain_occlusion_culling = 1
e_terrain_occlusion_culling_max_dist = 200
e_terrain_occlusion_culling_version = 0
e_terrain_lod_ratio = 0.8
e_lods = 1

 
### Post Processing settings ###

r_ColorGrading = 0
r_DepthOfField = 2
r_MotionBlur = 1
cl_hitblur = 0
cl_hitShake = 0
g_Dof_Ironsight = 1

### Shader settings ###

r_DetailDistance = 8
r_DetailNumLayers = 2
r_DetailTextures = 1
r_EnvTexUpdateInterval = 0.75
r_FillLights = 7
r_HairSortingQuality = 0
r_LightsSinglePass = 0
e_max_entity_lights = 11
e_particles_lights = 1
e_ram_maps = 1
e_sky_type = 1
e_sky_update_rate = 1
e_terrain_ao = 1
e_terrain_normal_map = 0
e_vegetation_use_terrain_color = 1
q_Renderer = 2
q_ShaderFX = 3
q_ShaderGeneral = 2
q_ShaderGlass = 3
q_ShaderHDR = 3
q_ShaderMetal = 3
q_ShaderPostProcess = 2
q_ShaderIce = 3
q_ShaderShadow = 2
q_ShaderSky = 3
q_ShaderTerrain = 3
q_ShaderVegetation = 3
sys_flash_edgeaa = 1


### Particles settings ###

e_particles_lod = 1
e_particles_max_emitter_draw_screen = 20
e_particles_quality = 3
e_particles_object_collisions = 0
r_UseSoftParticles = 1
e_particles_thread=1
e_particles_receive_shadows = 1


### Shadow settings ###

e_shadows = 1
e_shadows_cast_view_dist_ratio = 0.8
e_shadows_max_texture_size = 768
e_shadows_from_terrain_in_all_lods = 0
e_shadows_on_alpha_blended = 1
e_gsm_cache = 0 --Change to 0 if running SLi or CrossFire
e_gsm_lods_num = 5
e_gsm_range = 3

r_ShadowJittering = 1.5
r_ShadowBlur = 0
r_ShadowsMaskResolution = 0

### Sound settings ###

s_CacheSize = 80
s_FormatSampleRate = 48000
s_MPEGDecoders = 32
s_Obstruction = 1
s_ObstructionAccuracy = 1
s_ObstructionUpdate = 0.1
s_ReverbType = 1 -- 1 is EAX sound, set to 2 (software) if needed
s_SoundMoodsDSP = 1
s_VariationLimiter = 1

### Water settings ###

r_WaterCaustics = 1
r_WaterReflections = 1
r_WaterReflectionsQuality = 2
r_WaterRefractions = 1
r_WaterUpdateDistance = 0.2
r_WaterUpdateFactor = 0.05
r_WaterGodRays = 1
r_WaterReflectionsMinVisiblePixelsUpdate = 0.001
q_ShaderWater = 2
e_water_ocean_fft = 1
e_water_ocean_soft_particles = 1
e_water_tesselation_amount = 8
e_water_tesselation_swath_width = 10

### Vegetation settings ###

e_vegetation_static_instancing=0
e_vegetation_sprites_distance_ratio = 1
e_cull_veg_activation = 50
e_view_dist_ratio_vegetation = 50
e_proc_vegetation = 1
e_vegetation_bending = 2
e_vegetation_min_size = 0
e_vegetation_sprites_distance_custom_ratio_min = 1
e_vegetation_wind = 1
 

### Viewdistance settings ###

e_detail_materials_view_dist_xy = 4096
e_detail_materials_view_dist_z = 256
e_max_view_dst_spec_lerp = 1

### Physics ###

e_foliage_wind_activation_dist = 25
e_phys_foliage = 2
e_phys_ocean_cell = 0.5
es_MaxPhysDist = 180
es_MaxPhysDistInvisible = 25
g_breakage_particles_limit = 220
g_joint_breaking = 1
g_tree_cut_reuse_dist = 0
p_max_MC_iters = 6000
p_max_substeps_large_group = 5
p_num_bodies_large_group = 6w0


### Lighting & Volumetric settings ###

-- Sunshafts --
r_sunshafts = 1
r_Beams = 3
r_BeamsDistFactor = 0.03
r_BeamsMaxSlices = 220
e_clouds = 1
r_CloudsUpdateAlways = 1
r_Coronas = 1
r_Flares = 1


### HDR + AO settings ###

r_SSAO = 1
r_SSAO_darkening = 0.3
r_ssao_quality = 1
r_ssao_radius = 1
r_ssao_amount 0.2
r_HDRRendering = 2

r_HDRlevel = .6

r_SSAO_blur = 1
r_SSAO_blurrines .8

r_GlowScreenMultiplier = 0.2
r_TerrainAO = 7
r_TerrainAO_FadeDist=0.1



### Texture Settings ###

r_usepom = 1
r_DynTexMaxSize = 80
r_EnvTexResolution = 3
r_EnvCMResolution = 2
r_ImposterRatio = 1
r_TexAtlasSize = 1024
r_TexSkyResolution = 0
r_TexBumpResolution = 0
r_TexResolution = 0
r_TexturesFilteringQuality = 0
r_DynTexAtlasSpritesMaxSize = 24
sys_LowSpecPak = 0
r_VegetationSpritesTexRes = 128
r_DynTexAtlasCloudsMaxSize = 32


### Various tweaks ###

--- Optimization ---
r_GeomInstancing=1
e_cbuffer = 1
r_CullGeometryForLights = 1
e_recursion_occlusion_culling = 1
e_particles_preload = 1
v_vehicle_quality = 4

--- Game specific ---
g_battleDust_enable = 1
g_ragdollDistance = 30
g_ragdollMinTime = 15
i_lighteffects = 1

r_TexturesStreaming = 0
--- Anti Aliasing ---

r_useEdgeAA = 1

--- Enable CrossFire or SLi (dual graphics cards) ---
r_MultiGPU = 2 ---Set to 1 force enable

----- xGj 2008 -----


Buio 09-28-08 01:51 AM

Re: My Warhead Config
 
I removed the ones giving [Warning] Unknown command: as per my post above and after that the log was ok. Maybe stuff that worked in Crysis but is not in Warhead?



Btw gerardfraser, doesn't the commands r_width = 1920 and r_height = 1080 set the resolution? That means you should not put those in the cfg, because not everyone has a 1920 capable monitor? Or am I wrong?

Also, you set r_displayinfo 1 at the start, then r_displayinfo 0 bit later.

gerardfraser 09-28-08 02:07 AM

Re: My Warhead Config
 
Quote:

Originally Posted by Buio (Post 1790735)
I removed the ones giving [Warning] Unknown command: as per my post above and after that the log was ok. Maybe stuff that worked in Crysis but is not in Warhead?



Btw gerardfraser, doesn't the commands r_width = 1920 and r_height = 1080 set the resolution? That means you should not put those in the cfg, because not everyone has a 1920 capable monitor? Or am I wrong?

Also, you set r_displayinfo 1 at the start, then r_displayinfo 0 bit later.

DOH your correct sir,and its corrected now thanks

Buio 09-28-08 02:08 AM

Re: My Warhead Config
 
I'm gonna test yours in a moment, but have to set some stuff a bit lower as my comp can't handle everything at max.

gerardfraser 09-28-08 02:56 AM

Re: My Warhead Config
 
Cool love to see what ya get,I just changed the other one to fix some stuff

FastRedPonyCar 09-28-08 07:20 AM

Re: My Warhead Config
 
gerard, the ice looked pretty bad in my config but I couldn't figure out what was making the edges of the ice and snow covered rocks look the way they did. I thought it was something to do with just the way the textures were..

what did you change to get rid of them?

I ask so I can go tell the author of Xconfig over at the incrysis forums what to change.


All times are GMT -5. The time now is 08:24 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.