nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   Corruption in 177.78 BETA driver (http://www.nvnews.net/vbulletin/showthread.php?t=120280)

rnejdl 09-30-08 10:01 PM

Corruption in 177.78 BETA driver
 
I'm seeing image corruption in my buttons and other screen features running KDE 4.1. I have seen in the linux forum that this might be an issue with the damage events occuring before the buffer is filled and ready. Is anyone else seeing this and NVIDIA, are you working on fixing this before releasing the next driver?

Thanks!
Rusty Nejdl

zander 10-01-08 10:39 AM

Re: Corruption in 177.78 BETA driver
 
Please provide more information on what kind of corruption you're seeing, with which hardware you're seeing it and how to reproduce the problem (see http://www.nvnews.net/vbulletin/showthread.php?t=46678). Please also check the 'NVIDIA Linux' forum to see if other users reported similar problems.

rnejdl 10-01-08 09:20 PM

Re: Corruption in 177.78 BETA driver
 
2 Attachment(s)
I've attached a bug report as well as an image showing the image corruption in the menu of my paint program. If I try to save a document and then I move my mouse over the buttons, the buttons corrupt or I get some corruption of the text in the menus. I haven't seen this in the other betas. I am running IPP=2. I've seen other reports of corruption but I cannot tell if this is exactly the same issue or something else. I'll try some more testing tonight to see what I can find.

Thanks!
Rusty Nejdl

rnejdl 10-02-08 10:05 PM

Re: Corruption in 177.78 BETA driver
 
I saw some comments in the linux form and tried these settings in xorg.conf:

Option "RenderAccel" "true"
Option "UseEvents" "false"
Option "TripleBuffer" "True"
Option "DamageEvents" "True"
Option "BackingStore" "True"
Option "AllowIndirectPixmaps" "true"
Option "AddARGBGLXVisuals" "True"
Option "PixmapCacheSize" "1000000"
Option "AllowSHMPixmaps" "False"

I am no longer seeing any artifacts. I'm not sure what is going to be made default but I was running a very clean setup earlier with just:

Option "AddARGBGLXVisuals" "True"
Option "PixmapCacheSize" "3000000"
Option "AllowSHMPixmaps" "0"

So, it appears that one of those options has corrected this for me that I had not explicitly mentioned earlier.

Rusty

marlll 11-03-08 03:30 AM

Re: Corruption in 177.78 BETA driver
 
Hard topic(nana2)


Used Cargo Container


All times are GMT -5. The time now is 07:17 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.