nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   177.78 performance (http://www.nvnews.net/vbulletin/showthread.php?t=120505)

HenryHu 10-04-08 12:44 PM

177.78 performance
 
I'm using a laptop with Core Duo T7500 @ 2.2GHz, GeForce 8600MGS.
With kwin, glxgears runs at ~4700 FPS.
With compiz, glxgears runs at ~1400 FPS with an empty desktop.
As I remember, it used to run faster.
How about yours?

rnejdl 10-05-08 08:25 AM

Re: 177.78 performance
 
It seems a bit laggy as I seem to recall having performance around 3 times as high:

15346 frames in 5.0 seconds = 3069.139 FPS
18023 frames in 5.0 seconds = 3604.567 FPS
17775 frames in 5.0 seconds = 3553.541 FPS
17033 frames in 5.0 seconds = 3406.100 FPS
17883 frames in 5.0 seconds = 3576.588 FPS

Rusty

HenryHu 10-05-08 10:05 AM

Re: 177.78 performance
 
Quote:

Originally Posted by rnejdl (Post 1798467)
It seems a bit laggy as I seem to recall having performance around 3 times as high:

15346 frames in 5.0 seconds = 3069.139 FPS
18023 frames in 5.0 seconds = 3604.567 FPS
17775 frames in 5.0 seconds = 3553.541 FPS
17033 frames in 5.0 seconds = 3406.100 FPS
17883 frames in 5.0 seconds = 3576.588 FPS

Rusty

Which card are you using? Do you use compiz/beryl?

rnejdl 10-06-08 10:53 PM

Re: 177.78 performance
 
hw.nvidia.cards.0.model: GeForce 9600 GT

I use KDE 4.1 with it's built in effects. When I tried compiz previously, it was not a pleasant experience.

Rusty

Enderbsd 10-07-08 12:19 AM

Re: 177.78 performance
 
SLI 8800M GTX's here.

3141 frames in 5.0 seconds = 628.113 FPS
2420 frames in 7.5 seconds = 320.869 FPS
3458 frames in 5.0 seconds = 690.484 FPS
4892 frames in 5.0 seconds = 978.145 FPS

See this thread
http://www.nvnews.net/vbulletin/showthread.php?t=120310

Attribute 'GPUPerfModes' (pcbsd:0.0): perf=0, nvclock=200, memclock=100 ; perf=1,
nvclock=275, memclock=301 ; perf=2, nvclock=383, memclock=301 ; perf=3, nvclock=500,
memclock=799


Attribute 'GPUCurrentPerfMode' (pcbsd:0.0): 1.
Attribute 'GPUCurrentPerfLevel' (pcbsd:0.0): 1.
Attribute 'GPUAdaptiveClockState' (pcbsd:0.0): 1.
Attribute 'GPUPowerSource' (pcbsd:0.0): 1.
FreeBSD 8.0-CURRENT #0: Sun Oct 5 20:51:00 EDT 2008

I can not get the powermizer mode to go over 1 to save my life. I have tried every single combo of
Option "RegistryDwords" "PowerMizerLevelAC=0x3"
Option "RegistryDwords" "PowerMizerLevel=0x3"
Powerlevelsrc 0x3333 0x3322 in my xorg.conf i have tried in my boot/loader.conf i have even tried editing the driver source code src/nv-reg.h and adding the dwords inside the driver and recompiling. Nothing will move this thing past powermizer level 1 out of 3. (trying other nvidia driver versions actually made it run in power level 0 which is worse)

I hope there is an update that fixes this soon.


I would like to thank Nvidia for supporting freebsd.

Enderbsd 11-06-08 08:24 PM

Re: 177.78 performance
 
This still happens in 177.80

Can not get powermizer over level 1 to save my life (level 0-3 3 being fullspeed)


All times are GMT -5. The time now is 05:09 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.