nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Redhat 9 and NVIDIA Drivers Not Working (http://www.nvnews.net/vbulletin/showthread.php?t=12124)

Guyser 05-20-03 06:56 AM

Redhat 9 and NVIDIA Drivers Not Working
 
1 Attachment(s)
I don't know how more obvious I could have made the topic title

AMD Athlon 750
PNY GeForce 3 ti 200
Soyo k7-vta
Redhat 9 shrike
Of course I'm using the 4363 drivers

I installed the drivers exactly how I was told. I edited the XF86Config file replaced driver "nv" with "nvidia" then system locks up when I try to log in to Xserver

This also is the same case in redhat 8.0. The "nv" driver works fine in 2d with no 3d, "nvidia" just won't let you boot into x at all. There was some sample config file that got intalled with the drivers. I took a look at it and tried pasting some of the stuff I thought I may need, that ended up screwing up my config even more.

Guyser 05-20-03 07:07 AM

and as far as I can remember using linux not one of nvidia's drivers have ever worked in any distro I have used, other than the standard 2d nv drivers that come with some rh versions

DrOzz 05-20-03 11:10 AM

well d00d, i don't know what to tell you other than the fact that i had the exact same problem on my AMD T-Bird1.2ghz using AOpen AK73-Pro(A) mobo...i have tried RH8, RH9, MDK9.1, and MDK8.2...now i don't know if you wanna try this, but the following link i will give you is the steps i took, and i have gotten it to work...its up to yoU :P

My Steps To Ridding Lockups

cjmace 05-20-03 01:12 PM

I had a similar problem..

This fixed it for me:

1) nvidia-install --uninstall
2) rpm -q -a | grep XFree > /tmp/foo
3) (in a csh variant)
foreach x (`cat /tmp/foo`)
echo $x
rpm -V $x
end
4) Go to your distribution and download any and all rpms that had any errors.
5) Go to the NVIDIA site and download the driver with version 4349 from the archive site.
6) Go to the console and issue 'telinit S'
7) rpm --erase --nodeps XXXX Where XXXX are the damaged rpms
8) rpm --install XXXX Where XXXX are the damaged rpms you downloaded
9) Run the script from nvidia ONCE and only ONCE.
10) Double check the XF86Config.
11) Reboot.

This fixed mine. I wasnt able to get GLX working with the new driver, and when I put 'nvidia' instead of 'nv' in my config with the new driver, my X freaked out. I got regular X with 'nv' but not glx. I think the new driver is just bugged for redhat.

-cjohn

cjmace 05-20-03 03:36 PM

ps, since i was bored today, i ran the nvidia-installer --update. It did manage to upgrade the version to 4363 and everything is working.

-cjohn


All times are GMT -5. The time now is 06:30 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.