nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   A7N8X Deluxe & Mandrake 8.2 Probs (http://www.nvnews.net/vbulletin/showthread.php?t=12143)

mooseshoes 05-20-03 04:19 PM

A7N8X Deluxe & Mandrake 8.2 Probs
 
All:

I'm trying to get my Asus A7N8X Deluxe NVIDIA LAN connection (and audio too) to work on my MDK 8.2 system and have not been successful with the binary RPM that I downloaded from NVIDIA support which was supposedly created for my distribution, OS version and kernel version.

I'm looking for resources that could assist me with this matter.

Please advise.

Thanks in advance,

Moose

erwos 05-20-03 07:22 PM

You need to be a little bit more specific with regards to any errors you're seeing.

"It doesn't work" doesn't tell us much.

-Erwos

mooseshoes 05-20-03 09:42 PM

OK, Erwos, I'll bite...

I was looking for a link to some information, but since you have demonstrated an interested, here is some more data -

I have been able to get the NVIDIA LAN port working before though admittedly I must have stumbled into it. I have the RPM's from both the ASUS site and NVIDIA site. The NVIDIA RPM's are hard to resist for me because they have MDK and 8.2 right in the file name and despite the fact that the ASUS download site insists to only use their drivers, I have tried both. When I load the NVIDIA MDK 8.2 drivers from the RPM, upon reboot I get an error message that ETH0 has failed to configure. The strange part about this is that following the booting sequence if I go into Mandrake's Control Center utility and look at the LAN connection is shows that LAN Configuration ETH0 is up using driver, nvnet. The Internet Connection, however, doesn't work when it tries to connect. Additionally, I can't connect to the outside world using, for example, a web browser.

Now, if the drivers would have appeared in the list of available drivers for the network connection that would have been lovely, but I'm guessing this doesn't happen because everything is on the board. Quite honestly I would be happy to use the 3COM interface as well, but by the looks of things that would be like trying to squeeze water from a rock.

I'm happy to provide you with as much information as I can (since you're being so helpful) and if you happen to get me up and running I'll treat you to a Fat Burger and fries next time you're in L.A.

Thanks,

Moose

mooseshoes 05-20-03 09:44 PM

More clarification -

I had reloaded my OS (MDK 8.2 Powerpack Edition) which is why my connection is no longer working. It was a clean slate install.

Moose

leibold 05-20-03 11:55 PM

Actually from what you are saying it appears that the installation of the nvnet driver was successfull, just that you can't actually communicate.

To confirm that run (as root):
lsmod
ifconfig -a

The output of the first command should include 'nvnet' for the nforce NIC and either '3c59x' or '3c90x' for the 3Com NIC.
The output of the second command should include lines starting with 'eth' like:
eth0 Link encap: Ethernet HWaddr 00:E0:18:xx:xx:xx
eth1 Link encap: Ethernet HWaddr 00:26:54:xx:xx:xx

In this case nvnet (the nforce NIC) is eth0 and the 3Com NIC is eth1 (the first half of the MAC address is the vendor code).

One common problem with the network communication on the A7N8X is that acpi needs to be either turned off completely (acpi=off) or at least ignored for the purpose of assigning PCI interrupts (pci=noacpi). These options can be specified on the boot command line in lilo or grub. Add them to /etc/lilo.conf or /boot/grub/menu.lst to make them permanent.

mooseshoes 05-21-03 09:31 AM

Leibold:

Thanks for the response. I checked lsmod and found the "nvnet" output and then ran ifconfig and got the "eth0 Link..." output as well. I don't have anything for eth1.

I then put the following lines in my lilo.conf file:

acpi=off
pci=noacpi

Following this I rebooted and got the same message:

"Bringing up interface eth0 - [FAILED]"

I appreciate your suggestions and will be happy to try some more.

Best,

Moose

leibold 05-21-03 12:23 PM

"Bringing up eth0: Failed" does not have to be bad news. It could mean that you configured the nic to get it's IP address automatically from a DHCP server and it didn't get one (or not quickly enough, or one it didn't like :-).

First thing to check is that you are actually having the network cable plugged into the right port. The nforce (nvnet) nic is the connector between all the audio connections.

You say you added those two lines to the /etc/lilo.conf file ? You really only need one or the other, not both. More importantly you can't just add them as lines to /etc/lilo.conf. There should be an 'image' section for each lilo boot option. Locate the 'image' section that you are normally booting and see if it already has any 'append=' statement. If it does add one of the statements to the string. If not add the following line to that section:
append = " acpi=off"

The run /sbin/lilo in order for the change to take effect.

mooseshoes 05-22-03 12:39 AM

Leibold:

Here is the latest. I made the changes you suggested, unfortunately without success. Here is what the image section of my lilo.conf file looks like for the relevant boot area:

image=/boot/vmlinuz
label=linux
root=/dev/hda1
initrd=/boot/initrd.img
append="devfs=mount quiet acpi=off"
vga=788
read only

Basically things are the same. Please let me know if my syntax is wrong. Incidentally I did run /sbin/lilo and then rebooted. I tried it with both acpi=off and pci=noacpi.

I'm very sorry to bother you with this, but I feel like we're close here. Any other thoughts?

Best,

Moose

leibold 05-22-03 08:01 AM

That lilo.conf syntax looks good. I'm slowly starting to run out of ideas. You are sure that the cable connection to the NIC is working properly ? Is the link led on the network connector lit ?
What kind of network are you connecting the pc to, perhaps try manually setting the IP address for the NIC with ifconfig ?
E.g.:
ifconfig eth0 192.168.0.50 netmask 255.255.255.0 up

mooseshoes 05-22-03 05:15 PM

Leibold:

Well, I'm throwing in the towel and upgrading to MDK 9.1 which supports the board right out of the box. Normally, I'd use this as a learning opportunity but I'm a bit strapped for time.

You earned yourself that Fat Burger and fries though so if you find yourself in Los Angeles, drop me a note and you can cash in your IOU.

Thanks for your help!

Moose


All times are GMT -5. The time now is 09:13 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.