nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   How do you NOT startX (http://www.nvnews.net/vbulletin/showthread.php?t=12150)

JJacob 05-20-03 05:59 PM

How do you NOT startX
 
Ok so I never was able to get mandrake to stabaly use my Nvidia drivers. I got Red hat 8 to work perfectly without installing the drivers. I want to update them and I have X start automatically and I can't run the install from X, how do I close X and return to just the terminal? Mandrake has a failsafe, but the redhat failsafe opens up in X. I know how to reboot, and shut down, but when my comp comes back on I am still in X... I know this has got to be really simple, someone please clue me in.

connyosis 05-20-03 06:18 PM

I'm sure there is some option in Mandrakes configcenter that allows you not to start X automatically at bootup.
I myself use Slackware but Mandrake should also have a file called /etc/inittab
In this file there is a line that goes something like:

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

Change this to

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

instead and when you reboot you will be left at the login prompt in the console. Now just login and upgrade your driver. When you're done change the line back to its original state and reboot. Voila!

nikolokolus 05-20-03 06:26 PM

I'm not sure what the procedure is under Redhat or Mandrake (i use SuSE), but you need to edit your default runlevel to '3' instead of '5'.

If you use grub as a bootloader just hit the "up" arrow and enter the number '3' in the boot parameters line (bottom of the screen). Otherwise, your distro shold tell you how to change the deafult runlevel in the user manual. (I hope!!)

Hope this helps.

JJacob 05-20-03 07:08 PM

Thanks guys, I see exactly what you mean, one other small question, I got the files open, and am logged in under SU, but it still doesn't let me edit them, apparently they are write protected, what must I do? Thanks.

connyosis 05-20-03 07:28 PM

Remount the partition the /etc directory is located under read-write, like:

mount -o remount -w /dev/hda5

Replace hda5 with the correct partition for your system.

JJacob 05-20-03 08:30 PM

I tried the command you just gave me as root except used hda3 which is my / directory.... I then tried to open the file and I still got a file read only thing. Please help, thanks for the help so far.

leibold 05-20-03 10:34 PM

what do you get when you do: ls -l /etc/inittab ?

It should be owned and writable by root. If you only temporarily want to turn off X-Window mode you don't even need to change that file. Just enter the command init 3 (you need to be logged in as root to do that).

JJacob 05-21-03 10:31 AM

ls -l /etc/inittab
-rw-r--r-- 1 root root 1756 May 19 18:38 /

The other command init 3 as root says command not found, reading man pages to try and figure out.

leibold 05-21-03 10:53 AM

The permissions and ownership on your /etc/inittab are correct. I have no idea why you can't edit it. If the init command isn't in your search path try /sbin/init 3 . In most cases init lives in /sbin, if not you have to search for it.

bwkaz 05-21-03 05:05 PM

What does lsattr /etc/inittab say? Does it have an i in the attributes field (or anything else, for that matter)?

If not, do your su thing again, and then do a whoami. Just as a sanity check...

For init 3, you need to do /sbin/init 3 as root, or do su - instead of normal su (this is so root's profile gets executed, and you get the /sbin directory put into your PATH).

JJacob 05-21-03 11:16 PM

Ok, I finally got into command mode by using the /sbin/ thing, when running the new patch I got some error about having not the right kernel (just updated to the most recent one), not sure what the deal is, but I will just wait till they put a newer one on the nvidia site. Thanks for the help everyone. Oh, the error i got said something about downloading the header files for something, anyone had this problem? Thanks.

connyosis 05-22-03 05:26 AM

You probably have to install the kernel headers.


All times are GMT -5. The time now is 01:02 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.