nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   1.0-4363 installer can't compile kernel mod in RH8.0's new 2.4.20-13 kernel (http://www.nvnews.net/vbulletin/showthread.php?t=12174)

jeffwsi 05-21-03 01:55 AM

1.0-4363 installer can't compile kernel mod in RH8.0's new 2.4.20-13 kernel
 
Good Morning,

I just installed Redhat 8.0's new 2.4.20-13.8.0 kernel update. I uninstalled the nividia rpm's I was using and downloaded the NVIDIA-Linux-1.0-4363.run installer and tried installing it.

The install process claims it lacks the appropriate kernel mod and that the nvidia ftp site does not have an appropriate one either. It tries to compile it's own but the compile process comes up with some nasty errors and exits.

I verified I have the 2.4.20-13.8.0 kernel source rpm installed and the tree is located in /usr/src.

Has anyone successfully compiled an nvidia kernel module or installed Nvidia h/w accelerated drivers on the 2.4.20-13.8.0 kernel yet?

Thanks,

Jeff

bwkaz 05-21-03 05:07 PM

Define "nasty errors", please. ;)

A copy and paste of the first few would be helpful. You can pass the --extract-only option to the installer, then cd into NVIDIA-<whatever>/usr/src/nv directory, then do a make >log.txt 2>&1 and attach the resulting log.txt file here; it'll have the full output of make.

Cigarman 05-21-03 09:19 PM

same here
 
Hell I've tried it with both red hat 9 and suse 8.2 and it tells me different answers but with the same result - S-O-L. I wish nvidia the distro maintainers would have a little better communication or something because this situation is unacceptable.

rangerFan 05-21-03 09:26 PM

1 Attachment(s)
I haven't been able to get the video driver installed yet but i have managed to grab the output of the errors. I have tried using the 'make SYSINCLUDE' command to see if that worked which it didn't. I am attaching the file that has the errors in it. If anyone can make sense of it please let me know

bwkaz 05-22-03 05:58 PM

rangerFan -- you're getting this:

Quote:

/usr/include/linux/autoconf.h:1:2: #error Invalid kernel header included in userspace
Notice the path the header file is in, here? /usr/include/linux?

That's the wrong header file. You need to be getting the autoconf header file that's inside the kernel sources, not the one in /usr/include/linux.

To do this, you need to configure your kernel -- make sure it's at the right version (check the toplevel Makefile, and upgrade the package if necessary), then run make clean oldconfig dep in the source directory (usually /usr/src/linux-<version>).

rangerFan 05-22-03 06:54 PM

1 Attachment(s)
thanks for the help. you helped me get rid of over 3/4 of my errors. To create rpms for another non-working piece of hard ware I created a soft link to my linux kernel ie 'ln -s /usr/src/linux /usr/src/linux-2.4.20-13.9' I am not sure if this soft link is the reason for the the remaining erros. I am attaching the remaining errors. I am going to see if removing that link fixes my problem

bwkaz 05-23-03 05:23 PM

OK... umm... that is VERY strange. What does ls -ld /lib/modules/2.4.20-13.9/build say? What about ls -ld /lib/modules/2.4.20-13.9/build/include?

Open the file that's complaining in an editor (that is, /lib/modules/2.4.20-13.9/build/include/linux/modversions.h), and post the first 20 or 30 lines or so (actually, you might want to just attach the whole file -- rename it to .txt first, though).

rangerFan 05-23-03 06:02 PM

1 Attachment(s)
The first ls outputs a symbolic link to ../../../usr/src/linux-2.4.20-13.9

and the second one is just a directory.

I think there is something wrong with my modversions.h file. it is attached

bwkaz 05-23-03 08:28 PM

There most definitely is something wrong with it.

It's not from the kernel-source package. It's from glibc-devel (I think).

My modversions.h is attached as well, so you can see what it's supposed to look like (approximately). This file very likely won't work if you just try to copy it into your kernel source tree, because of configuration differences, but it works in mine (because it was generated by make menuconfig). You may have issues with other files, too, though.

Have you run a "make oldconfig" at all?

What happens if you query the RPM database on the integrity of the installed kernel-source package? (I don't remember the option to use, perhaps "rpm -qv kernel-source"?)

bwkaz 05-23-03 08:30 PM

1 Attachment(s)
OK, apparently I forgot to attach it. Take 2:

rangerFan 05-23-03 09:01 PM

hey thanks running make oldconfig did the trick. when i queried the kernel-source it showed that the kernel-source was installed

bwkaz 05-24-03 08:37 AM

Glad it ended up working for you.

But I didn't mean query it to see if it was installed. ;) I meant to say "make sure it's still in the condition it was in when it got installed".

The rpm database keeps md5sums (actually, I'm not sure what kind of checksum it is, might just be CRCs, but it's something) for each file that gets installed. You can have rpm check the integrity of all the files in any one package at any time, I think with rpm -qv <packagename>. But I don't know about the v part, v might need to be something else instead.

If files get changed, this verification will fail.

Of course, it's working now, so it's a moot point anyway. :)


All times are GMT -5. The time now is 09:24 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.