nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   what's the XFree86.0.log (http://www.nvnews.net/vbulletin/showthread.php?t=12251)

snowpony 05-23-03 02:38 AM

what's the XFree86.0.log
 
last week ,I downladed and installed the 1.0-4363 successfully,and the graphic circumstance was perfect.But today,maybe because of my mistake,it shows that there is a fatal problem that it can not open the XFree86.0.log after I inputing startx.
would someone tell me what the problem is and how to work it out? thanks a lot!

leibold 05-23-03 04:26 AM

Are you running "startx" from different user accounts ? The XFree86.0.log is where the X server writes a lot of important information during startup as well as any errors while running. It is usually located in the /var/log directory. You may want to check the permissions on the directory /var/log as well as those on the XFree86.0.log file if it is already present:

ls -ld /var/log
ls -l /var/log/XFree86.0.log

snowpony 05-23-03 08:29 AM

I did not run "startx" from a different account,and the permission was not unexpected,what's the matter?

bwkaz 05-23-03 05:13 PM

What are the permissions? Which user were you running startx as?

Make sure that file /usr/X11R6/bin/XFree86 says something about "setuid executable", too, and make sure that root owns it.

And the exact error would be a lot more helpful, too. Copy and paste it (or do a startx >log.txt 2>&1 to save it to the log.txt file).

snowpony 05-23-03 10:57 PM

I am a novice to linux,so I don't know how to paste the log from linux OS to Windows,because the permission of /mnt is readonly and I couldn't chmod it.after I running startx,the error information is:
"hostname:Host name lookup failure
Fatal server error
cannot open log file "/var/log/XFree86.0.log"
xinit: No such file or directory (errno 2):unable to connect to X server.
xinit: No such process (errno 3):server error "

I ran startx as the root. the permission of /var/log is drwxr-xr-x ,
/var/log/XFree86.0.log : -rw-r----- ;and the permission of /usr/X11R6/bin/XFree : -rwxr-xr-x .
I don't know what the problem is.please help me!!

bwkaz 05-24-03 08:51 AM

You're running NTFS on your Windows drive, then, right? If so, you won't be able to make it writable -- Microsoft changes the filesystem format too often for the drivers to be stable enough that you won't run the risk of hosing your entire Windows partition if you enable write support.

Anyway, if those are the permissions (and not -rwsr-xr-x instead), then it's probably that your XFree86 binary needs to be installed suid root so that it can use your hardware correctly (not to mention so that it can write to /var/log). Either that, or it needs to be run as root, from xdm or gdm or kdm, but it sounds like you don't want to use those. So try (as root) doing a chmod u+s /usr/X11R6/bin/XFree86 and see if that helps.

snowpony 05-24-03 09:38 PM

to bwkaz:
thank you!
I tried what you told me,but it didn't work.I am very depressed.Maybe I should install the OS again.

bwkaz 05-24-03 09:47 PM

It's still complaining, with the same error, then?

Are you sure that root owns the XFree86 binary? (the owner is listed in the ls -l output)

Do you have an entry in /etc/hosts for your machine? (I noticed a "hostname lookup failure" earlier, this can cause issues, but probably not this kind of issue) It should look like www.xxx.yyy.zzz hostname aliases, where you replace www.xxx.yyy.zzz with your IP address, and "hostname" and "aliases" with your hostname and aliases. For example, my /etc/hosts looks like:

Quote:

127.0.0.1 localhost.localdomain localhost
192.168.2.254 beta.localdomain beta
Since my hostname is "beta", and 192.168.2.254 is my IP address. You should also have the 127 (loopback) address in there.


All times are GMT -5. The time now is 05:33 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.