nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia 177.82 30+ seconds hang (http://www.nvnews.net/vbulletin/showthread.php?t=123003)

kvaster 11-13-08 02:54 AM

Nvidia 177.82 30+ seconds hang
 
1 Attachment(s)
Kernel: 2.6.27
Driver: nvidia 177.82 (same with all 177.X series)
Card: Nvidia Quadro NVS 140M

Driver hangs for exactly 30 seconds in ioctl.

Reproducing:

1) Launch linux, start gnome, press ctrl + alt + backspace, wait for X to restart. Driver will hang for 30 seconds in ioctl on X restart.

2) Launch linux, start suspend to disk, try to resume from disk. Nvidia driver will hang on start for 30 seconds in ioctl after resuming from disk.

Kirurgs 11-13-08 08:37 AM

Re: Nvidia 177.82 30+ seconds hang
 
Suspend works like a charm for me and was before :) Hibernate doesn't - it hangs (2x30 secs or 3x30 secs), the same applies to X restart (You either log out of DE or Ctrl + Alt + Bkspc).
I was hoping that hibernate will be fixed coz that's real slow for me and it beeps 2 times in between, I don't really care for log out, as I do that once during week or more, but I assume if X restart is fixed so will be hibernate...

Please nVidia, give us more background, why this is happening in the first place? As I understand this is related to different ACPI implementation of different laptop manufacturers... Is it so?

P.S. I had a chance to get the same laptop with red competitor's GPU in it for couple of tests, and it worked like a charm with suspend / hibernate and binary drivers ;) Somehow they got that ACPI working then.

Big P 11-13-08 01:09 PM

Re: Nvidia 177.82 30+ seconds hang
 
Quote:

Originally Posted by Kirurgs (Post 1843754)
the same applies to X restart (You either log out of DE or Ctrl + Alt + Bkspc).

That's odd, I don't have that problem with xdm + slim on Gentoo. Have you tried other login managers? What if you just startx and do ctrl + alt + backspace, does it still hang? Do you have the same problem on your laptop and desktop nvidia cards?

Kirurgs 11-13-08 02:14 PM

Re: Nvidia 177.82 30+ seconds hang
 
Desktop is OK, the problem is with laptop only... I'll try other login managers and edit this post...

Edit: problem appears with xdm too (it's so bloody ugly :( ). Tried rmmod nvidia, that didin't help either...

blakeyez 11-13-08 02:24 PM

Re: Nvidia 177.82 30+ seconds hang
 
I've got the same chipset (140M), and am experiencing the same issue. I'm not even using a display manager - starting the X server in any way results in a 30 second hang, then the nvidia logo and everything works fine. I've used older drivers in the past without this issue but have just re-installed my system so can't look up which version I was using before.

Kirurgs 11-13-08 02:34 PM

Re: Nvidia 177.82 30+ seconds hang
 
Please, specify Your distro too, blakeyez... Author seem to run the gentoo, the same as Big P, but results are vice versa... I do have this problem starting 17x series, if I rememeber correctly... 177 series gave me this sudden slowdown with IPP=2 too (w/o it it runs smooth all the week).

blakeyez 11-13-08 02:55 PM

Re: Nvidia 177.82 30+ seconds hang
 
Quote:

Originally Posted by Kirurgs (Post 1844092)
Please, specify Your distro too, blakeyez...

Sorry, I'm running Arch Linux, 32-bit. It's a brand new install, as I mentioned.

kvaster 11-14-08 01:52 AM

Re: Nvidia 177.82 30+ seconds hang
 
I'm using gentoo on thinkpad laptop.
Driver hangs on restart. It means that if I start X using startx, and kill it with ctrl + alt + backspace - it's all ok. But if I'll try to use startx second time, driver will hang for 30 seconds.

NvFuchs 11-14-08 02:11 AM

Re: Nvidia 177.82 30+ seconds hang
 
Fully able to reproduce it, reported it twice with bug report, chipset is also a 140m in a thinkpad.

http://www.nvnews.net/vbulletin/showthread.php?t=120626

Having exactly 30 seconds sounds like a timeout for me, and as it seems to happen mainly on notebooks, this could be ACPI (power state, display state, whatever) related.

Nvidia, please please fix this.

Fuchs

Big P 11-14-08 10:39 AM

Re: Nvidia 177.82 30+ seconds hang
 
It sounds like it is specific to your chipset so, since my gf4 440Go, 6600GT, 7600GT and 8800GTS all don't have this issue. Have you tried emailing the address at the top of your bug report rather than relying on the forums? Any time I have done that so far has resulted in them opening a ticket.

NvFuchs 11-14-08 11:01 AM

Re: Nvidia 177.82 30+ seconds hang
 
Yes, in the meantime I did. Unfortunately this problem is still present in the new 180 series. (which is a little bit of a disappointment, I am still waiting for configurable powermizer, good XRandR support and OpenGL 3)

Let's hope they can reproduce it and / or get it fixed.

Fuchs

ale.ji 11-14-08 09:37 PM

Re: Nvidia 177.82 30+ seconds hang
 
yes , My Thinkpad 61with Quadro NVS140M , i also encounter this problem . first start x ,it's everything runs Ok , but as you logout x ,and restart X, it will be hang 30 second ... ,
I try it at Opensuse 11.0 release and debian 5.0Rc....

Debian 5.0 with Kernel: 2.6.27 and Opensuse 11 release with Kernel 2.6.26
Driver: nvidia 177.82 (same with180.06 )
Card: Nvidia Quadro NVS 140M

btw , how can i use the older version Nvidia driver (173 series ... for example) to replace the current version installed my box??


All times are GMT -5. The time now is 06:00 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.