nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Fairly frustrating (RedHat 9) (http://www.nvnews.net/vbulletin/showthread.php?t=12322)

Firestarter 05-24-03 01:56 AM

Fairly frustrating (RedHat 9)
I have the latest kernel downloaded and installed, 2.4.20-13.9. I'm technically a noobie to all of this because i just installed linux two days ago, but after a couple of hours of tinkering, i was finally able to get the
NVIDIA-Linux-x86-1.0-4363.run --kernel-include-path /usr/include/linux/kernel.h
correct, with the correct kernel header file and everything, and yet, it was still unable to compile a new installer or whatever it was doing...how do i fix this problem, or should i just wait for a newer driver to come out that is (to the best of my knowledge) behind current kernel's put out by Red Hat. A little disgruntled, please help! :)
Did I just not get the correct header file? Anyone else who has successfully installed this driver with the new kernel please tell me how to do it.
I'm running
GeForce2 Go 32Mb
Red Hat 9
Dell Inspiron 8000 motherboard (don't know actual model)
a Pentium III 900MHz

DrOzz 05-24-03 02:06 AM

well d00d if your new to the scene i don't know why you are specifying kernel header files...just run the basic install and see what the deal is...and post your log files for we can help ya threw this...

Firestarter 05-24-03 02:11 AM

well i'm new at linux not, necessarily computer illiterate though, but i was wondering how to view that log file in a format i can put here, since i'm not in X when the error occurs. (this is where explicit instructions are needed because i can be the noobie i am lol) thanks a bunch. i specified the kernel files because after trying to do it normal, it told me to do it that way
so after trial and error of a format it would accept, it was off to X to figure out where the dumb header file was, after trying several different ones i found, i got the farthest with the one i posted above. i also looked at all the precompiled ones and they stop at 12, i have 13 as my kernel version, so i'm not sure what the problem is. but i honestly did do it the normal noobie way first <shy g>

Firestarter 05-24-03 02:20 AM

ok, i think i figured something out here... i ran
rpm -qv kernel-source
and it said that the "kernel-source" is not installed. that seems like an important fact, and if it is, how do i install it?

Adrac 05-24-03 03:58 PM

Since you have updated your kernel, you will have to download the sources from the web. The kernel sources that are supplied on the CD are likely _not_ going to work for you. So, here's a link to the current redhat kernel sources: ftp://ftp.redhat.com/pub/redhat/linu...-13.9.i386.rpm
Fair warning, this is nearly 40MB in size in case you are working on dial-up.

If that site is busy, you can check for mirrored sites on http://www.redhat.com/mirrors.html

Once you have the file, just do an rpm -i kernel-source-2.4.20-13.9.i386.rpm and you "should" be good to go. Good luck :)

Firestarter 05-24-03 07:01 PM

Thanks for all the help guys. I fixed it this morning and got the driver up and running. But for anyone who was having trouble similar to me, here is the layman's run down. I rebooted my computer with the Red Hat9 install CD, and then did an upgrade. I installed the kernel-source.rpm and then entered back into X as root. there was an update on Red Hat network for the newest source and i installed it. then opened a terminal window and typed init 3, the rest is the same as the install instructions. Once again thank you all the help. have a good one and God bless.

Tommi 06-11-03 09:27 AM

A general rule when handling Linux....

1. Relax. Take a deep breath...

2. Forget all hurry.

3. Accept the idea that sometimes you may need to spend two weeks to solve some installation problem which is possible to solve in windows with 15 minutes... :-)

4. Take it as a hobby. Forget the idea that everything should be allways ready.

5. Enjoy problem solving...

If you can make it run you are a hero. You can do things that windows people never could make because they are simply lacking that ATTITUDE. Windows is for vimps.

Anyway once you can make it run it runs for MONTHS without reboot. It may even run for ONE YEAR without reboot. Forget this this Windows...and so on.

Good luck, Blessing,



All times are GMT -5. The time now is 10:28 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.