nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Error (http://www.nvnews.net/vbulletin/showthread.php?t=12340)

kyden 05-24-03 04:35 PM

Error
 
I recently installed Linux, and had to put the NVIDIA driver on. And I did it, and everything worked perfect.

Well, basically, something on Linux got screwed up and I had to reinstall it.

I wiped my one drive and installed Mandrake 9.1 again. Everything worked good, except when i tried to install my driver for NVIDIA Geforce2.

I get this error:

Unable to find the system utility 'ld'; please make sure you have the package 'binutils' installed. If you do have 'binutils' installed, then please check that 'ld' is in your PATH.


Please help.

Adrac 05-24-03 05:05 PM

ld is an program that helps tie together pieces of an application while it is being built; in a single word, ld is a linker.

I have not worked with mandrake much but I seem to recall that it supports rpm. You can check to see if you installed ld with the binutils package. Simply type rpm -qv binutils

If this prints a line indicating that binutils is not installed, you will need to install binutils from your Mandrake distrbution. If binutils is installed, you will need to determine where ld was installed and make sure that the directory ld is located in is a part of your path.

DrOzz 05-24-03 05:05 PM

well go to console and issue the command:
rpm -qa|grep -i binutils
if you get an output similiar to something like:
binutils-2.13.90.0.2-2
then you do have it installed.
and of course your version will be different cause i use RH8 and your using MDK9.1...but if you don't see any output, then just go get the binutils package and install it, and try the nvidia installation again..gl

kyden 05-24-03 06:32 PM

Ok, that's fine, but now when I try to open up a program that needed it I get this error:

Could not find a compatible OpenGL display resolution. Please check your driver configuration. (Error: Couldn't find matching GLX Visual)


I tried, but to no avail.

kyden 05-24-03 08:09 PM

So I guess basically how do I configure it.

Adrac 05-25-03 01:12 AM

More than likely this application is requesting a resolution that is not enabled in X. If you can determine what that resolution is, you can add it to the XF86Config file. This can be done by editing the file by hand or if Mandrake has a GUI editor using that.

If you have to do this by hand, the following will give you a general idea of what is required. The file you are looking for is XF86Config (might be XF86Config-4). On my system, this is located in /etc/X11; if it is not here on your system, you can type locate XF86Config to find where it is.

Before going any farther, make a backup copy of this file!

Edit this file in your favorite editor (you will probably need to be root to do this). There should be a line in the file that starts with the word "Modes" (no quotes). This line is the one that lists what resolutions are enabled for the particular screen. Add any resolutions you need here.

Modes "1024x768" "800x600"
could be changed to:
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

Note that the resolutions do have quotations around them and should be put in the file that way. Save your changes and restart X.

Hopefully this takes care of you.


All times are GMT -5. The time now is 11:30 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.