nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   180.08 & red checkerboard (http://www.nvnews.net/vbulletin/showthread.php?t=123439)

roalter 11-20-08 06:11 PM

180.11 & red checkerboard
 
1 Attachment(s)
After installing 180.08, when playing back videos, either from DVD or 720p (I don't have any larger ones lying around) I get short moments, when the output is overlaid with a red/transparent checkerboard pattern.

I made a screenshot of it attached to this post.

playback is done with mplayer, output is xv. With the 177.80 all is well (the last driver I tried).

I'll revert for the moment to the 177.80, but looking forward for any help in decoding h.264 in matroska files, my AMD X2 3800 has 50-80% CPU usage on decoding them and this results in the occasional frame drop. ... seems like the old times, when I was playing back DVDs on my AMD K6-400, when I could playback dvds barely with lots of framedrop. I seriously hoped I would never have to experience this again...

roalter 11-24-08 04:23 AM

Re: 180.08 & red checkerboard
 
*bump*

did anyone encounter this problem besides me? That's very strange...

roalter 12-02-08 06:53 PM

Re: 180.08 & red checkerboard
 
*another bump*

With 180.11 the problem still occurs.

I have a 8600 GTS and a 6200GS in my system (6200 being PCI). On the 6200 I did not encounter the problem, but on the 8600 GTS (where the TV is connected via HDMI) these checkerboard flickerings happen from time to time, both in fullscreen and window mode of mplayer, using XV as video output.

CajunArson 12-02-08 08:38 PM

Re: 180.08 & red checkerboard
 
You are not the only one. I have the red checker board with the 180 series drivers, but with the older 178 series drivers it was a black checkerboard (go figure).
My personal setup is using the new KDE 4.2 beta series under Kubuntu 8.10. I have two possible work-arounds that have worked for me: 1. Disabling the compositing manager has stopped the problem while watching video. 2. I've noticed that either enabling a scaling mode like the Expose' effect or maximizing the video window also helps.
I've noticed the checkerboarding with mplayer and vlc, but I've never seen it with things like Youtube videos in Flash.
I hope this helps, if you are using a desktop with compiz, try falling back to the non-compositing manager while watching video and that may help.

roalter 12-03-08 07:37 AM

Re: 180.08 & red checkerboard
 
Hm, no compositing working, since it won't do with both the 8600 and the 6200 in the system. (no GL on the 6200 either, so glxgears only shows an image on the 8600 screens, but remains black on the 6200 screen)

What really strikes me is on what causes this pattern. The size of the squares is 16x16 pixels, but they aren't completely opaque, but slightly translucent, so I reckon it must be something from the driver.

mefistostarr 12-03-08 07:54 AM

Re: 180.08 & red checkerboard
 
I can confirm similar bug - i use ubuntu 8.10, my videocard is mobile nvidia 8600GT.
if i watch video over XV-output (by default i use totem) and use scrolling in other window (for example, Pidgin Buddy List or Firefox), i can see blinking checkboard pattern.
It blinks when I use mouse move scrolling.

BTW: for me, bug present in 177.82 and 180.06 nvidia drivers.i use compiz.

skarhand 12-13-08 03:47 PM

Re: 180.08 & red checkerboard
 
I can confirm the red checkerboard when playing videos with mplayer/xv. It only appears for one frame or so once in a while. Video card is a GF 8800 GT with the 180.16 driver. Using compiz as well.

thecheatah 12-13-08 09:46 PM

Re: 180.08 & red checkerboard
 
I can confirm this on mythtv as well.


http://www.nvnews.net/vbulletin/showthread.php?t=123789

rdv 12-29-08 09:22 PM

Re: 180.08 & red checkerboard
 
I am also experiencing this problem starting with the 177 driver when black checks would be displayed.

I installed the first release of the 180.xx series driver and the checks were gone. Now with the 180.18 driver I get red checks as described in previous posts. In addition to the occasional red checks I will also get a full red screen flash during xv video playback. I use both compiz-fusion and smplayer/mplayer.

I have a EVGA 8600 GTS.

keyser7777 01-11-09 04:14 PM

Re: 180.08 & red checkerboard
 
I can confirm too. I have an 8600GT card, and the problem appeared since 180.xx. I'm using KDE4 with kwin compositing enabled

theluckyone17 01-11-09 06:41 PM

Re: 180.08 & red checkerboard
 
Quote:

Originally Posted by rdv (Post 1887537)
I am also experiencing this problem starting with the 177 driver when black checks would be displayed.

I installed the first release of the 180.xx series driver and the checks were gone. Now with the 180.18 driver I get red checks as described in previous posts. In addition to the occasional red checks I will also get a full red screen flash during xv video playback. I use both compiz-fusion and smplayer/mplayer.

I have a EVGA 8600 GTS.

Same situation here. 177 would show a black checkerboard pattern on any video I was playing:
  • DVD Kaffeine: Xine engine
  • Electric Sheep screensaver

180.22 is giving me a red checkboard pattern, too. I don't get a fullscreen flash. Running KDE3 w/ Compiz-Fusion. Video card is a 9600GT.

theluckyone17 01-19-09 06:06 PM

Re: 180.08 & red checkerboard
 
A shameless bump, plus some more information:

Oddly enough, the problem seems to occur less the longer it's been since my last reboot.


All times are GMT -5. The time now is 09:23 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.