nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   how to modify XF86Config in RH 9 after installing NVIDIA driver (http://www.nvnews.net/vbulletin/showthread.php?t=12360)

Albert 05-25-03 06:15 AM

how to modify XF86Config in RH 9 after installing NVIDIA driver
1 Attachment(s)
Thanks to anyone who might be able to offer some help. Maybe there is some "HOWTO" available anywhere.

Here's my question:

I installed the nVIDIA driver 1.0-4363 in RedHat 9. I did read the release 40 notes,
but I can't find how to modify XF86Config.

I tried replacing: load "nv" by: load "nvidia". That failed, so I did:
"modprobe" to actually load the driver.

Now, lsmod says:
nvidia 1672480 0 (unused)

I assume the nvidia driver did load, but something still prevents it from running.

What can I do to correct the situation?

PS: 'Attach file' does not allow me to add more than one file to this thread. I also wanted to enclose XF86Config, but then it takes away the XFree86.0.log. I'd be happy to mail additional info later.

DrOzz 05-25-03 07:19 AM

well exit outta of X and "su" to root, and type "pico /etc/X11/XF86Config" and scroll down to the spot where it says Load "nv" and change nv to nvidia, and also put a "#" at the beginning of the line that says "load "dri""...press ctrl-x, press yes(y) to save and you will be put back to console, type "exit" to be put back to regular user privileges, and then type startx...

Albert 05-25-03 08:00 AM

Thanks you for your swift reply.

I pressed 'Ctrl-Alt-F2' to exit X (Hope that's correct)

Here's what I got, when I entered as root:
pico /etc/X11/XF86Config

bash: pico: command not found

So, I used 'vi' for editing XF86Config
In section: "Device" I replaced "nv" -> "nvidia"

Did not find the line: load "dri" though.
(I noticed there is a line that contains: 'glx', should that stay?)

Albert 05-25-03 09:29 AM

After having replaced "nv" -> "nividia" in XF86Config, it reports:

(EE) NVIDIA (0): Failed to initialize the NVIDIA kernel module!

(BTW: I run Linux kernel 2.40.20-13.9)

Then the former XF86Config file is restored.
So X starts up the way it used to.

Maybe I'd better forget about 3D acceleration running this kernel?

cjmace 05-25-03 09:48 AM

I figured a way around this and posted it a couple of weeks ago.

Uninstall all nvidia software and drivers.
rpm -V all XFree rpms.
refresh any drivers that have problems, so that ALL XFree rpms are happy.

Install the driver PREVIOUS to 4363 and run the script to make the driver.

Then run nvidia-update and it will load the 4363 and do the build and all works fine that way.

Be sure to run the install file and the update once and only once.

Works fine this way and loads glx.


Albert 05-25-03 10:07 AM

Thank your for your kind reply.

Unfortunately, I hardly understand what should be done.

I have no idea how to uninstall the NVIDIA stuff.

What's the command(s)? How to check if it has been done the right way?

How should that driver's "refresh" be done? What are the commands?
Which drivers should be happy? How do I know they are?

Sorry for being that ignorant. I have no Linux background.

I can imaging it may take too long to explain step be step. I don't want to steal your time. So if it's too complex, just forget about it. I can live without 3D graphics.

DrOzz 05-25-03 11:35 AM

ok first, when you press ctrl-alt-f2 you are not exiting X...that is completly wrong..and the reason why i told you to use pico is because when your installing redhat there is an option to install the package "pine" which is a text based email program, which is packed with pico...its by far the easiest text editor imo, so thats why i suggested you use it, so you must of not installed pine, but anyways...if you dont' see load dri in the modules section then thats cool, thats just one less thing you have to comment out...all you have to do is make sure it doesn't load anyways...
and as to uninstalling nvidia drivers, based on if you using the .run file you would issue a command logged under root:
"sh NVIDIA-Linux-x86-1.0-4363.run -uninstall"
now as of exiting X properly and not how you were doing it, i will just explain the steps that most take and the steps i use...
first open up the console and log in as root, and edit the file /etc/inittab
you will see the line that says id:5:initdefault...change the 5 to a 3 so when you reboot your computer it will boot directly into the console and not into X...then you install the drivers, make the required changes to the xf86config file, and then type exit to get outta root privledges to go back to your basic user, and type startx...if it works, then when in X you can edit the inittab file again and change it back to a 5,so for the next time you reboot you can boot directly back to X, and if don't work then you'll be able to reboot your computer back to text mode, and then you will have to troubleshoot, so we'll hope that doesn't happen :D
if something doesn't make sense, just post back with more question, i am kinda in a hurry so i had to type that quick...GL!

Albert 05-25-03 01:02 PM

First, I should thank you for your time. Feels really nice to get this kind of support.

Well, I learned how to change runlevels. It's simply: 'telinit 3'. And to startx again: 'telinit 5'. No booting to switch runlevels.

I understand the uninstall command should be: sh NVIDIA-Linux-x86-1.0-4363.run --uninstall (that's a double - - after 'run')
It confirmed it really did uninstall. Clear.

Apparantly, I am missing 'kerel-headers' (whatever that is) to istall the nvidia driver for kernel 2.4.20-13.9

So, I rebooted and changed to a previous kernel: 2.4.20-8. (I still had that one sitting in GRUB)

Then I was able to run the NVIDIA installer again. It installed fine and told me to check the XF86Config when it finished.
So I'm back were I started.

Whenever I replace "nv" -> "nvidia", it fails to start-up X and it suggests to automatically reconfigure the old XF86Config for me. Which is quite polite, but it brings me no 3D accelaration.

Albert 05-25-03 01:27 PM

My problem is solved! I got the NVIDIA driver running just fine!

I must be an idiot. After I did a cold reboot, the NVIDIA screen just flashed !

I guess it was a mistake to boldly remove the line: "load "glx" in XF86Config. If I remember well, I had to do that for the Mandrake distro. Now that does not seem to be the case for Red Hat.

Thanks again for your kind support!

(Anybody nows about a free driver for a soundcard SB Live! 5.1 (OEM model CT0200)?

That's another hurdle to overcome :D
"We are in control!" Minister of IT affairs

DrOzz 05-25-03 04:36 PM

well i don't know of any distro that needs load "glx" removed...you maybe thinking of load "glcore" or something, but not glx...anyways, your sblive should be automatically detected and in working order...cause the audigy was one of the last of creatives cards to get supported and i am running rh8 and it picked it up fine...your sblive should be even supported in some or all rh7.x...

but if the case be that it is not picked up just go to
SourceForge - Creative OpenSource

and download the emu10k1, you don't need the emutools file, and just download the first one in the list it is a rpm file...you will just double click it and after it is done you should have sound...
the name of it is below.........

0.9.4 2002-01-18 00:00 emu-tools-0.9.4-1.i386.rpm 68983 26590 i386 .rpm

Albert 05-27-03 11:40 AM

Thanks again for your time.

I won't continue about my sound card on this forum, after this reply. This forum is supposed to be dedicated to nVIDIA and I apologize to the members for this abberation.

My sound card is rather different and obscure. It is a so called "OEM" version (model CT0200) The EMU10K1 definately will not drive it, because this card carries a different chip set than the usual SB Live! cards.

There is only one commercially available binary Linux driver that I know about for this card.

It is sold by Opensound.com. I trust this driver will work as soon as I got a missing cable for connecting my CD drive to the sound card. You don't need this cable for Windoze. But you do need it for Linux.

DELL did not bother to install this cable, as they seem to assume the whole world belongs to M$.

Again, thank's for your support and your kind attention.


DrOzz 05-27-03 11:49 AM

well i will make my final post towards this post and tell you again about the audigy finally getting supported under the linux environment, and how mine is also OEM, and it picks it up fine...i dont' know what your getting at by saying its OEM so it dont' pick it up, but anyways i am not gonna argue about such a thing, and we'll leave it at that..

All times are GMT -5. The time now is 04:21 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.