nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nVidia Geforce4 440 Go 1400x1050 problem (http://www.nvnews.net/vbulletin/showthread.php?t=1237)

moreinf 08-28-02 05:31 PM

nVidia Geforce4 440 Go 1400x1050 problem
 
I got Toshiba 5105-S501 notebook. It has Geforce4 440 Go 32MB. I installed Redhat 7.3 and didn't upgrade the kernel. And I installed the linux device driver as the website provides. And it seems to work well only with until 1280x1024.

I am using it as 1280x1024, 16bit color. 24 bit color also doesn't work, and I am struggled because my TFT-LCD supports 1400x1050, so 1280x1024 is not pretty at all. (you know, the LCD screen is not like a regular CRT, so it shows best when used by the default=highest resolution.)

Is there anyone who has the same problem with me? How can I solve this thing?

I also posted some tips and tricks for those who has the same notebook as mine.

http://www.cs.umn.edu/~sungil/toshiba.html

Thanks.

moreinf 08-28-02 05:36 PM

Also, not-full-screen-problem.
 
Also, I got one more problem. at 1280x1024 or 1024x768, my screen is not used fully, i.e., the right side, about 7mm (or 0.3inch) is not used - just black. Is there anyone why this happens?

Thanks.

moreinf 08-28-02 10:10 PM

I simply solved my problem!!!
 
I have Toshiba 5105-S501 as all you might know.

1. install Redhat 7.3. And you should select 'Geforce4' before the installing ends.

2. select also 'text' node login.

3. login as normal user, then do 'su root'

4. install nvidia rpms, kernel i686-up first, then GLX.

5. just remove 'GLcore' and 'dri' from /etc/X11/XF86Config-4

6. add '1400x1050' in the /etc/X11/XF86Config-4

7. also, remove the '#' mark before XkbDisable option there.

8. Just start x by startx!! (of course, first, exit the root user)

dhodho 08-29-02 04:12 AM

1 Attachment(s)
I have a Dell Inspiron 8200 with geforce 4, and there are several ways to get it to work with nice clear text.

1.Use nvidia's driver, with following modelines in your monitor section:

# -- 1400x1050 --
# 1400x1050 @ 60Hz, 65.8 kHz hsync
Modeline "1400x1050" 129 1400 1464 1656 1960
1050 1051 1054 1100 +HSync +VSync

# 1400x1050 @ 70Hz, 76.8 kHz hsync
Modeline "1400x1050" 151 1400 1464 1656 1960
1050 1051 1054 1100 +HSync +VSync

# 1400x1050 @ 75Hz, 82.3 kHz hsync
Modeline "1400x1050" 162 1400 1464 1656 1960
1050 1051 1054 1100 +HSync +VSync

# 1400x1050 @ 85Hz, 93.2 kHz hsync
Modeline "1400x1050" 184 1400 1464 1656 1960
1050 1051 1054 1100 +HSync +VSync


In Screen section, Display subsection, specify
Depth 24
Modes "1400x1050"

This works great. Problem is that nvidia driver is not suspend-compatible. So when I need to suspend linux in X11, I use the following:

2. In Device section, use Driver "vesa"
In Screen section use DefaultDepth 16, and in Screen.Display subsection, use Depth 16, Modes 1280x1024. This is similar to what you are doing--and it looks butt-ugly if the LCD display blows it up to 1400x1050. But

my dell laptop has a Fn-key combination (Fn-F7) that switches the display from full-screen to reduced-size. If you can also do this on your Toshiba, you will get a crisp screen output that has small black margins on the outside.

Good luck. My XF86Config-4 is attached to this message.

Dave.

binduwavell 09-12-02 02:55 PM

I have been using:

Modeline "1400x1050" 129 1400 1464 1656 1960
1050 1051 1054 1100 +HSync +VSync

on my S501 with Mandrake 8.2 for a few weeks, it's basically good, except that the right hand edge of the screen (a little less than 1cm) is blank. The issue is that when I maximize windows the scroll bar ends up behind this black vortex wich makes it very hard to scroll arround.

If it helps, here is my XF86Config-4 file:

http://www.wavell.net/X/XF86Config-4

Any thoughts on how I can fix this?

Thanks,


-- Bindu

Found the answer to this one, add:

options NVdriver NVreg_SoftEDIDs=0 NVreg_Mobile=2

to /etc/modules.conf and then reboot.

If anyone knows what this does, an explaination would be greatly appreciated!

xpunkrockryanx 09-13-02 02:02 PM

also having problems with 1400x1050
 
1 Attachment(s)
I've got a Toshiba 5105-S501. I installed the proper drivers and I've been able to get X to run, but only in 1024x768 mode. I've tried a ton of different modes and refresh rates, but cant get 1400x1050 to work. It sounds like my problem could be in the refresh rates specified, but I don't really know. If anybody can help me get this working in 1400x1050, I'd appreciate it.

Attached below is my XF86Config-4 file. Please reply here if you have any suggestions or if you can find problems with my config.

Thanks!

Andy Mecham 09-13-02 02:43 PM

A HorizSync of 31-57 sounds a little conservative. Xconfigurator lists a HorizSync of 31.5-67 and VertRefresh of 50-90 for a generic 1400x1050 panel - can you try those settings? I wouldn't go any higher until you can find which exact panel you have, and what the appropriate settings for it are.

--andy

xpunkrockryanx 09-15-02 01:35 PM

Andy,

I tried the rates you mentioned, and (like the other rates I've tried) it didn't work. I've been unable to find any documentation from Toshiba which lists proper refresh rates, but I just posted a message to their forums requesting the information, so hopefully they'll get back to me there.

xpunkrockryanx 09-15-02 07:02 PM

update: the tech who replied on the forums there says that the screen will run at 60Hz for all resolutions, but he didn't know anything about a HorizSync rate...

has anybody else gotten X working with the Toshiba 5105-S501 at 1400x1050?

binduwavell 09-15-02 11:31 PM

Toshiba S501 working w/ Madrake 8.2
 
It's working for me. I basically installed the nVidia drivers (following their docs). I had to add the line listed above to /etc/modules.conf and it works great. Note the file I posted above has a bunch of hacky things that don't appear to be necessary.

-- Bindu

xpunkrockryanx 09-16-02 12:25 PM

thanks for the help. i tried the added line to the modules.conf, and it took away the annoying black bar on the side of the screen, but unfortunately i'm still stuck in 1024x768. i think i'm going to try out gentoo linux today and see what i can come up with. i normally run slackware, but i thought i'd break away from my usual init script comfortability and try redhat. let me tell you it irritates the **** out of me lol. seems like they try to make things too easy but end up confuscating everything in the end... /shrug


All times are GMT -5. The time now is 07:43 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.