nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem after compilation during insmod (http://www.nvnews.net/vbulletin/showthread.php?t=124)

gerbil 07-29-02 04:38 AM

Problem after compilation, during insmod
 
Hello,

I had just reconfigured this system after having the drivers working on it a week earlier. After downloading the drivers (the tar.gz packages), and successfully compiling them, the problem I have is that NVdriver does not pass module dependencies on my system currently.

I run Slackware 8.0 kernel 2.4.5 with a STB Velocity 4400 TNT. Here is the error message I am recieving for NVdriver (GLX seems to install fine):

Quote:

depmod: *** Unresolved symbols in /lib/modules/2.4.5/kernel/drivers/video/NVdriver

/lib/modules/2.4.5/kernel/drivers/video/NVdriver: unresolved symbol __global_cli

/lib/modules/2.4.5/kernel/drivers/video/NVdriver: unresolved tqueue_lock

/lib/modules/2.4.5/kernel/drivers/video/NVdriver: unresolved symbol __global_save_flags

/lib/modules/2.4.5/kernel/drivers/video/NVdriver: unresolved symbol __global_restore_flags
I tried editting the autoconf.h in /usr/include/linux/ to remove SMB support but I still recieved the "tqueue_lock" error.

Funny thing is that the drivers worked fine the first time i installed them months ago.


[edit] forgot to set my MTU settings again >.<; [/edit]

Hopefully there is something I can edit to knock out these module dependency errors.

Thanks

Thunderbird 07-29-02 04:46 AM

Most of the time NVdriver complains about unresolved symbols when you used wrong kernel headers. I mean when you use kernel headers which aren't the ones for your kernel version.

gerbil 07-29-02 03:22 PM

Okay thanks, I'll do some research into that.

[edit]
I ran make with the SYSINCLUDE option for the directory that contained the include files for the 2.4.5 kernel (/usr/src/linux-2.4.5/include) but I still seem to get these unresolved symbol errors. I did make sure to make menuconfig dep before doing that.

Are there any other files that could be giving NV's makefile the wrong kernel header locations?

[edit 2]
Thank you for the help. Was not aware of that slack issue (just a newb).

Andy Mecham 07-29-02 05:11 PM

Slackware 8.0 shipped with unconfigured kernel headers, which is why you're seeing the unresolved symbols. You'll probably have to reconfigure your sources and then recompile your kernel to get the two to match.

I hope this helps...

--andy


All times are GMT -5. The time now is 11:51 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.