nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nForce2 Unified driver on Mandrake 9.1 (http://www.nvnews.net/vbulletin/showthread.php?t=12401)

CeltiKaos 05-26-03 06:55 AM

nForce2 Unified driver on Mandrake 9.1

The current RPM for download is still only for Mandrake 9.0, whereas other distros such as SuSe have been updated. Please can anyone advise when Mandrake 9.1 will have the driver available.

Currently Mandrake 9.0 doesn't know what the network (onboard) card is, but will use it. Mandrake 9.1 recognises the device properly but won't use it <!?!>

Any thoughts appreciated.

Kind regards,


Pallesen 05-26-03 07:24 AM

Try downloading the Kernel Tar File NVIDIA_nforce-1.0-0256.tar.gz from Nvidias homepage. You install this file by doing:

tar xfzv NVIDIA_nforce-1.0-0256.tar.gz

cd nforce2 (I think this is the name of the folder the file is extracted to...)


This final step you must be root to do:

make install

I think this should do the trick.


pies 06-03-03 10:37 AM

tar install fails
I tried that, but it seems to go horribly wrong. Have other people got it to work?

$ make
make -C nvnet
make[1]: Entering directory `/home/tom/Desktop/nforce/nvnet'
cc -c -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/usr/src/linux-2.4.21/include nvnet.c
In file included from /usr/include/linux/prefetch.h:13,
from /usr/include/linux/list.h:6,
from /usr/include/linux/module.h:11,
from nvnet.h:20,
from nvnet.c:21:
/usr/include/asm/processor.h:55: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm/processor.h:55: requested alignment is not a constant
In file included from /usr/include/linux/module.h:20,
from nvnet.h:20,
from nvnet.c:21:
/usr/include/linux/modversions.h:1:2: #error "================================================= ======"
/usr/include/linux/modversions.h:2:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/modversions.h:3:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/modversions.h:4:2: #error ""
/usr/include/linux/modversions.h:5:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/modversions.h:6:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/modversions.h:7:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/modversions.h:8:2: #error "currently running kernel. They should only be"
/usr/include/linux/modversions.h:9:2: #error "included via other system header files - user space"
/usr/include/linux/modversions.h:10:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/modversions.h:11:2: #error "<asm/*.h> as well."

<snip!> more errors followed...

D3F4U7T 06-04-03 04:28 AM

I have installed the nforce drivers for my A7N8X on Mandrake 9.1 using the source file (NVIDIA_nforce-1.0-0256.src.rpm) to compile my own rpm. It works fine, except for an error on boot-up with regards to sound, although I still get sound! ;)

Pallesen 06-04-03 07:42 AM

Re: nForce2 Unified driver on Mandrake 9.1
Hi Julian

I see you use Mandrake 9.0. I seem to remember some bug in a beta of MDK9.1 which gave trouble when trying to install the Nforce2 drivers, perhaps this is what you are experiencing in 9.0. I don't know what causes this, perhaps you have to upgrade to 9.1 :|


Pallesen 06-04-03 07:45 AM

Heh, did not see that it was someone else replying with the make error... :)

Which distribution are you using pies?

All times are GMT -5. The time now is 07:19 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.