nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Newbie - Error compiling kernel (http://www.nvnews.net/vbulletin/showthread.php?t=12429)

JimKerwood 05-26-03 10:27 PM

Newbie - Error compiling kernel
 
1 Attachment(s)
I have downloaded the new .run files from NVidia and after trying to run them I get an error on the Kernel compilation.
I have changed my XF86Config-4 to get into X but I am at a loss on how to get the kernel to compile the new driver.
I am running an Asus v7100 w/ TV out on a Asus P2B 533 Celeron. I have tried to install NVIDIA-Linux-ix86-1.0-4349 and 4363 on Redhat 2.4.20-13.8
Thanks
Jim

bwkaz 05-27-03 06:42 PM

What does cc -dumpversion tell you?

What gcc version is listed in /proc/version (this is the gcc version used to compile the kernel)? These should be the same, or it would've complained earlier, but you never know (you didn't use IGNORE_CC_MISMATCH, did you? Don't ever use that unless you KNOW it'll work)...

Are you sure your kernel-source is installed correctly? rpm has an option for --query that will look at all installed files and recalculate their checksums against the original RPM package's checksums. Run that on the kernel source package to see if it matches up well enough.

You might also try running a make oldconfig from inside /usr/src/linux-<version>

JimKerwood 05-27-03 07:27 PM

Still nada
 
dumped to 3.2 which is the same as my rpm --query returned

I am pretty sure that the source is installed correctly. I ran the --query and sure enough kernel-source-2.4.20-13.8 .
I also ran the make oldconfig and it completed. I then ran the make dep and it completed with no errors. Then tried the .run and still nothing. nada. zip.

Couple of things I will mention.
1) I was running kernel-2.4.18-14 but upgraded. It still shows up in my rpm --query kernel but I thought that is just in the RPM database. Now that 20-13.8 is running I can probably remove safely.
2) When redhat detected a software change of my video card (or tried installing with the Asus v7100) it locked. So I installed with another card. Shutdown replaced the other card with the 7100 and told the autodetect to ignore the change. I wouldnt think that this would affect the compile.

Still confused
Jim


All times are GMT -5. The time now is 07:45 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.