nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NForce2 AGP "Failure to recognize" problem (http://www.nvnews.net/vbulletin/showthread.php?t=12484)

DethMaster 05-27-03 06:56 PM

NForce2 AGP "Failure to recognize" problem
 
1 Attachment(s)
I'm using the latest Nforce drivers and the latest Graphics card drivers, but I cannot use AGP at all. In my XFree86 Log file it says that it fails to verify AGP usage. Wierd. I do not have support in the kernel at all for AGPGART. It's simply not there.
OpenGL stuff still works. UT2003 will even run, but it's not doing AGP.

dkowis@Raziel:~$ cat /proc/driver/nvidia/agp/status
Status: Disabled

I'll attach the log right now, and I hope that I can attach my XF86Config file as well.

DethMaster 05-27-03 06:57 PM

1 Attachment(s)
Adding my XF86Config file so that it can be browsed

DrOzz 05-27-03 07:06 PM

i had the same problem along with various other problems, but if you wanted to look at what i did to fix my machine you can refer to my post..

My Fix

it may suck to go through all that, and i would suggest trying the various other things that people have tried and succeeded with that you'll find throughout these fourms and i assume people will post with things you can try, but as a last resort you can try what i did....
GL!

dleblanc 05-28-03 10:18 PM

The nForce AGPGART patch has been merged into kernel 2.4.21-rc5-ac1. You could try that, and see if AGPGART works for you. Patch for 2.4.20 kernel can be downloaded here.

Edit: I just did this, it worked, but if you've just got the 2.4.20 kernel, you have to apply the 2.4.21-rc5 patch first.

shassard 05-28-03 10:21 PM

another stupid point is that /proc/driver/nvidia/agp/status only shows enabled when xf86 is actually running ..

DethMaster 05-29-03 02:51 PM

well.... I'm administering my box via ssh and i built the new kernel then rebooted and it didn't come back into network existance. So, I'll have to wait until I get home to tell you if it worked.
Thanks for the help

DethMaster 06-12-03 08:17 AM

KDE or gnome hozing
 
When I use that kernel or anyone later than it, KDE and gnome don't start anymore. There's also a problem with kdemultimedia compiling. It dies on /usr/include/asm/byteorder.h The file seems to be written badly.

I think I might have agp support now, but nothing stays working long enough to test it.


All times are GMT -5. The time now is 01:31 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.