nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   HDMI audio not working once X starts (http://www.nvnews.net/vbulletin/showthread.php?t=124872)

justinj 12-17-08 07:21 PM

HDMI audio not working once X starts
 
First let me say, my audio works while at a terminal before X starts. Then once I start X with the nvidia binary, the audio stops working. If I start it with the nv driver, it does fine, but I need xvmc, so thats not really an option.

I'm using the latest alsa 1.0.18a (which is what I needed to get any audio over hdmi)
I've tried the latest drivers as well as the latest beta drivers, same result.

The biggest thing I've noticed is that while audio is working /proc/asound/card0/codec#1
Pin-ctls = 0x40
Amp-out = 0x0

But after I start X with the nvidia drivers,
Pin-ctls = 0x0
Amp-out = 0x80

Does anyone have any guidance for getting hdmi audio working while X is running, or investigating what would be changing the codec#1 (assuming whatever changes that is the root cause of the problem) I assume there aren't any options for the module or options in xorg.conf that could affect the audio operation, but maybe someone can correct me on that.

Thank you for any help or suggestions on how to track this down.

Also note, I have analog audio working while the nvidia X is running, just not the digital audio over hdmi.
Also note, the aplay lists the hdmi device correctly, and I can write to it via speaker-test in both terminal mode and X mode, but only while in terminal mode do I hear anything come out of the speakers.

toor 12-18-08 02:42 AM

Re: HDMI audio not working once X starts
 
I have such problem too. Just one addition that with 100.14.19 driver HDMI audio works without problems both before X starts and while in X.

justinj 12-18-08 11:30 AM

Re: HDMI audio not working once X starts
 
I realize you have the same problem, I was hoping for some help though. Let me also say that the latest 96.xxx (or 173.xxx for that matter) series drivers have the same audio problem. I haven't been able to come up with a patch for 100.14.19 on kernel 2.6.27, so I can't validate that being a solution/workaround for me.

I just can't think of anything nvidia be doing to the audio subsystem when X starts that would cause it to be broken.

If I restart alsa inside X the audio remains broken. However, if I shut down X, then restart alsa, I get the audio back. Start X again...audio broken once again. Frustrating!

wck555 05-04-09 10:35 PM

Re: HDMI audio not working once X starts
 
I have the same issue on my system and am currently working on a solution. I have been posting results of my tests to this thread:

http://www.nvnews.net/vbulletin/show....php?p=1996245

I am curious. What nvidia GPU do you have? What variety of Linux are you running?

I am not able to play audio when X is stopped. aplay -l returns "aplay: device_list:215: no soundcards found...". I wonder how you are able to play audio with X stopped?

For me restarting alsa does not restore the HDMI audio. I have to reboot the system.


All times are GMT -5. The time now is 08:55 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.