nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Sidux - Type1 not loaded (http://www.nvnews.net/vbulletin/showthread.php?t=125034)

sidux-user 12-20-08 12:09 PM

Sidux - Type1 not loaded
 
2 Attachment(s)
Hello,

I have a problem using the nvidia driver on my sidux computer. The card Geforce 4 440 Go did work with the kernel 2.6.27.07 before playing around with framebuffer images in TTY (fbi), but started making problems afterwards. With the kernel 2.6.27.10, everything works but the nvidia-driver.

I tried both, the actual driver 96.43.07 and the beta-driver -09, which give the same result. The screen is completely black. It does not even say that it is not working, it's just blank and black.
The last time I logged in, I also was able to hear the "Welcome"-sound, which is strange, because I had no chance to log in...?!?

What I did:
I started the xserver ("startx -- -logverbose 6") on TTY1, ran nvidia-bugreport.sh on TTY2 and after completition, killed the xserver again using ^c.

I think the problem is related to the what I wrote in the title: this is the only error I find in the Xorg.0.log.
Maybe also of interest: The first problems with the xserver appeared, after using framebuffer grafics like fbi. But I have no idea why this should have an influence on the xserver.

Btw, the community "nv"-driver works.

p.s. the logfile was too big, I split it.

alienexplorers 12-20-08 01:01 PM

Re: Sidux - Type1 not loaded
 
Remove from your xorg.conf file the line:
Quote:

Load "type1"
Add to your xorg.conf device section:
Quote:

Option "RenderAccel" "0"

sidux-user 12-21-08 07:55 AM

Re: Sidux - Type1 not loaded
 
1 Attachment(s)
The answer sounds so cool, I was almost ready to write: 'Did the job'

But it failed, same problem, but no error in /var/log/Xorg.0.log :-(

I attached the new nvidia-report-log, this time smaller than the limit.

AaronP 12-21-08 10:30 AM

Re: Sidux - Type1 not loaded
 
Hi sidux-user,

According to your log file, your GPU is not detecting any connected display devices. What monitor is connected, and how?

Also, if the log file is too big to attach, you can gzip it.

sidux-user 12-21-08 04:27 PM

Re: Sidux - Type1 not loaded
 
Strange error. It is a notebook (Samsung X10).
No idea of internal wiring...

sidux-user 12-23-08 03:41 PM

Re: Sidux - Type1 not loaded
 
No more ideas?

*push*

blackiron 12-23-08 09:54 PM

Re: Sidux - Type1 not loaded
 
# Load "type1"

sidux-user 12-26-08 09:03 AM

Re: Sidux - Type1 not loaded
 
Quote:

Originally Posted by blackiron (Post 1883892)
# Load "type1"

Well, thanks for the answer.
But this was the idea of alienexplorer in the second post in this thread, by the way.

Happy Christmas

alienexplorers 12-26-08 12:40 PM

Re: Sidux - Type1 not loaded
 
I had problems with the 96.43.07 driver and went with the 96.43.09 driver. Made the two changes mentioned in my original post and everything worked fine including compiz.
My xorg.conf looks like so:
Code:

terminator@terminator-desktop:~$ cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Mon Nov  3 08:46:46 UTC 2008


Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load          "dbe"
    Load          "extmod"
    Load          "freetype"
    Load          "GLcore"
    Load          "v4l"
    Load          "glx"
EndSection

Section "ServerFlags"
    Option        "Xinerama" "0"
EndSection

Section "InputDevice"
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/psaux"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier    "Keyboard0"
    Driver        "kbd"
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "ViewSonic"
    ModelName      "ViewSonic VA703 SERIES"
    HorizSync      30.0 - 82.0
    VertRefresh    50.0 - 75.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce FX 5200"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "NoLogo" "True"
    Option        "RenderAccel" "False"
    Option        "AddARGBGLXVisuals" "True"
    Option        "AllowGLXWithComposite" "True"
    Option        "EnablePageFlip" "true"
    Option        "TwinView" "0"
    Option        "TwinViewXineramaInfoOrder" "CRT-0"
    Option        "metamodes" "1280x1024_60 +0+0"
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection

Section "DRI"
    Group      "video"
    Mode      0660
EndSection

Section "Extensions"
    Option        "Composite" "Enabled"
EndSection


sidux-user 12-28-08 10:26 AM

Re: Sidux - Type1 not loaded
 
1 Attachment(s)
Hmmm....

I tried your xorg.conf and the 09. beta, but the display stays black :-(

To me it seems it is one of these EDID-problems.

Unfortunately I wasnt able to check the md5 of my EDID, because running nvidia-settings did not give me the DFT-choice or however it was called.

I produced a new bug-report.
Greets

sidux-user 01-01-09 12:24 PM

Re: Sidux - Type1 not loaded
 
*push* once again

sidux-user 01-05-09 05:59 AM

Re: Sidux - Type1 not loaded
 
:-(


All times are GMT -5. The time now is 06:52 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.