nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   problems with compiz and multiple cards (http://www.nvnews.net/vbulletin/showthread.php?t=125398)

schomin 12-29-08 01:35 PM

problems with compiz and multiple cards
 
Ok so i have two 8800gt's (not in SLI) with a monitor connected to each. I have xinerama enable on the monitors so i can have a single desktop spanning across two GPU's and two displays. I can't seem to get compiz to work though i'm not sure if xinerama supports it but i've herd people have gotten compiz to work with xinerama.

I guess my question is what kind of options do i have and is there a better setup than what i have now? because i want the two gpu's and i want compiz.

Also i'm getting some smearing between monitors i'm guessing this is because of the seperate gpu's and xinerama.

I'm using 180.12 i think it is

heres my xorg.conf:

Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Sun Dec 14 20:59:16 PST 2008

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder58)  Sun Dec 14 20:59:58 PST 2008

Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" 1920 150
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "Module"
    Load          "dbe"
    Load          "extmod"
    Load          "type1"
    Load          "freetype"
    Load          "glx"
EndSection

Section "ServerFlags"
    Option        "Xinerama" "1"
EndSection

Section "InputDevice"

    # generated from default
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier    "Keyboard0"
    Driver        "kbd"
    Option        "XkbLayout" "us"
    Option        "XkbModel" "pc105"
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync      27.0 - 81.0
    VertRefresh    50.0 - 75.0
    Option        "DPMS"
EndSection

Section "Monitor"
    Identifier    "Monitor1"
    VendorName    "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync      30.0 - 81.0
    VertRefresh    56.0 - 75.0
EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 8800 GT"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier    "Device1"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 8800 GT"
    BusID          "PCI:3:0:0"
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "DFP-0: nvidia-auto-select +0+0"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "AllowGLXWithComposite" "True"
    Option        "RenderAccel" "true"
    Option        "AddARGBGLXVisuals" "True"
    Option        "DRI" "True"
    Option        "SLI" "off"
    Option        "MultiGPU" "off"
    Option        "TwinView" "1"
    Option        "metamodes" "nvidia-auto-select +0+0"
    Option        "CursorShadow" "true"
    Option        "AddARGBVisuals" "True"
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "DFP-1: nvidia-auto-select +0+0"
    Identifier    "Screen1"
    Device        "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option        "AllowGLXWithComposite" "True"
    Option        "RenderAccel" "true"
    Option        "AddARGBGLXVisuals" "True"
    Option        "DRI" "True"
    Option        "SLI" "off"
    Option        "MultiGPU" "off"
    Option        "TwinView" "1"
    Option        "metamodes" "nvidia-auto-select +0+0"
    Option        "CursorShadow" "true"
    Option        "AddARGBVisuals" "True"
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection

Section "Extensions"
    Option        "RENDER" "true"
    Option        "Composite" "Enable"
EndSection


schomin 12-29-08 02:16 PM

Re: problems with compiz and multiple cards
 
bump?

Dragoran 12-29-08 03:02 PM

Re: problems with compiz and multiple cards
 
Composite is not supported when Xinerama is in use, and its required for compiz to run.

schomin 12-29-08 03:04 PM

Re: problems with compiz and multiple cards
 
Yeah thats what i figured. Is compiz-fusion any different? or is there anyway to get twinview working, as i am not using SLI?

Dragoran 12-29-08 03:13 PM

Re: problems with compiz and multiple cards
 
No compiz = compiz-fusion without the plugins, besides any compositing manager requires the composite extension.

As for twinview with multiple card, dunno if this is possible.

schomin 12-29-08 03:19 PM

Re: problems with compiz and multiple cards
 
ok well thanks anyways.

I know that SLI is not able to use TWinview but it never said anything about seperate cards so i didn't know.

adamk75 12-29-08 06:44 PM

Re: problems with compiz and multiple cards
 
twinview can not use separate video cards. The only option would be to use xinerama, and then running an Xgl session on top of that. Not an easy solution, and certainly not a supported one (as Xgl is deprecated) but it is possible.

Adam

schomin 12-30-08 12:41 AM

Re: problems with compiz and multiple cards
 
Quote:

Originally Posted by adamk75 (Post 1887480)
twinview can not use separate video cards. The only option would be to use xinerama, and then running an Xgl session on top of that. Not an easy solution, and certainly not a supported one (as Xgl is deprecated) but it is possible.

Adam

ok well thanks for the help. is there anyway to run the cards in SLI with xinerama and if so would it be more efficient?

adamk75 12-30-08 03:47 AM

Re: problems with compiz and multiple cards
 
Sorry, I have no idea about SLI :-)

Adam

schomin 12-30-08 10:40 AM

Re: problems with compiz and multiple cards
 
Ok well thanks again. Do you know how i would go about setting up the xgl setup you mentioned earlier?

schomin 12-31-08 12:56 PM

Re: problems with compiz and multiple cards
 
other input would be greatly appreciated.

Dragoran 12-31-08 01:01 PM

Re: problems with compiz and multiple cards
 
Quote:

Originally Posted by schomin (Post 1889059)
other input would be greatly appreciated.

simply connect the second monitor to the first card and use twinview?


All times are GMT -5. The time now is 02:44 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.