nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Solaris (http://www.nvnews.net/vbulletin/forumdisplay.php?f=45)
-   -   BugReport for 1.77.82 and snv_101b - Failed to initialize the NVIDIA graphics device! (http://www.nvnews.net/vbulletin/showthread.php?t=125411)

betchou 12-29-08 06:29 PM

BugReport for 1.77.82 and snv_101b - Failed to initialize the NVIDIA graphics device!
 
1 Attachment(s)
Hye all,

you will see in attachments two bug reports.

- The first one is when I don't try to correct symlinks which are still linking with mesa.
It is related to this bug: http://defect.opensolaris.org/bz/show_bug.cgi?id=363 which seems not to be corrected yet.

- The second report is when symlinks are "corrected". May be partially corrected... I updated the /var/run/opengl symlinks with the following script.

Code:

#!/usr/bin/env bash

find /usr/X11/include/NVIDIA/GL/ -name *.h -exec ln -sf {} /var/run/opengl/include \;

ln -sf /usr/X11/lib/NVIDIA/libGL.so.1 /var/run/opengl/lib/libGL.so.1
ln -sf /usr/X11/lib/NVIDIA/amd64/libGL.so.1 /var/run/opengl/lib/amd64/libGL.so.1

ln -sf /usr/X11/lib/modules/extensions/NVIDIA/libglx.so /var/run/opengl/server/libglx.so
ln -sf /usr/X11/lib/modules/extensions/NVIDIA/amd64/libglx.so /var/run/opengl/server/amd64/libglx.so

In the second case I'm going further, but it still ends with "Failed to initialize the NVIDIA graphics device!"

In those two cases I'm following the basic procedure ...
sh NVIDIA-Solaris-x86-177.82.sh
pfexec nvidia-xconfig
ctr+alt+backspace or pfexec svcadm restart gdm or pfexec init 6

I hope you will be able to help me. :)

Regards,
betchou

betchou 12-30-08 06:22 PM

Re: BugReport for 1.77.82 and snv_101b - Failed to initialize the NVIDIA graphics dev
 
As I see here symlinks should be corrected in build 103. There is a release for IPS in January with the build 105. This should be at least better ...
But I already think having corrected symlinks.

betchou 01-09-09 03:59 AM

Re: BugReport for 1.77.82 and snv_101b - Failed to initialize the NVIDIA graphics dev
 
NVIDIA 9300GE Device PCI ID 0x06EA works with 1.80.22 !! Please add it to the Supported NVIDIA GPU for 1.80.22 webpage :)


All times are GMT -5. The time now is 12:33 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.