nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GF8200 / Poor 2D performance / ETA of fix? (http://www.nvnews.net/vbulletin/showthread.php?t=125471)

Space 12-30-08 10:11 PM

GF8200 / Poor 2D performance / ETA of fix?
 
1 Attachment(s)
Hello,

I just bought a new board (Asrock K10N78FullHD) with GF 8200 chipset to watch HDTV via VDPAU. The board replaced my old GF 7050 based one (Asrock Alive NF7G) and when the system booted up I was really shocked. I never thought that 2D could be *that* *slow*. After reading in this forum I found out that this is a known problem and lots of people have it. Too bad it was not mentioned in the threads regarding VDPAU. But one question was either never asked or answered: when will there be a fix for this? I read something about "later in the 177 series" but that answer is almost 6 month old. And somewhere it was mentioned that the performance enhancements are enabled in the later 180.xx drivers but the current one (180.18) does not fix the problem for me.

So Nvidia. What's the plan about fixing this? Are there any estimates yet or will the answer be the Duke Nukem one? Because then this board will go back to the dealer for sure and I will buy an AMD based one.

The bugreport is attached.

Best regards,

Space

Space 12-31-08 07:07 PM

Re: GF8200 / Poor 2D performance / ETA of fix?
 
Hello,

I have downgraded to 173.14.15. This fixed the worst performance problems although I still have some sporadic flicker which I never noticed with the 7050 chipset.

But since the main reason for buying this board was VDPAU I still would like to know then the performance problems in the 180 series will be fixed. Is Nvidia working on this?

Best regards,

Space

Space 01-09-09 11:33 AM

Re: GF8200 / Poor 2D performance / ETA of fix?
 
Today I tested with 180.22. The performance is as slow as with previous releases > 173.14.15.

So the question remains: when will this be fixed?

Best regards,

Space

apaige 01-09-09 01:07 PM

Re: GF8200 / Poor 2D performance / ETA of fix?
 
If you're using a compositing window manager (Compiz, KDE4, etc…), you can't really talk of 2D performance. If you're not, disable the Composite extension, just in case. Also, do you run "nvidia-settings -a PixmapCacheRoundSizeKB=65536" after starting X? That helps a lot with 2D performance. The value I'm using (64 megabytes) is probably overkill, but I don't feel like testing for hours to find the sweet spot.

I have a GeForce 8300 IGP, running Openbox and GTK2 apps, and with the recent optimizations added to the driver (among which, the aformentionned parameter), performance is pretty good. gtkperf -c 1000 runs in less than 80 seconds, scrolling in Firefox is smooth (even on pages with fixed backgrounds), etc… There's still a couple of bugs remaining of course.

zim2dive 01-09-09 01:39 PM

Re: GF8200 / Poor 2D performance / ETA of fix?
 
Quote:

Originally Posted by apaige (Post 1898421)
If you're using a compositing window manager (Compiz, KDE4, etc…), you can't really talk of 2D performance. If you're not, disable the Composite extension, just in case. Also, do you run "nvidia-settings -a PixmapCacheRoundSizeKB=65536" after starting X? That helps a lot with 2D performance. The value I'm using (64 megabytes) is probably overkill, but I don't feel like testing for hours to find the sweet spot.

I have a GeForce 8300 IGP, running Openbox and GTK2 apps, and with the recent optimizations added to the driver (among which, the aformentionned parameter), performance is pretty good. gtkperf -c 1000 runs in less than 80 seconds, scrolling in Firefox is smooth (even on pages with fixed backgrounds), etc… There's still a couple of bugs remaining of course.

can you play video from hulu.com/hd ? Can you play The Daily show episodes at full-screen?

I can under 173 .. changing nothing else, this breaks miserably with 177, 180. So the problem seems independent of window manager, cache size, etc.

Again, the only thing you need to do to massively impact performance is to swap between 173 and 177/180.. that rather definitely suggests that the nvidia driver has introduced a massive performance decrease.

Other changes may or many not help as well, but the driver itself needs fixing.

apaige 01-10-09 04:15 AM

Re: GF8200 / Poor 2D performance / ETA of fix?
 
So you're not really talking about 2D performance, you're really just talking about Flash.

Flash has always been crap. Not to say that NVIDIA can't do anything about it. If you download the flv and use mplayer to play it, you'll see no performance issue at all. Hint: you're not supposed to watch videos in a web browser in the first place.

X-Dimension 01-10-09 05:13 AM

Re: GF8200 / Poor 2D performance / ETA of fix?
 
Please look at all the GF8200/8300 IGP threads here! This is not a flash problem!
The desktop performance ist horrible slow. You can see how your login screen is drawed line by line with Nvidia driver later 173.xx!

I switched back to the X.org vesa driver because 173.xx don't compile with my kernel 2.6.28 and the 2D-performance is for me unusable with 177.xx and 180.xx.

BTW: Those people who talking about flash performance issues here are often using Compiz! Compiz is a 3D accelerated desktop, so they don't see the 2D performance issues all other users are talking about here! They only see this problem when they're using something that is rendered in 2D like flash!

Linuxhippy 01-10-09 06:05 AM

Re: GF8200 / Poor 2D performance / ETA of fix?
 
Quote:

Originally Posted by X-Dimension (Post 1899158)
BTW: Those people who talking about flash performance issues here are often using Compiz! Compiz is a 3D accelerated desktop, so they don't see the 2D performance issues all other users are talking about here!

Compiz does not change how applications draw their contents, this has really nothing to do with 2D or 3D. The only difference is that instead to screen applications draw to an additional buffer which is the blended using OpenGL, however all the application rendering is still done using X11/XRender.

Without compiz: Application --2D--> Back-Buffer --2D--> Screen
With Compiz: Application ---2D--> Back-Buffer --2D---> Window backbuffer --3D--> Screen


- Clemens

Dragoran 01-10-09 06:54 AM

Re: GF8200 / Poor 2D performance / ETA of fix?
 
Quote:

Originally Posted by Space (Post 1898345)
Today I tested with 180.22. The performance is as slow as with previous releases > 173.14.15.

So the question remains: when will this be fixed?

Best regards,

Space

Try
Code:

nvidia-settings -a InitialPixmapPlacement=1
(its 2 by default in 180.x and was 1 in anything older).

That might be your problem. (even thought IPP=2 should be faster in most cases)

zim2dive 01-10-09 07:23 AM

Re: GF8200 / Poor 2D performance / ETA of fix?
 
Quote:

Originally Posted by Dragoran (Post 1899200)
Try
Code:

nvidia-settings -a InitialPixmapPlacement=1
(its 2 by default in 180.x and was 1 in anything older).

That might be your problem. (even thought IPP=2 should be faster in most cases)

177 was bad too. So your explanation doesn't hold water.

Quote:

Originally Posted by apaige
So you're not really talking about 2D performance, you're really just talking about Flash.Flash has always been crap.

Again, reading comprehension is fundamental. Flash works very well with 173 and very badly with 177/180. That very clearly shows that nvidia has done something which has significantly degraded performance (and which they should be able to correct).

Not sure why it is that everyone wants to ignore this very set of what works well and what doesn't. I'm not saying there's only one thing that is sub-optimal.. but its VERY clear that whatever issues Flash has, the nvidia driver is making them WORSE for the 8200/8300 in particular (whereas other nvidia GPUs tended to improve performance over these drivers, the 8200/8300 got worse)

apaige 01-10-09 09:58 AM

Re: GF8200 / Poor 2D performance / ETA of fix?
 
Quote:

Originally Posted by X-Dimension (Post 1899158)
Please look at all the GF8200/8300 IGP threads here! This is not a flash problem!
The desktop performance ist horrible slow. You can see how your login screen is drawed line by line with Nvidia driver later 173.xx!

Yes I see all those threads, but they must be doing something different from me, because I have a 8300 and my desktop performance is not horrible slow (sic) at all. Windows get drawn instantly. Then again, the nvidia-settings command I run plays a big role in 2D performance.

Windseeker 01-10-09 10:46 AM

Re: GF8200 / Poor 2D performance / ETA of fix?
 
Quote:

Originally Posted by apaige (Post 1899315)
Yes I see all those threads, but they must be doing something different from me, because I have a 8300 and my desktop performance is not horrible slow (sic) at all. Windows get drawn instantly. Then again, the nvidia-settings command I run plays a big role in 2D performance.

Hmmm... I don't own a GF8 card, but out of the logic:
At the login screen you don't set any values with nvidia-settings, too. I bet your nvidia-settings is executed _after_ login from KDE/Gnome Autostart. So the problem could only be in some xorg.conf parameters or really a horrible bug in the driver or a broken card.

And before somebody is shouting "nonsense!": Yes, broken card could match the report as well, because the newer driver could perhaps trigger the fault whilst the older drivers didn't. I can't tell how likely this might be, but it is possible, too.


All times are GMT -5. The time now is 11:22 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.