nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   [BUG REPORT] 8600M: gnome-terminal refresh and performance problems (http://www.nvnews.net/vbulletin/showthread.php?t=125706)

Snaury 01-05-09 03:19 PM

[BUG REPORT] 8600M: gnome-terminal refresh and performance problems
 
1 Attachment(s)
Since sticky post was saying to file a bug report if I'd still experience performance problems here it is. Even scrolling this nvnews website is horribly slow in firefox (though, I must say, that nvidia is very close to nv driver with 180.18, but still it is still way too horrible).

Another, and primary, problem with 180.* (<=180.18) is that vte (gnome-terminal, guake, etc) often don't redraw themselves with Compiz, especially when using Midnight Commander. This is extremely serious and prevents me from using Midnight Command (with Compiz) at all. For example: sometimes, when pressing keys (like PageUp/PageDown when viewing some text file), there is nothing changed on the screen, but pressing Ctrl+L shows that it just didn't draw itself properly, these forgotten redraws are very confusing.

As this often happens with complete vte redraws (like PageUp/PageDown in Midnight Commander) with Compiz enabled, I'm not sure what it is related to. But, since I see it a lot less with 177.* it might be some regression in 180.*.

X-Dimension 01-06-09 12:24 PM

Re: [BUG REPORT] 8600M: gnome-terminal refresh and performance problems
 
Did you have this problem also with the driver 173.xx and 177.xx Versions?
Many users report this problem with Geforce 8200/8300 IGP. The 173.xx driver series works much better, but has no sound over HDMI and also no VDPAU.

Snaury 01-06-09 12:46 PM

Re: [BUG REPORT] 8600M: gnome-terminal refresh and performance problems
 
Quote:

Originally Posted by X-Dimension (Post 1894640)
Did you have this problem also with the driver 173.xx and 177.xx Versions?
Many users report this problem with Geforce 8200/8300 IGP. The 173.xx driver series works much better, but has no sound over HDMI and also no VDPAU.

Well, I didn't check it with 173.xx, but I did check it with 177.xx that is shipped with Ubuntu 8.10 (Intrepid Ibex), and I believe I still had the redraw issue with compiz, although it was much more rare (if it was at all, since I'm not sure/can't remember).

As for performance, 180.xx is worse for me than stock 177.xx that is in Ubuntu 8.10. And both are so horribly slow that they once again squeezed me back to Vista. I hope performance and other problems would be resolved by the time Ubuntu 9.04 is released, until then I won't even try to touch this buggy crap again. :(


All times are GMT -5. The time now is 02:52 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.