nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Can't enable XGL (http://www.nvnews.net/vbulletin/showthread.php?t=125734)

Tweetie 01-06-09 04:36 AM

Can't enable XGL
 
Using x86_64, nVidia card with prop. nVidia drivers, KDE4, Compiz-fusion.

After trying to get X and Compiz to stop eating CPU resources, I was told to try using XGL instead of "native support". However, every time I enable XGL, I cannot boot in, X kicks me out, and have to re-enable native support to get a working desktop.

Checking the xorg.log there are no errors indicated, however in xorg.9.log, there is a short section which describes the following problem:

Code:

(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions//libglx.so
dlopen: /usr/lib64/xorg/modules/extensions//libglx.so: cannot open shared object file: No such file or directory
(EE) Failed to load /usr/lib64/xorg/modules/extensions//libglx.so
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (loader failed, 7)

I added a line in xorg.conf to point to the module location, but still the above error occurs.

Un-installing the nVidia driver as per nVidia documentation (nvidia-installer --uninstall), then re-installed, but still the same problem, Xgl does not start. Installing the driver as pure x86_64 instead of 32 bit libraries as well (to get Google Earth to run), does not solve the problem. I have deleted libglx.so and the symlinked file in case there was a problem with these files, the nVidia driver re-installs them but still no joy.

Also as the help documentation suggests, I check the existence of certain files / symlinks, libglx.so does exist as a link to the current version of libglx for the nVidia driver.

I am now lost at what to do next, I am no Linux expert so don't want to do any more that might trash the setup, which brings me here.

Current driver version: NVIDIA-Linux-x86_64-177.82-pkg2.run
Card: Nvidia GeForce 6200 TurboCache

nvpro 01-06-09 04:50 AM

Re: Can't enable XGL
 
XGL has a few drawbacks, is unsupported and not developed anymore; in general you shouldn't use it anymore.
What problem exactly do you have with Compiz? It might be worth to give the new beta drivers (180.xx) a try.

phaedrusiszen 01-06-09 05:11 AM

Re: Can't enable XGL
 
XGL is not your friend. Back in the day it was an alternative, but shouldn't be used anymore.

It looks like your driver is not installed correctly. Since it's looking in lib64 and not finding the driver, are you sure it correctly installed the 64-bit version of the driver? If so, try creating a symlink in that directory to the NVIDIA libglx.so.

Tweetie 01-06-09 05:12 AM

Re: Can't enable XGL
 
Specifically, the problem I've had is that the combination of X and Compiz eat processor usage as if it's going out of fashion, looking like the graphics work is being done mostly by the processor. On a normal boot X+Compiz eat anything from 10% to 40% (observed from using "top"), and obviously starting more applications like the TV makes processor usage go up.

However, before Beryl was axed, I used X+Beryl and it would use 5% of processor no matter how hard you pushed the graphics, used stupidly computational useless intensive effects like snow and / or moving the 3D box around. The graphics card was doing ALL the graphics work.

Obviously the software has been updated, as have the drivers. The one thing though that has not changed is the hardware.

So I can't figure what is going on, and would like the processor usage to drop considerably.

I have a separate issue when installing the nVidia drivers where all the screens showing the installation process have allthetextinoneline - no character spaces, also the next screen does not clear the previous, so the text over-writes the previous screen making it impossible to read. That problem has never been identified as what is causing it.

phaedrusiszen 01-06-09 05:23 AM

Re: Can't enable XGL
 
Can you install the 180.18 driver? I know it's beta, but it improves much of what you're talking about.
If the problem persists after that, can you post the Xorg log? Also, the output of glxinfo?

Tweetie 01-06-09 08:21 AM

Re: Can't enable XGL
 
The Beta driver did not solve the problem, still have the same libglx error.

xorg.conf
Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister)  Tue Nov  4 17:18:57 PST 2008
# File generated by XFdrake (rev 247269)

Section "ServerLayout"
    Identifier    "Layout0"
    Screen        "screen1" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    ModulePath      "/usr/lib64/xorg/modules"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "Module"
    Load          "dbe"
    Load          "v4l"
    Load          "extmod"
    Load          "type1"
    Load          "freetype"
    Load          "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/psaux"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier    "Keyboard0"
    Driver        "kbd"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "gb"
    Option        "XkbOptions" "compose:rwin"
EndSection

Section "Monitor"

    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    Identifier    "monitor1"
    VendorName    "Generic"
    ModelName      "Flat Panel 1280x1024"
    HorizSync      31.5 - 90.0
    VertRefresh    60.0
    ModeLine      "768x576" 50.00 768 832 846 1000 576 590 595 630
    ModeLine      "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier    "screen1"
    Device        "Device0"
    Monitor        "monitor1"
    DefaultDepth    24
    Option        "DPMS"
    Option        "DisableGLXRootClipping" "True"
    Option        "RenderAccel" "True"
    SubSection    "Display"
        Depth      24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Extensions"
    Option        "Composite" "Enable"
EndSection

"glxinfo" command (edited highlights)

Code:

name of display: :0.0   
display: :0  screen: 0   
direct rendering: Yes   
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4             
server glx extensions:                     
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,   
    GLX_EXT_texture_from_pixmap, GLX_ARB_create_context, GLX_ARB_multisample,
    GLX_NV_float_buffer, GLX_ARB_fbconfig_float                             
client glx vendor string: NVIDIA Corporation                                 
client glx version string: 1.4                                               
client glx extensions:                                                       
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,     
    GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,       
    GLX_NV_swap_group, GLX_NV_video_out, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGI_swap_control, GLX_ARB_create_context, GLX_NV_float_buffer,       
    GLX_ARB_fbconfig_float, GLX_EXT_fbconfig_packed_float,                   
    GLX_EXT_texture_from_pixmap, GLX_EXT_framebuffer_sRGB,                   
    GLX_NV_present_video, GLX_NV_multisample_coverage                       
GLX version: 1.3                                                             
GLX extensions:                                                             
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,           
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,             
    GLX_EXT_texture_from_pixmap, GLX_ARB_create_context, GLX_ARB_multisample,
    GLX_NV_float_buffer, GLX_ARB_fbconfig_float, GLX_ARB_get_proc_address   
OpenGL vendor string: NVIDIA Corporation                                     
OpenGL renderer string: GeForce 6200 TurboCache(TM)/PCI/SSE2                 
OpenGL version string: 2.1.2 NVIDIA 180.17                                   
OpenGL extensions:                                                           
    GL_ARB_color_buffer_float, GL_ARB_depth_texture, GL_ARB_draw_buffers,   
    GL_ARB_fragment_program, GL_ARB_fragment_program_shadow,                 
    GL_ARB_fragment_shader, GL_ARB_half_float_pixel, GL_ARB_half_float_vertex,
    GL_ARB_framebuffer_object, GL_ARB_imaging, GL_ARB_multisample,           
    GL_ARB_multitexture, GL_ARB_occlusion_query, GL_ARB_pixel_buffer_object, 
    GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,             
    GL_ARB_shader_objects, GL_ARB_shading_language_100,                       
    GL_ARB_texture_border_clamp, GL_ARB_texture_compression,                 
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,                         
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3, GL_ARB_texture_float,
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_non_power_of_two,         
    GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,                       
    GL_ARB_vertex_array_object, GL_ARB_vertex_buffer_object,                 
    GL_ARB_vertex_program, GL_ARB_vertex_shader, GL_ARB_window_pos,           
    GL_ATI_draw_buffers, GL_ATI_texture_float, GL_ATI_texture_mirror_once,   
    GL_S3_s3tc, GL_EXT_texture_env_add, GL_EXT_abgr, GL_EXT_bgra,             
    GL_EXT_blend_color, GL_EXT_blend_equation_separate,                       
    GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract,   
    GL_EXT_compiled_vertex_array, GL_EXT_Cg_shader, GL_EXT_depth_bounds_test, 
    GL_EXT_direct_state_access, GL_EXT_draw_range_elements, GL_EXT_fog_coord, 
    GL_EXT_framebuffer_blit, GL_EXT_framebuffer_multisample,                 
    GL_EXT_framebuffer_object, GL_EXT_gpu_program_parameters,                 
    GL_EXT_multi_draw_arrays, GL_EXT_packed_depth_stencil,                   
    GL_EXT_packed_pixels, GL_EXT_pixel_buffer_object, GL_EXT_point_parameters,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,                           
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,                     
    GL_EXT_stencil_two_side, GL_EXT_stencil_wrap, GL_EXT_texture3D,           
    GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,                 
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,                   
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,               
    GL_EXT_texture_lod, GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp, 
    GL_EXT_texture_object, GL_EXT_texture_sRGB, GL_EXT_timer_query,           
    GL_EXT_vertex_array, GL_EXT_vertex_array_bgra, GL_IBM_rasterpos_clip,     
    GL_IBM_texture_mirrored_repeat, GL_KTX_buffer_region, GL_NV_blend_square, 
    GL_NV_copy_depth_to_color, GL_NV_depth_clamp, GL_NV_fence,               
    GL_NV_float_buffer, GL_NV_fog_distance, GL_NV_fragment_program,           
    GL_NV_fragment_program_option, GL_NV_fragment_program2,                   
    GL_NV_framebuffer_multisample_coverage, GL_NV_half_float,                 
    GL_NV_light_max_exponent, GL_NV_multisample_filter_hint,                 
    GL_NV_occlusion_query, GL_NV_packed_depth_stencil, GL_NV_pixel_data_range,
    GL_NV_point_sprite, GL_NV_primitive_restart, GL_NV_register_combiners,   
    GL_NV_register_combiners2, GL_NV_texgen_reflection,                       
    GL_NV_texture_compression_vtc, GL_NV_texture_env_combine4,               
    GL_NV_texture_expand_normal, GL_NV_texture_rectangle,                     
    GL_NV_texture_shader, GL_NV_texture_shader2, GL_NV_texture_shader3,       
    GL_NV_vertex_array_range, GL_NV_vertex_array_range2, GL_NV_vertex_program,
    GL_NV_vertex_program1_1, GL_NV_vertex_program2,                           
    GL_NV_vertex_program2_option, GL_NV_vertex_program3,                     
    GL_NVX_conditional_render, GL_SGIS_generate_mipmap, GL_SGIS_texture_lod, 
    GL_SGIX_depth_texture, GL_SGIX_shadow, GL_SUN_slice_accum


phaedrusiszen 01-06-09 08:24 AM

Re: Can't enable XGL
 
Try adding:
Option "AddARGBGLXVisuals" "True"
To your xorg.conf.

Can you also post the Xorg.0.log?

Thanks.

Tweetie 01-06-09 08:45 AM

Re: Can't enable XGL
 
In directory /usr/lib64/xorg/modules/extensions

libglx.so is linked to libglx.so.180.17 (the beta driver just installed)

Unless the help files are not up to date or a typing mistake.

/lib/modules/'uname -r'/kernel/drivers/video/nvidia.o does not exist
However in that directory exists a "nvidia.ko". Don't know if that means anything.

phaedrusiszen 01-06-09 09:24 AM

Re: Can't enable XGL
 
Quote:

Originally Posted by Tweetie (Post 1894431)
In directory /usr/lib64/xorg/modules/extensions

libglx.so is linked to libglx.so.180.17 (the beta driver just installed)

Unless the help files are not up to date or a typing mistake.

/lib/modules/'uname -r'/kernel/drivers/video/nvidia.o does not exist
However in that directory exists a "nvidia.ko". Don't know if that means anything.

.ko is correct.

Tweetie 01-06-09 09:24 AM

Re: Can't enable XGL
 
I added AddARGBVisuals, but the log file shows it's not being used.

xorg.0.log as used after "XGL" is enabled (instead of "native"). Because of word limit I've edited the log file, left in what is necessary.

Code:

X.Org X Server 1.4.2
Release Date: 11 June 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux_2.6.24.7-server-2mnb Mandriva
Current Operating System: Linux whateva 2.6.27.7-desktop-1mnb #1 SMP Dec 2008 x86_64
Build Date: 05 January 2009  01:36:31PM
 
        Before reporting problems, check http://qa.mandriva.com
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jan  6 15:07:23 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Layout0"
(**) |-->Screen "screen1" (0)
(**) |  |-->Monitor "monitor1"
(**) |  |-->Device "Device0"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "Mouse0"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) Including the default font path catalogue:/etc/X11/fontpath.d.
(**) FontPath set to:
        /usr/share/fonts/default/Type1,
        catalogue:/etc/X11/fontpath.d
(==) RgbPath set to "/usr/share/X11/rgb"
(**) ModulePath set to "/usr/lib64/xorg/modules"
(**) Extension "Composite" is enabled
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x7c0940
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.3
        X.Org Video Driver: 2.0
        X.Org XInput driver : 2.0
        X.Org Server Extension : 0.3
        X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "pcidata"
(II) Loading /usr/lib64/xorg/modules//libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        ABI class: X.Org Video Driver, version 2.0
(--) using VT number 7

(II) PCI: PCI scan (all values are in hex)

(II) PCI: End of PCI scan
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:1:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(II) Subtractive PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:6:0), (0,1,1), BCTRL: 0x0a04 (VGA_EN is cleared)
(II) Bus 1 I/O range:

(II) Bus 1 non-prefetchable memory range:
        [0] -1        0        0xfdd00000 - 0xfddfffff (0x100000) MX[b]
(II) Bus 1 prefetchable memory range:
        [0] -1        0        0xfde00000 - 0xfdefffff (0x100000) MX[b]
(II) PCI-to-PCI bridge:
(II) Bus 2: bridge is at (0:14:0), (0,2,2), BCTRL: 0x0004 (VGA_EN is cleared)
(II) Bus 2 I/O range:

(II) Bus 2 non-prefetchable memory range:
        [0] -1        0        0xfdc00000 - 0xfdcfffff (0x100000) MX[b]
(II) PCI-to-PCI bridge:
(II) Bus 3: bridge is at (0:15:0), (0,3,3), BCTRL: 0x001c (VGA_EN is set)
(II) Bus 3 non-prefetchable memory range:
        [0] -1        0        0xfa000000 - 0xfcffffff (0x3000000) MX[b]
(II) Bus 3 prefetchable memory range:
        [0] -1        0        0xe0000000 - 0xefffffff (0x10000000) MX[b]
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:24:0), (0,0,3), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
        [0] -1        0        0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) Bus 0 non-prefetchable memory range:
        [0] -1        0        0x00000000 - 0xffffffff (0x100000000) MX[b]
(II) Bus 0 prefetchable memory range:
        [0] -1        0        0x00000000 - 0xffffffff (0x100000000) MX[b]
(--) PCI: (1:6:0) Brooktree Corporation Bt878 Video Capture rev 2, Mem @ 0xfdeff000/12
(--) PCI:*(3:0:0) nVidia Corporation NV44 [GeForce 6200 TurboCache(TM)] rev 161, Mem @ 0xfa000000/24, 0xe0000000/28, 0xfb000000/24, BIOS @ 0xfcfe0000/17
(II) Addressable bus resource ranges are

(II) OS-reported resource ranges:

(II) Active PCI resource ranges:

(II) Active PCI resource ranges after removing overlaps:

(II) OS-reported resource ranges after removing overlaps with PCI:

(II) All system resource ranges:

(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "freetype" will be loaded. This was enabled by default and also specified in the config file.
(II) "type1" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) LoadModule: "dbe"
(II) Loading /usr/lib64/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.3
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "v4l"
(II) Loading /usr/lib64/xorg/modules/drivers//v4l_drv.so
(II) Module v4l: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 0.1.1
        ABI class: X.Org Video Driver, version 2.0
(II) LoadModule: "extmod"
(II) Loading /usr/lib64/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.3
(II) Loading extension SHAPE
(II) Loading extension Multi-Buffering
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(II) Loading /usr/lib64/xorg/modules/fonts//libtype1.so
(II) Module type1: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.2
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.5
(II) Loading font Type1
(II) LoadModule: "freetype"
(II) Loading /usr/lib64/xorg/modules/fonts//libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
        compiled for 1.4.2, module version = 2.1.0
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.5
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.0
        Module class: X.Org Server Extension
(II) NVIDIA GLX Module  180.17  Sun Dec 14 20:55:14 PST 2008
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib64/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.13.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.3
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib64/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        ABI class: X.Org Server Extension, version 0.3
(II) Loading extension XFree86-DRI
(II) LoadModule: "nvidia"
(II) Loading /usr/lib64/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.0
        Module class: X.Org Video Driver
(II) LoadModule: "kbd"
(II) Loading /usr/lib64/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.3.1
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.0
(II) LoadModule: "mouse"
(II) Loading /usr/lib64/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.3.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.0
(II) v4l driver for Video4Linux
(II) NVIDIA dlloader X Driver  180.17  Sun Dec 14 21:01:47 PST 2008
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 03:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib64/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.3
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib64/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.3
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"(II) Module "ramdac" already built-in
(II) resource ranges after xf86ClaimFixedResources() call:

(II) resource ranges after probing:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "RenderAccel" "True"
(**) NVIDIA(0): Option "DisableGLXRootClipping" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):    enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce 6200 TurboCache(TM) (NV44) at PCI:3:0:0
(II) NVIDIA(0):    (GPU-0)
(--) NVIDIA(0): Memory: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 05.44.02.41.00
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 6200 TurboCache(TM) at
(--) NVIDIA(0):    PCI:3:0:0:
(--) NVIDIA(0):    HSD HC194D (DFP-0)
(--) NVIDIA(0): HSD HC194D (DFP-0): 155.0 MHz maximum pixel clock
(--) NVIDIA(0): HSD HC194D (DFP-0): Internal Single Link TMDS
(WW) NVIDIA(0): The EDID for HSD HC194D (DFP-0) contradicts itself: mode
(WW) NVIDIA(0):    "640x360" is specified in the EDID; however, the EDID's
(WW) NVIDIA(0):    valid HorizSync range (31.000-81.000 kHz) would exclude
(WW) NVIDIA(0):    this mode's HorizSync (26.2 kHz); ignoring HorizSync check
(WW) NVIDIA(0):    for mode "640x360".
(WW) NVIDIA(0): The EDID for HSD HC194D (DFP-0) contradicts itself: mode
(WW) NVIDIA(0):    "640x360" is specified in the EDID; however, the EDID's
(WW) NVIDIA(0):    valid HorizSync range (31.000-81.000 kHz) would exclude
(WW) NVIDIA(0):    this mode's HorizSync (26.2 kHz); ignoring HorizSync check
(WW) NVIDIA(0):    for mode "640x360".
(II) NVIDIA(0): Assigned Display Device: DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):    "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) NVIDIA(0): DPI set to (85, 86); computed from "UseEdidDpi" X config
(--) NVIDIA(0):    option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:

(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(WW) NVIDIA(0): Option "AddARGBLXVisuals" is not used
(==) RandR enabled
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(**) Option "CoreKeyboard"
(**) Keyboard0: always reports core events
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "gb"
(**) Keyboard0: XkbLayout: "gb"
(**) Option "XkbOptions" "compose:rwin"
(**) Keyboard0: XkbOptions: "compose:rwin"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(**) Option "Protocol" "auto"
(**) Mouse0: Device: "/dev/psaux"
(**) Mouse0: Protocol: "auto"
(**) Option "CorePointer"
(**) Mouse0: always reports core events
(**) Option "Device" "/dev/psaux"
(**) Option "Emulate3Buttons" "no"
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 9
(**) Mouse0: Sensitivity: 1
(II) evaluating device (Mouse0)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) evaluating device (Keyboard0)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(--) Mouse0: PnP-detected protocol: "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded


Tweetie 01-07-09 09:32 AM

Re: Can't enable XGL
 
The second problem I mentioned of corrupted characters when installing the nVidia drivers has at least been found what is causing the problem.

By accident and a lot of reading online, I found that running the nVidia installer with --ui=none uses the command line to install the driver. Therefore that particular problem was caused with ncurses and not the installer itself.

The main problem of the high CPU usage for X+Compiz and being unable to get Xgl to run is still unsolved.

ledoc 01-07-09 06:23 PM

Re: Can't enable XGL
 
Are you sure you have installed xgl properly? Ideally from packages for your distribution? Is there an Xgl.log file?


All times are GMT -5. The time now is 10:25 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.