nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Driver fails with different errors (WAIT, DVC error etc) (http://www.nvnews.net/vbulletin/showthread.php?t=125824)

gimpel 01-07-09 05:55 PM

Driver fails with different errors (WAIT, DVC error etc) after RAM upgrade to 6GB
 
1 Attachment(s)
Hi,

today I did a hardware upgrade, installing additional RAM and a new hard drive.
Now after booting up the system again, the nvidia driver fails to initialize on Xorg startup with various errors, means on each startup a bit different things happen:

* it takes a while, then I get an "out of range" on the DFP and it goes into powersaving, leaving the keyboard dead for anything other than sysrq+reisub
* it takes a while until the X server crashes and I'm back on the fb console (attached that one)
* I just get a black screen with a not-blinking cursor in the top-left edge, keyboard dead.

Currently I'm using "nv" driver, so basically the card works in 2D at least. Kernel and nvidia driver version remained unchanged actually, but I tried an older kernel too without success.

I have no idea whatsoever is going on. The new RAM is fine, I touched the metal heater before touching the PC, so I don't think I broke the video card. I also tried disabling TwinView etc.. no go.

Any help would be appreciated.

Thanks!

gimpel 01-07-09 06:02 PM

Re: Driver fails with different errors (WAIT, DVC error etc)
 
PS: here is a bit of log with those DVC errors and DPMS failing (not in the above nvidia-bug-report, as said it acts different from try to try...)

Code:

(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
(II) NVIDIA(0):    may not be running or the "AcpidSocketPath" X
(II) NVIDIA(0):    configuration option may not be set correctly.  When the
(II) NVIDIA(0):    ACPI event daemon is available, the NVIDIA X driver will
(II) NVIDIA(0):    try to use it to receive ACPI event notifications.  For
(II) NVIDIA(0):    details, please see the "ConnectToAcpid" and
(II) NVIDIA(0):    "AcpidSocketPath" X configuration options in Appendix B: X
(II) NVIDIA(0):    Config Options in the README.
(WW) NVIDIA(0): WAIT (0, 6, 0x8000, 0x00000500, 0x00000500)
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(WW) NVIDIA(0): WAIT (0, 1, 0x8000, 0x000005bc, 0x000005bc)
(EE) NVIDIA(0): Error setting DVC.
(II) Loading extension NV-GLX
(WW) NVIDIA(0): WAIT (0, 11, 0x8000, 0x00000b24, 0x00000b24)
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(WW) NVIDIA(0): WAIT (0, 6, 0x8000, 0x00001070, 0x00001070)
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(**) Option "CoreKeyboard"
...[input stuff]...
(II) NVIDIA(0): Initialized GPU GART.
(WW) NVIDIA(0): Failed to set DPMS to on for LG L226W (DFP-0)
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
..[repeated some hundret times]...


gimpel 01-07-09 08:13 PM

Re: Driver fails with different errors (WAIT, DVC error etc)
 
OK, as enough disk space was available, I installed OpenSUSE 11.1 on that new disk, using the 177.x nvidia drivers from the repository, and.. damn.. same issue there.

So, I guess somehow the card is b0rked.

Now, any idea on what could be the issue? Is it possible to reflash the BIOS?
Other than completely powering off the box the first time in about 10 months, I didn't do anything unusual when installing the new hardware o.O

Le_Pedagogue 01-08-09 09:40 AM

Re: Driver fails with different errors (WAIT, DVC error etc)
 
I have the exact same problem! I'm running 64-bit Debian Lenny and I just installed some extra RAM on my computer. Now X won't start properly using the "nvidia" drivers (I've been using the 173.x drivers from Debian's repository, and they worked just fine when I only had 2 GB of RAM installed), so I had to switch to the "nv" drivers to be able to start an X server.

Help appreciated!

Le_Pedagogue 01-08-09 09:55 AM

Re: Driver fails with different errors (WAIT, DVC error etc)
 
1 Attachment(s)
Attached bug report log.

gimpel 01-08-09 04:55 PM

Re: Driver fails with different errors (WAIT, DVC error etc)
 
1 Attachment(s)
Le_Pedagogue, you attached the log generated with "nv" driver. You need to generate it after the nvidia crash, but before you start X with nv. E.g. boot into init 3 instead of 5 (no idea how debian's runlevels look like).

Today I bought a new device, a 8500 GT.

Now guess what...
Similar issues, just that it always acts the same: xorg starts, screen goes black, with non-blinking cursor in upper left.

Attached is output from the brand-new 8500 GT on my Gentoo box with 180.22 drivers.
I also tested on OpenSUSE 11.1 with 177.x, same result.

PS: I forgot to mention that I tried removing the new additional 4GB RAM, but the problem remained, so I suspected my video card was broken. Now with the new card also not working in a similar fashion, I have no idea what's wrong...

gimpel 01-08-09 06:59 PM

Re: Driver fails with different errors (WAIT, DVC error etc)
 
OK, I don't know what to think, what to check else.. the motherboard/pci-e slot seems fine, the RAM is fine, the new video card is fine, and lol, the old also still works. But only with

Code:

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
└ lsmod
Module                  Size  Used by
nouveau              245440  1
drm                  173696  2 nouveau

the nouveau driver. Unfortunately that one's still a bit buggy and doesn't support tv-out yet, which I really need.

So, I'm out of ideas... what the heck could be the cause for the nvidia driver to fail, while anything else works?

Le_Pedagogue 01-09-09 04:23 PM

Re: Driver fails with different errors (WAIT, DVC error etc)
 
1 Attachment(s)
Ooops. Here's the bug report log from an attempted 177.xx install from Debian repository.

gimpel 01-10-09 11:29 AM

Re: Driver fails with different errors (WAIT, DVC error etc)
 
Woohoo.

A Motherboard BIOS update solved it here!

Le_Pedagogue 01-12-09 07:25 PM

Re: Driver fails with different errors (WAIT, DVC error etc)
 
Quote:

Originally Posted by gimpel (Post 1899392)
Woohoo.

A Motherboard BIOS update solved it here!

Thanks for the tip! After a BIOS upgrade I was able to install the latest drivers without any problems.


All times are GMT -5. The time now is 12:10 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.