nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   setting VDPAU_TRACE and VDPAU_NVIDIA_DEBUG causes vdpau to fail? (http://www.nvnews.net/vbulletin/showthread.php?t=126121)

shepmaster 01-11-09 07:43 PM

setting VDPAU_TRACE and VDPAU_NVIDIA_DEBUG causes vdpau to fail?
 
Hey all, I have a crash when using MythTV with vdpau. I compiled Myth with debugging and saw that the crash occurs inside libvdpau_nvidia. I set

Code:

export VDPAU_TRACE=1
export VDPAU_NVIDIA_DEBUG=3

But setting these causes Myth to fail vdpau init. Is there some variant I can use that will only enable a version of vdpau that will have debugging symbols, without any other changes?

Running driver version 180.22.

shepmaster 01-11-09 08:20 PM

Re: setting VDPAU_TRACE and VDPAU_NVIDIA_DEBUG causes vdpau to fail?
 
1 Attachment(s)
Quote:

Originally Posted by shepmaster (Post 1900552)
Code:

export VDPAU_TRACE=1
export VDPAU_NVIDIA_DEBUG=3


It seems that specifically VDPAU_TRACE causes the failure. I've attached the trace to this post.

Stephen Warren 01-12-09 12:08 PM

Re: setting VDPAU_TRACE and VDPAU_NVIDIA_DEBUG causes vdpau to fail?
 
I don't see any crash here; just MythTV deciding not to use VDPAU for some reason.

None of the VDPAU APIs are returning any error. It looks like this is a pure MythTV problem. You should probably ask about this on the MythTV forums/mailing-list/...

Sorry I can't help more.


All times are GMT -5. The time now is 09:14 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.