nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   7.1 performance (http://www.nvnews.net/vbulletin/showthread.php?t=126228)

jfnvf378 01-13-09 07:29 PM

7.1 performance
7.1-Pre-Release was working just fine, however once I upgraded to the full release performance dropped significantly and X is now taking up 35% WCPU in top all of the time.

I hadn't made any changes to xorg.conf
Did a kldunload nvidia and make deinstall on the nvidia-driver port (177.80), then rebuilt it with make clean && make install.

That didn't improve anything, so I removed the port again, downloaded the source for 180.22 and installed it. Still no improvement.

What's odd is the release of 7.1-PRE was only a couple of weeks older than 7.1-STABLE and it worked fine. Any ideas on what might have changed that would drop the performance so much?

edit to add:
CPU: Phenome 9600 quad core
Motherboard: M3N78-EMH
Graphics: Built-in GeForce 8200
using 32 bit freebsd 7.1-RELEASE

rnejdl 01-13-09 08:28 PM

Re: 7.1 performance
This is just throwing stuff out there but sometimes when I've upgraded systems and something weird comes up, I've had to rebuild all my ports. I am not seeing anything like this. Firefox is generally my biggest CPU eater. 180.22 is running fine and I just upgraded last week to RELENG_7 which isn't exactly 7 release.

Rusty Nejdl

sillium 01-14-09 09:23 AM

Re: 7.1 performance

maybe you'd like to try this:
nvidia-settings -a PixmapCache=1 -a PixmapCacheRoundSizeKB=4

Works pretty well for my 8600GT's since the 180.xx drivers got released.
7.1 prerelease as well as RELENG_7 (latest stable).

jfnvf378 01-14-09 09:34 AM

Re: 7.1 performance
Thanks for the suggestions

Upgraded to RELENG_7 and rebuilt the system and all of the xorg ports, no change.

Though I think I found a clue to what is going on, if I run X as root there is no performance problem and Xorg sits at 0.00% most of the time, run as a regular user performance is still terrible and 30-40% WCPU.

chmod +s /usr/local/bin/enlightenment_sys
This file hadn't changed, so I have no idea why it would suddenly need to be suid, but the problem went away.

rnejdl 01-14-09 03:46 PM

Re: 7.1 performance
Ok, now that's interesting since startkde does not have the setuid flag. What is enlightenment doing that it needs that? Or do you not have the suid flag on the X binary?


All times are GMT -5. The time now is 12:02 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.