nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Random contents displayed upon KDM Startup in 180.22 driver (http://www.nvnews.net/vbulletin/showthread.php?t=126324)

raddy 01-15-09 07:51 AM

[Bug] Random contents displayed upon KDM Startup in 180.22 driver
 
Hello Everybody

I am using Nvidia 9300GS equipped laptop.
Upon KDM Startup in OpenSUSE 11.1 instead of black, Random contents gets displayed briefly.

Anybody else experiencing this issue?

Is there a work-around?

tonz 01-15-09 03:58 PM

Re: Random contents displayed upon KDM Startup in 180.22 driver
 
Quote:

Originally Posted by raddy (Post 1903431)

I am using Nvidia 9300GS equipped laptop.
Upon KDM Startup in OpenSUSE 11.1 instead of black, Random contents gets displayed briefly.

Anybody else experiencing this issue?

same here on a desktop with 8600GT. Additionally after a random amount of time opengl applications (e.g. the opengl screensaver) start to stutter. If I restart them they run fine again for a while.

Cheers,
tonz

elsewhere 01-15-09 04:53 PM

Re: Random contents displayed upon KDM Startup in 180.22 driver
 
I had that problem with the 180.xx drivers and openSUSE 11.0/11.1. Graphical artifacts and "ghost" images of previously rendered images. It would happen at KDM startup, and then when KDE was loading. Never lasted more than a second or so.

Bizarrely, it only happened when using the openSUSE-branding theme for KDM in KDE4. When I replaced that with the upstream-branding (basically the default KDM theme that ships with KDE4), it stopped happening.

Never happened with the previous drivers and openSUSE, and yet only happens with the openSUSE theme, so I'm not sure where the fault may lie.

Cheers,
KV

xin44 01-15-09 08:33 PM

Re: Random contents displayed upon KDM Startup in 180.22 driver
 
...same for me, and when corruption comes, all the corrupt areas are fill in with those graphical artifact.

raddy 01-15-09 11:02 PM

Re: Random contents displayed upon KDM Startup in 180.22 driver
 
As of my knowledge this issue occurs because of the updated nVidia driver uses InitialPixmapPlacement=2 instead of 1 i think.

This "2" option places X pixmaps in your GPU's video memory instead of the traditional system memory.

Is anybody able to revert the changes?

Lysius 01-16-09 06:43 PM

Re: Random contents displayed upon KDM Startup in 180.22 driver
 
I tested with KDE 4.1.96 on Fedora 10 and every time I log in, I can see this random content on my second monitor. On the first monitor I can see the splash screen of kde, but on the second monitor (with TwinView) either just some random colors or parts of Images that still seem to be present in video memory (e.g. the desktop from before a reboot) are displayed.

I'm not sure if it is a bug in nvidia driver or kde, but it seems as if the video memory is not initialized correctly before usage.

clarious 01-18-09 05:48 AM

Re: Random contents displayed upon KDM Startup in 180.22 driver
 
I also have problems that are related to this.

I run compiz with --loose-binding for better performance, if I don't enable indirect-rendering (thing has to pass to X server before go to screen) then windows won't automatically redraw on my screen until I pass my mouse on it, running it with indirect rendering solve this problem but compiz developers don't recommend doing this.

I hope this will get fixed in the next version together with suspend/resume problem.

Tigerw 01-18-09 06:15 AM

Re: Random contents displayed upon KDM Startup in 180.22 driver
 
1 Attachment(s)
I have the same problem with 9800GTX+.

kriko 01-18-09 09:21 AM

Re: Random contents displayed upon KDM Startup in 180.22 driver
 
Same here with 7600GT

Lysius 01-18-09 12:07 PM

Re: Random contents displayed upon KDM Startup in 180.22 driver
 
Quote:

Originally Posted by clarious (Post 1905977)
I also have problems that are related to this.

Are you sure that your problems are related to uninitialized video memory?

sl1pkn07 01-18-09 12:15 PM

Re: [Bug] Random contents displayed upon KDM Startup in 180.22 driver
 
Quote:

Originally Posted by raddy (Post 1903431)
Hello Everybody

I am using Nvidia 9300GS equipped laptop.
Upon KDM Startup in OpenSUSE 11.1 instead of black, Random contents gets displayed briefly.

Anybody else experiencing this issue?

Is there a work-around?

+1!

http://sl1pkn07.no-ip.com/imagenes/dscf4267.jpg

with 9300GS. with 7950GX2 not occur this


All times are GMT -5. The time now is 10:37 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.