nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nxtvepg as daemon = black vt's when switching from X (http://www.nvnews.net/vbulletin/showthread.php?t=126337)

tuxlin2009 01-15-09 12:35 PM

Nxtvepg as daemon = black vt's when switching from X
Hi guys!

I hope to find help here with a strange problem. Couldn't find a solution with google or by myself.

I am using an Nvidia 8500 GT in a twinview setup with the drivers of Nvidia (version 177.82).
Kernel:Linux xxx 2.6.27-gentoo-r7 #3 SMP PREEMPT Sat Jan 3 22:47:29 CET 2009 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ AuthenticAMD GNU/Linux

Last week i bought a tv card (Lifeview FlyVIDEO3000) with remote control.
It worked very good until i started to put nxtvepg into an (selfmade) init script for background epg data acquisition.

My problem is that when nxtvepg is started via default runlevel, switching from X to console, or ending X results in out of sync displays. (One is normal to switch off, but the first one should stay active). I can't tell what happens then because not even the osd of the displays work anymore.

It's no freeze because i can switch back to X or i can blindly type in startx and get back into X.

What have i tried so far...

1.) Removed the nxtvepg init script from the default runlevel. -> Good. No problem anymore, but also no nxtvepg daemon.
2.) Changed the init script to load at last. -> Didn't solve it.
3.) Loaded the nvidia driver before the saa7134 driver for my tv card. -> Didn't solve it.
4.) Removed anything unnecessary from my xorg.conf -> Didn't solve it.

It seems that the nvidia card doesn't like when the driver of my tv card becomes active before X was started.

Any hints how i can change the init script or anything else to make it work?

If you need logfiles, configfiles to help me, please ask me.

Here is the init script.
depend() {
need modules

start() {
ebegin "Starting nxtvepg daemon for data acquisition"
start-stop-daemon --start --exec /usr/bin/nxtvepg_daemon
pidof nxtvepg >| /var/run/nxtvepg.pid
eend $?

stop() {
ebegin "Stopping nxtvepg daemon"
start-stop-daemon --stop --exec /usr/bin/nxtvepg \
--pidfile /var/run/nxtvepg.pid
eend $?



Here is the 'oneliner' to start nxtvepg:

su bill -c "/usr/bin/nxtvepg -daemon"


I made the above because i wasn't able to start nxtvepg from the init script with parameters. Maybe i am wrong but it seems to me that start-stop-daemon doesn't like parameters appended to the program afterwards.

Thanks a lot in advance for any help. :)

All times are GMT -5. The time now is 04:59 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.