nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   correct overscan nvidia ubuntu - going crazy (http://www.nvnews.net/vbulletin/showthread.php?t=126508)

dbldown768 01-18-09 12:39 PM

correct overscan nvidia ubuntu - going crazy
 
I have been trying for days to correct the overscan on my tv in ubuntu. I am using an ASUS P5N7A-VM motherboard with and integrated 9300 nvidia card. The board is hooked up through my HDMI cable to my tv. My tv is a Sony KDF-55X955 which accepts up to 1080i resolution. I have tried many changed to the xorg.conf file and nothing seems to work. I have updated to the lasted nvidia drivers using Envy - which i believe is v177.

here is my current xorg.conf file: http://pastebin.com/f796ab5f7
here is a snippet from the Xorg log file
Code:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo"
(**) NVIDIA(0): Option "ExactModeTimingsDVI" "True"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Option "DynamicTwinView" "false"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):    enabled.
(II) NVIDIA(0): NVIDIA GPU MCP7A-S (C79) at PCI:3:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 62.79.34.00.00
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on MCP7A-S at PCI:3:0:0:
(--) NVIDIA(0):    SONY TV (DFP-0)
(--) NVIDIA(0): SONY TV (DFP-0): 165.0 MHz maximum pixel clock
(--) NVIDIA(0): SONY TV (DFP-0): Internal Single Link TMDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "1920x1080@60"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0):    "nvidia-auto-select".
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):    "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
(WW) NVIDIA(0): SONY TV (DFP-0)'s EDID does not contain a maximum image size;
(WW) NVIDIA(0):    cannot compute DPI from SONY TV (DFP-0)'s EDID.
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
(**) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp

here is what showed up in the Xorg.0.log when i ran the command startx -- -logverbose 6
Code:

(II) NVIDIA(0):
(--) NVIDIA(0): Connected display device(s) on MCP7A-S at PCI:3:0:0:
(--) NVIDIA(0):    SONY TV (DFP-0)
(--) NVIDIA(0): SONY TV (DFP-0): 165.0 MHz maximum pixel clock
(--) NVIDIA(0): SONY TV (DFP-0): Internal Single Link TMDS
(--) NVIDIA(0): SONY TV (DFP-0): Native FlatPanel Scaling is supported
(--) NVIDIA(0): SONY TV (DFP-0): DFP modes are not limited to 60 Hz refresh
(--) NVIDIA(0):    rate
(--) NVIDIA(0): SONY TV (DFP-0): DFP is not internal to notebook
(--) NVIDIA(0):
(--) NVIDIA(0): --- EDID for SONY TV (DFP-0) ---
(--) NVIDIA(0): EDID Version                : 1.3
(--) NVIDIA(0): Manufacturer                : SNY
(--) NVIDIA(0): Monitor Name                : SONY TV
(--) NVIDIA(0): Product ID                  : 504
(--) NVIDIA(0): 32-bit Serial Number        : 16843009
(--) NVIDIA(0): Serial Number String        :
(--) NVIDIA(0): Manufacture Date            : 2004, week 0
(--) NVIDIA(0): DPMS Capabilities            :
(--) NVIDIA(0): Prefer first detailed timing : Yes
(--) NVIDIA(0): Supports GTF                : No
(--) NVIDIA(0): Maximum Image Size          : 0mm x 0mm
(--) NVIDIA(0): Valid HSync Range            : 15.0 kHz - 46.0 kHz
(--) NVIDIA(0): Valid VRefresh Range        : 59 Hz - 61 Hz
(--) NVIDIA(0): EDID maximum pixel clock    : 80.0 MHz
(--) NVIDIA(0):
(--) NVIDIA(0): Detailed Timings:
(--) NVIDIA(0):  1920 x 1080 @ 60 Hz
(--) NVIDIA(0):    Pixel Clock      : 74.25 MHz
(--) NVIDIA(0):    HRes, HSyncStart : 1920, 2008
(--) NVIDIA(0):    HSyncEnd, HTotal : 2052, 2200
(--) NVIDIA(0):    VRes, VSyncStart : 1080, 1084
(--) NVIDIA(0):    VSyncEnd, VTotal : 1094, 1124
(--) NVIDIA(0):    H/V Polarity    : +/+
(--) NVIDIA(0):    Extra            : Interlaced

from this debug log i created the following log line:
Code:

Modeline "1920x1080@60" 74.25 1920 2008 2052 2200 1080 1084 1094 1124 +hsync +vsync
however, no matter how i put it in the xorg.conf file, i can never get the screen right. It seems to not find this configuation anywhere.


All times are GMT -5. The time now is 01:27 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.