nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia OpenGL borked since 180.22 (http://www.nvnews.net/vbulletin/showthread.php?t=127439)

afxmac 02-03-09 07:16 AM

Nvidia OpenGL borked since 180.22
 
Applications that happily ran on 172.88 now break with errors in the GL libraries of 180.22 onwards (tried up to 180.27).
Most notably the public preview of Bibble 5.

cheers
afx

gersoid 04-24-09 01:03 PM

Re: Nvidia OpenGL borked since 180.22
 
I am seeing exactly the same issue. have had to roll back to 1.73 to be able to use bibble 5. Ubuntu 8.10 and fedora core 10 both affected.

AaronP 04-24-09 05:21 PM

Re: Nvidia OpenGL borked since 180.22
 
Thanks for reporting this. I reproduced the problem and filed a bug. You can work around this by disabling Bibble 5's custom malloc implementation:
Code:

cd /opt/bibble5pro/lib
mv libtcmalloc.so libtcmalloc.so.original
touch libtcmalloc-dummy.c
gcc -o libtcmalloc.so -shared libtcmalloc-dummy.c

This forces Bibble 5 to use the malloc implementation in glibc.

alex31 04-27-09 03:30 AM

Re: Nvidia OpenGL borked since 180.22
 
Quote:

Thanks for reporting this. I reproduced the problem and filed a bug. You can work around this by disabling Bibble 5's custom malloc implementation:
This solution is NOT approved neither supported by bibble5 team which tell that bibble5 reliability is bad if tcmalloc is not enabled.

I hope that a solution will be found that enable the use of tcmalloc with latest nvidia driver.

I am opengl app developer, and i don't want to have to choose between being able to develop opengl 3.0/ glsl 1.30 app, and run bibble5.

Alexandre

zander 04-27-09 10:47 AM

Re: Nvidia OpenGL borked since 180.22
 
As Aaron said, a bug has been filed and will be investigated. The workaround is just that - a way for users to enable use of Bibble 5 with current NVIDIA graphics driver releases; it is not intended as a long-term solution.

fred106 05-13-09 12:56 PM

Re: Nvidia OpenGL borked since 180.22
 
Hi Aaron,

I tried what you proposed, but it is not working, bibble still does not start.

Thanks for your help,

afx 05-14-09 09:50 AM

Re: Nvidia OpenGL borked since 180.22
 
180.60 seems to fix this nicely.

thx
afx


All times are GMT -5. The time now is 09:40 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.